USB Gamepad not detected


I have an USB arcade stick to play fighting games. It works out of the box on Windows 10 but it does not seem to be detected on my Manjaro.

It doesn’t appear on ‘‘lsusb’’ command output and nothing in /dev/input as well.

I followed the official Gamepad page in ArchWiki.
My user is in the input group, I modprobe ‘analog’, ‘usbhid’ and ‘joydev’ modules.

I also have a wired Xbox 360 controller that works just fine.

I tried kernel 5.10 and 5.11 but it doesn’t change anything.

Any ideas ?

What’s the brand name and does their web site mention they’re Linux compatible?

Why, oh why???

Unfortunately, there is still a bunch of hardware out there that’s not Linux compatible…


It’s a MC Cthulhu from Toodles that I bought a decade ago. Their website is now dead but I managed to find it on the wayback machine. The manual just says “PC compatible”… (it’s supposed to be compatible with PC and PlayStation 3).

I guess I’ll just have to cry and dual-boot on Windows 10 to use it.


1 Like

Alternatively, get one that works on Linux. It’s been a long time, but I used to use a Mayflash F300 on Manjaro without issues. Don’t know if the F500 works or not.

1 Like

I made some progress. All hope is not gone !

My motherboard has USB2 and USB3 ports. I always use USB3 for everything.
Last night I tried to plug my device in an USB2 port and an almost miracle happened !

dmesg command output is now showing this :

[ 73.950708] usb 2-1.2: new full-speed USB device number 3 using ehci-pci
[ 74.102808] usb 2-1.2: New USB device found, idVendor=14d8, idProduct=00ce, bcdDevice= 1.06
[ 74.102811] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 74.102812] usb 2-1.2: Product: Cthulhu Mult
[ 74.102813] usb 2-1.2: Manufacturer: Toodles 2008
[ 74.104442] input: Toodles 2008 Cthulhu Mult as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/0003:14D8:00CE.0006/input/input37
[ 74.104749] hid-generic 0003:14D8:00CE.0006: input,hidraw3: USB HID v1.11 Gamepad [Toodles 2008 Cthulhu Mult] on usb-0000:00:1d.0-1.2/input0
[ 74.427193] usb 2-1.2: USB disconnect, device number 3

Sadly as you can see at the last line, my device is disconnected right away :neutral_face:

1 Like

It’s a nightmare ! :laughing:

I’ve done 20-25 reboots with different usbcore module settings found online and I got my device to work 2 times when it was plugged in at boot time.
Rebooting again and/or hot plugging it and it stops working with the same dmesg message as above.

I’m sorry, but you’re:



:sob: :man_shrugging:

Less sorrow, pain, frustration, time lost, … and as per @realmain 50$ just works, so if you’ve spent >5 hours on this you’re making less than minimum wage trying to have this piece of $hit incompatible gamepad behave!

:+1: :crossed_fingers:

Welllllllll, I am just going to put a disclaimer. I haven’t used a Mayflash F300 in 3-4 years, I don’t know if anything happened between then and now that might make it not work.

That being said, it worked GREAT when I used to use it for fighting games on Manjaro.

Per this person on /r/linux_gaming 6 months ago:

Mayflash F300? Works well. I use it often on Linux, never had a problem with any game on Manjaro.

I also heard that the 8Bitdo Arcade Stick works too. I haven’t tried it myself, you should research it first.

8Bitdo themselves said it works with a Raspberry Pi 4 (in the Amazon Q&A section), which means it should work on a x86-64 distro too.

I think you’re right. This madness has to stop :upside_down_face:
At least I tried everything I can.

I don’t want to change the whole arcade stick because it’s an expansive one (with high quality buttons).
The “piece of #&@%” hardware is the PCB inside it.

The most famous/expansive one is the “Brook Universal Fighting Board” but I don’t know if it works.
At least this brand is still alive as well as their website. I’ll ask them directly and post the answer here if someone needs it.

Thank you again for your support. I felt less alone in the dark :sweat_smile:

1 Like


I finally bought the “Zero-Pi Fighting Board EASY” from Brook accessory since it officially supports raspberry pi.
Guess what, it works out of the box ! :partying_face:
The only thing odd is that the select/back/share button does not work at all (it works flawlessly on Windows). Glad I never use it in all my fighting games.

Steam does not recognize the gamepad so I had to install xboxdrv in order to make it work (no need to start/enable the xboxdrv.service).
After my device is plugged in I run the following command :

xboxdrv --evdev /dev/input/by-id/usb-Brook_ZERO-Pi_Fighting_Board_000000000002-event-joystick --evdev-absmap ABS_HAT0X=DPAD_X,ABS_HAT0Y=DPAD_Y --evdev-keymap BTN_TL=LT,BTN_TR=RT,BTN_EAST=A,BTN_C=B,BTN_SOUTH=X,BTN_NORTH=Y,BTN_TR2=Start,BTN_TL2=Back,BTN_MODE=Guide,BTN_WEST=LB,BTN_Z=RB --mimic-xpad --trigger-as-button --detach-kernel-driver --silent

Then a Steam pop-up shows up telling that a xbox 360 controller has been connected :partying_face:

If you see two controllers connected in the Steam configuration you have to remove the xpad module with ‘sudo rmmod xpad’ before lauching xboxdrv.

It still isn’t a perfect experience but it will hopefully do the trick 99% of the time :sweat_smile:

EDIT : adding ‘–detach-kernel-driver’ option to command line does the same thing as removing xpad module but way simpler :wink:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.