USB drives extremely long mounting time, super slow response time, 100% CPU usage per thread


I stumbled across some very unusual issue with my USB drives.

  1. I utilize Evolveo Tiny 5 external frame case which allows me to connect my good-old 4TB 3.5" HDD via USB 3.0 to my laptop. It tends to work quite well, but there is an issue with incredibly long mounting time (up to 10 seconds) while one of my CPU threads sky-rockets up to stable 100% usage. I also noticed it tends to happen sometimes after copying or even simple browsing via folders, which consequently leads to the freeze of Dolphin and there is no other way than disconnecting the HDD manually and try again fresh.

  2. To counter this issue I decided to buy myself Adata SE800 external SSD drive, which connects itself via USB-C 3.0. When I connect this unit it follows extremely similar scenario: one of my 16 threads shoots to the moon with 100% CPU usage, the USB drive’s activity diode keeps blinking as crazy and this whole thing takes up to 20 seconds before I “can” access my data. But even when I finally see my folders I cannot browse quickly as even simple loading of folders again takes whole 100% of one of my threads, the unit becomes un-responsive and sometimes I even have to disconnect it manually and try again to get it somehow working.

There is something seriously wrong with my USB 3.0 ports, there is no doubt now. I tried to add noatime, discard options while mounting both my USB drives but it did not change a thing. I also tried messing with I/O schedulers, but I ended up with non-booting system and had to switch to latest Kernel in order to get it booting again. Even simple stuff like getting the SE800 formatted takes crazy amount of time and I am not using any time-consuming methods, it just takes 100% of my CPU every single time I try to do basically anything and during the time it is totally unresponsive.

Please kindly help with this as I tried for whole day Googling for solutions, but seems like nobody ever had this issue at all. I am kinda desperate now as only my main system drive works as it should without any strange 100% CPU usage stuff. No idea why that happens whatsoever :frowning:

Thank you VERY much in advance for any advice you can think of.

P.S.: I am running latest Manjaro KDE, Kernel 5.11, nVidia proprietary drivers. The machine itself is Lenovo IdeaPad Gaming 3 15ARH05 (82EY006RCK) which is AMD Renoir platform with nVidia dGPU.

I had an issue with USB 3.0 flash drives not mounting when the drives were inserted in the USB hub. They mounted fine when inserted in the USB ports (all are 3.0) directly. I don’t know if my issue is the same as you as your drives eventually mount. I am running xfce unstable fully updated. Here is what fixed it for me:

In GRUB add to cmdline:

to check:
cat /sys/module/usbcore/parameters/autosuspend 
should return -1
default was 2

Hello Richard,

I implemented your advice but it made things much worse, I could not even boot again properly without going through emergency mode and even then after firing-up “startx” my battery was not detected and other USB devices such as my USB audio card were not recognized at all. I had to revert it all back and now the situation is as described before: very long mounting of both my USB drivers, and I even noticed that my SE800 SSD is not even writable, once it finally mounts it is read-only.

What a mess to be honest. I just tried with my other laptop also equipped with AMD processor + graphics and the behaviour is 100% the same. Right now it seems like some AMD issue. Will investigate more in the morning.

// EDIT:

Allright, so there is still hope yet. I just spent some time Googling for something like “AMD Lenovo USB issues” and there are quite many instances where users are having issues with their USB ports. Mostly random disconnection or pure malfunction, so it is somewhat similar to what I am experiencing personally now.

I noticed there is a new BIOS for my laptop mentioned above:

… so I will definitelly try and update it later today, now I need to get some sleep as I am really done for today :slight_smile: However, if you have any idea how to fix it now, please let me know so that I can test it out. But it really seems now that the whole USB thing is kinda messed-up on this platform, let’s hope developers can find a fix rather sooner than later.

1 Like