USB drive formatting stalls at 33%

I have an HP v236w 32 GB USB drive that was using ntfs but which suddenly could not be mounted.

So, I tried formatting it to ext3 instead.

But the

KDE partitionmanager stalls at 33% as shown in attached screenshot.

I suspect that the USB drive most likely has a hardware/firmware problem that cannot be fixed?

Or can I re-partition it into two partitions and thereby salvage it? Any workarounds please?


Most likely - yes! If it has stalled once, very likely to happen again, buy a new one.

You can try to dd the first part of the stick
dd bs=512 count=1024 if=/dev/zero of=/dev/sdc status=progress (MAKE SURE THE STORAGE IS STILL SDC so you don’t accidentally overwrite something else!!!)

And then manually create a partition and format (I would use exFat instead of ext3 if you want to share it with windows) in cli. That would show you more closely where it fails.

But the most likely the explanation is like above stated, the storage is F***ED.


You could also try using GParted to erase and repartition the USB. If you encounter obvious errors with that, then the media is likely bad.

1 Like

You can try and salvage, but I see that a 32GB flash drive can be had for less than $10 so keeping this sure to fail soon drive seems like false economy

Thanks for suggesting gparted, @soundofthunder. Its progress messages are more informative than KDE’s partitionmanager.

The first time, making the ext3 failed with this message:

**mkfs.ext3 -F -L 'MUSIC-32' '/dev/sdd1'  00:00:00    ( ERROR )**
mke2fs 1.47.0 (5-Feb-2023)
/dev/sdd1 is mounted; will not make a filesystem here!

I then looked at KDE systemsettings and found that I had ticked the option shown here:
and that was the cause of the error.

After I unchecked the box, the formatting could proceed to successful completion but it took a very long time.

In the end the USB stick worked.

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.