USB-disconnect error: "Synchronize Cache(10) failed:"

Hi everybody,

just recognized an unknown error, as i checked my actual log with journalctl -f.

When i unmounted my Backup-USB-disk with unmount /path/to/disk and then pulled the cable out, a short unhealthy noise occured inside the USB-disk. Wasn’t the first time.

I checked the log (for another reason) and found following lines:

Aug 02 23:41:19 USER kernel: usb 4-1: USB disconnect, device number 2
Aug 02 23:41:19 USER kernel: sd 2:0:0:0: [sda] Synchronizing SCSI cache
Aug 02 23:41:19 USER kernel: sd 2:0:0:0: [sda] Synchronize Cache(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK

Does anybody know, what this is about? Searched the Web on a quick try, but couldn’t find anything concrete; just that it may be a bad sign for my USB-drive.

Would be nice to know, because the USB-drive is used on my daily Cron-job for backing up my home directory with different snapshots.


You heard a noise and are getting errors? That’s all I need to know, backup your data and get a new drive. It’s only a matter of time.

1 Like

maybe the drive is running on his last Bytes, but on the other side, it is only a few years old and seldomly used, so i would like to give it another try.
When i unmount the drive, it keeps summing like it’s still working. After up to 30 minutes the summing noise stops. If i pull the cable then, it doesn’t make this awful noise. So maybe it’s still working with the cache after i run umount, but 30 minutes seem very long. Therefore i tried running sync before unmounting, but didn’t change anything.
Does anyone know how to disable the drives cache completely? Want to test if this may change something.

Are you referring to the write buffer?

If so, look into the sync option when using mount or the fstab.

However, I think it’s best to consider this external USB drive as dead. I wouldn’t trust it to keep my data safe.

If you’re referring to the drive’s own internal cache, then I’m not sure that’s possible, since it’s at the firmware-level.

Again, regardless, not worth it in my opinion.

That doesn’t matter. Digital storage and disk drives are not like lightbulbs.

did you wait for the command to finish? … the prompt is back …

but that noise you describe, together with:

Aug 02 23:41:19 USER kernel: sd 2:0:0:0: [sda] Synchronize Cache(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK

points to a faulty drive


sorry for the late response, was busy.

Yes, tried it in fstab and manually with sync [device]—didn’t worked out.

Just gave sdparm a try and disabled Write Cache—but also no positive result…

Yes, of ourse. The prompt is back after half a second, but the dirve sounds like it keeps working for about 30 minutes. Also waited that span and pulled it out afterwards. Didn’t changed the result either.

So, it seems i have to accept that the drive will be gone in the near future. I’m going to buy a new one.

Thanks for your help. Any advices for a good SSD USB drive with 0.5 to 1 TB space? Shouldn’t be too expensive—maybe up to 80–100 Euros…


For all intents and purposes, it is “gone”. If you don’t have any backups of the data the currently resides on it, I would make a read-only drive image of if using ddrescue that you can later use in the future if you need to try to recover data. I say this because it’s within plausibility for the drive to catastrophically fail when you attempt to do a massive copy operation from the old drive to the newly-purchased drive.