USB devices over thunderbolt dock not working

Okay so I am currently running KDE Neon (simply Ubuntu with KDE nothing special) and I am planning to switch over to Manjaro Gnome as soon as I get my new laptop. My current laptop has thunderbolt 3 which I use connect to a thunderbolt dock to connect a second monitor, a keyboard, a mouse, headset, etc to my laptop at once. This works without any issue till now. Now I got myself a USB stick and booted Manjaro from my current laptop to test everything that I want to use on my new laptop (the new one is basically the same, just newer processor).

Now to my problem:

  • When I connect my laptop to my dock the monitor switches over without any issue. And PowerDelivery is working too. But my external keyboard is not lighting up, my external mouse is working, my headset is not available. Basically everything connected to my dock over USB is not working. Entering lsusb in the terminal does not show up any of my devices (like they wouldn’t be connected at all). I do have authorized the dock in the gnome settings and even boldctl is showing that the dock is authorized and connected.

What I tried so far:

  • Several disconnects / reconnects, restarts of Manjaro
  • disabling tlp
  • setting usbcore.autosuspend to -1

I have no clue what I could try else. If anyone on here could help me out, I would be very thankfully. I really do need to support for using all of these devices otherwise I am forced to continue using KDE Neon.

1 Like

For me usb peripherals on the Thunderbolt dock only work when I boot up connected to the dock. Plugging the dock with the OS running indeed fails to detect the usb devices. Haven’t spend time trying to diagnose the issue.

okay so I tried that out but it seems like nothing have changed other than that my wifi module is not getting recognized anymore (for me this seems more of like a hardware issue because I am seeing that on KDE Neon too, so I wouldn’t worry about it that much at this point). I also just tried to use it with direct access disabled, which also didn’t changed anything to my current situation.

I use a Dell D6000 with varied success. This is a pretty well known issues that is also discussed in Arch forums as well that the limitation is really you must have the device plugged in on boot, a “hot” plug will not work with much success. When I do a hot plug, I sometimes get a wired internet connection to work, but most everything else doesn’t. This is especially true with a display link or HDMI external monitor.