USB DAC(FiiO BTR5) randomly disconnecting and playing static on bootup

Hi guys, I am new to Manjaro and linux on a whole. I decided to make the switch when windows was using 6GB of RAM while on idle.

I have been loving manjaro so far. Having tested out Ubuntu before this, I much prefer the kde layout that I chose over the GNOME layout of Ubuntu but there have been a few things that are going wrong.

I have a USB DAC, the FiiO BTR5, connected to my headphones(SHP9500) and when I don’t play any audio for around 2 min or more, the DAC stops appearing in the outputs section and I have to unplug and replug it back in for manjaro to recognise it and start playing to it again. Also when I boot up manjaro sometimes(I am dual-booting windows and manjaro with grub), my headphones just play constant static noise and I have to unplug and replug the DAC to stop this. I don’t believe it is the DAC since it works perfectly in windows 10 and Ubuntu 20.04 and I tried multiple USB ports (C,3.1,3,2) and the issue still occured on all of them.

I also installed manjaro KDE on my laptop(Lenovo thinkpad T14s) and had the same issue but sometimes the DAC automatically reappeared after 3 seconds of static noise. I also tried on EndeavourOS to see if it was just manjaro but no it happened there as well

I am loving Manjaro so far but this audio problem wouild be a massive dealbreaker for me and I don’t want to switch from Manjaro which I have only been using for roughly a week now.

Welcome to Manjaro

I think you have 2 issues that you would probably find on a lot of versions of Linux
If they can be resolved on Manjaro KDE they should also help with other Linux distributions

Check that Fast Startup (hybrid hibernation) is turned off in the other OS
How to disable Windows 10 fast startup (and why you’d want to) | Windows Central
Manjaro might be unable to initialise the DAC correctly from hybrid hibernation state

This is probably due to PulseAudio module module-suspend-on-idle disconnecting PulseAudio when no audio streams are playing

Use this command to remove the module temporarily

pacmd unload-module module-suspend-on-idle 

If removing the module works for you, PulseAudio configuration can be changed to disable the module permanently

sudo sed -Ei '/load-module module-suspend*/s/^/#/' /etc/pulse/

This adds a comment tag ‘#’ to the start of the line to prevent the module being loaded

1 Like

Thank you for the reply!

The disabling of the pulseaudio module has completely fixed the problem of my DAC disappearing.

The only problem now is that my DAC isn’t recognised on bootup even though I disabled fast startup on windows. I have to unplug and replug it for it to come on. What should I do and is there any info you require?

Check if the DAC is detected as a USB device and an audio playback device in ALSA

lsusb && aplay -l

If the DAC is detected as a Playback Device in ALSA, check if PulseAudio has any error messages

systemctl --user -l --no-pager status pulseaudio*

And restart PulseAudio

systemctl --user restart pulseaudio

Hi, the first line shows me that my DAC is detected as both a USB and playback device
When I run the second line, I get some errors

Mar 09 19:52:42 Irodi-Linux pulseaudio[1540]: Failed to find a working profile.
Mar 09 19:52:42 Irodi-Linux pulseaudio[1540]: Failed to load module “module-alsa-card” (argument: "device_id=“4” name=“usb-Generic_USB_Audio_201405280001-00” card_name=“alsa_card.usb-Generic_USB_Audio_201405280001-00” namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties=“module-udev-detect.discovered=1"”): initialization failed.

What should I do from here?
I restarted pulseaudio but that issue kept coming up whenever I restarted my pc