USB-C to HDMI Not Working With Dual Intel/Nvidia Laptop

I recently switched from Ubuntu to Manjaro on my 2020 Razer Blade Stealth 13". I have an Anker USB-C to HDMI Adapter (Model A8312) that I had previously been using on Ubuntu with no issues. However, when I use it on Manjaro it does not work.

I followed the Arch wiki instructions for setting up DisplayLink, but no luck.I tried all 3 evdi packages that are listed in step 1.2 of the wiki. I do get an error at step 1.3

Output from running xrandr --listproviders

Providers: number : 2
Provider 0: id: 0x40 cap: 0x2, Sink Output crtcs: 1 outputs: 1 associated providers: 0 name:modesetting
Provider 1: id: 0x1d9 cap: 0x0 crtcs: 0 outputs: 0 associated providers: 0 name:NVIDIA-G0

Based on that output, I ran xrandr --setprovideroutputsource 0 1 to connect provider 0 (modesetting) to provider 1 (Nvidia GC). However, that results in this error:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  35 (RRSetProviderOutputSource)
  Value in failed request:  0x1d9
  Serial number of failed request:  16
  Current serial number in output stream:  17

I did try loading the udl kernel module via modprobe udl as suggested in the wiki, but nothing changed.

Also, at no point do I see a second display in the display settings, or another frame buffer in /dev/ other than /dev/fb0 which I assume is the frame buffer for my laptop screen.

I can see that the USB device is recognized (result of dmesg when plugging/unplugging adapter) :

 2740.735302] usb 3-3: new full-speed USB device number 7 using xhci_hcd
[ 2740.894598] usb 3-3: not running at top speed; connect to a high speed hub
[ 2740.912308] usb 3-3: New USB device found, idVendor=0bda, idProduct=2172, bcdDevice= 1.00
[ 2740.912312] usb 3-3: New USB device strings: Mfr=17, Product=18, SerialNumber=19
[ 2740.912313] usb 3-3: Product: BillBoard Device
[ 2740.912314] usb 3-3: Manufacturer: Realtek
[ 2740.912315] usb 3-3: SerialNumber: 00000000000000000
[ 2742.926623] usb 3-3: USB disconnect, device number 7

Some other info that may be helpful: This laptop has integrated intel graphics as well as an Nvidia GeForce GTX 1650 Ti Mobile. I installed video-hybrid-intel-nvidia-470xx-prime using mhwd and after several attempts to get the laptop to boot I ended up needing to add nomodeset to the kernel parameters. I am using Gnome.

I suspect it has something to do with my graphics drivers but I’m not sure what. I’d appreciate any help I can get here, I’d really like to continue using Manjaro but if I can’t connect to a second monitor I’ll probably need to go back to Ubuntu. Also, apologies if I didn’t make anything clear or missed some information. I used Arch extensively about 5 years ago, but have just been using Ubuntu or Windows since so I’m pretty rusty :slight_smile:

Nvidia is doing their own thing - not always compatible with edge Linux - one suggestion is to use the nvidia dkms package - not that it comes with any warranties - but …