USB Bose speakers not outputting sound

Hi guys,

New to manjaro and am enjoying it.

Right now im trying to get my bose speaker connected via usb to output audio but according to aslamixer it’s being interpreted as a sound card and no audio is being outputed

I’ve tried to edit the and client.conf in /etc/pulse but no luck.

Any ideas


Welcome to Manjaro forum

Please post more information about system hardware

inxi -Fazy --no-host

and more information about PulseAudio

pacmd dump

Please use the preformatted text button </> when pasting the terminal responses

Hi Mate


inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.12.1-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 
  root=UUID=d2f1e0d7-41e3-4e38-bce5-dbbac2caf899 rw quiet udev.log_priority=3 
  Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 
  dm: SDDM Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: Micro-Star product: MS-7B98 v: 1.0 serial: <filter> 
  Mobo: Micro-Star model: Z390-A PRO (MS-7B98) v: 1.0 serial: <filter> 
  UEFI-[Legacy]: American Megatrends v: 1.70 date: 08/13/2019 
  RAM: total: 15.57 GiB used: 2.98 GiB (19.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: Intel Core i5-9600KF bits: 64 type: MCP arch: Kaby Lake 
  note: check family: 6 model-id: 9E (158) stepping: D (13) microcode: DE 
  cache: L2: 9 MiB bogomips: 44412 
  Speed: 800 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc 
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr 
  nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni 
  popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss 
  ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc 
  tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
  xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort mitigation: TSX disabled 
  Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] vendor: 
  driver: nvidia v: 460.73.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1f06 class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.0x10.7") 
  s-diag: 554mm (21.8") 
  OpenGL: renderer: GeForce RTX 2060 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl 
  bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403 
  Device-2: NVIDIA TU106 High Definition Audio vendor: 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9 
  class-ID: 0403 
  Device-3: Bose Bose Revolve SoundLink type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:7 chip-ID: 05a7:40fa 
  class-ID: 0300 serial: <filter> 
  Device-4: SYDNEY USB SYDNEY USB type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-5:4 chip-ID: 3212:1a01 
  class-ID: 0300 serial: <filter> 
  Sound Server-1: ALSA v: k5.12.1-2-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: yes 
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e 
  v: kernel port: efa0 bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Broadcom vendor: ASUSTeK driver: brcmfmac v: kernel port: 3000 
  bus-ID: 03:00.0 chip-ID: 14e4:43c3 class-ID: 0280 
  IF: wlp3s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 232.89 GiB used: 14.28 GiB (6.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 250GB 
  size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 3B6Q scheme: MBR 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 232.88 GiB size: 228.17 GiB (97.98%) 
  used: 14.28 GiB (6.3%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: d2f1e0d7-41e3-4e38-bce5-dbbac2caf899 
  Alert: No swap data was found. 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-2:2 info: Microsoft Basic Optical Mouse v2.0 type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s 
  power: 100mA chip-ID: 045e:00cb class-ID: 0301 
  Device-2: 1-3:7 info: Bose Bose Revolve SoundLink type: Audio,HID 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 2.0 
  speed: 12 Mb/s power: 500mA chip-ID: 05a7:40fa class-ID: 0300 
  serial: <filter> 
  Device-3: 1-5:4 info: SYDNEY USB SYDNEY USB type: Audio,HID 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 1.1 
  speed: 12 Mb/s power: 100mA chip-ID: 3212:1a01 class-ID: 0300 
  serial: <filter> 
  Device-4: 1-6:5 info: Holtek USB-HID Keyboard type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 04d9:0295 class-ID: 0300 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.1 
  speed: 10 Gb/s chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 32.0 C mobo: N/A gpu: nvidia temp: 34 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 227 Uptime: 1h 27m wakeups: 1 Init: systemd v: 247 
  tool: systemctl Compilers: gcc: 10.2.0 Packages: pacman: 1228 lib: 316 
  Shell: Zsh v: 5.8 running-in: konsole inxi: 3.3.04 
╭─-ms7b98 ~  
╰─➤  pacmd dump              
### Configuration dump generated at Sat May  8 20:20:58 2021

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="1" name="pci-0000_01_00.1" card_name="alsa_card.pci-0000_01_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="3" name="usb-SYDNEY_USB_SYDNEY_USB_20200521-00" card_name="alsa_card.usb-SYDNEY_USB_SYDNEY_USB_20200521-00" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="0" name="pci-0000_00_1f.3" card_name="alsa_card.pci-0000_00_1f.3" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:0 xauthority=/home/adrian/.Xauthority
load-module module-x11-xsmp display=:0 xauthority=/home/adrian/.Xauthority session_manager=local/adrian-ms7b98:@/tmp/.ICE-unix/1018,unix/adrian-ms7b98:/tmp/.ICE-unix/1018
load-module module-alsa-card device_id="2" name="usb-Bose_Corporation_Bose_Revolve_SoundLink_Q9218012609742956KD0510-00" card_name="alsa_card.usb-Bose_Corporation_Bose_Revolve_SoundLink_Q9218012609742956KD0510-00" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_00_1f.3.analog-stereo 0x8ccd
set-sink-mute alsa_output.pci-0000_00_1f.3.analog-stereo no
suspend-sink alsa_output.pci-0000_00_1f.3.analog-stereo yes
set-sink-volume alsa_output.usb-Bose_Corporation_Bose_Revolve_SoundLink_Q9218012609742956KD0510-00.iec958-stereo 0x70a4
set-sink-mute alsa_output.usb-Bose_Corporation_Bose_Revolve_SoundLink_Q9218012609742956KD0510-00.iec958-stereo no
suspend-sink alsa_output.usb-Bose_Corporation_Bose_Revolve_SoundLink_Q9218012609742956KD0510-00.iec958-stereo yes

set-source-volume alsa_input.usb-SYDNEY_USB_SYDNEY_USB_20200521-00.mono-fallback 0x10000
set-source-mute alsa_input.usb-SYDNEY_USB_SYDNEY_USB_20200521-00.mono-fallback no
suspend-source alsa_input.usb-SYDNEY_USB_SYDNEY_USB_20200521-00.mono-fallback yes
set-source-volume alsa_output.pci-0000_00_1f.3.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1f.3.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_00_1f.3.analog-stereo.monitor yes
set-source-volume alsa_output.usb-Bose_Corporation_Bose_Revolve_SoundLink_Q9218012609742956KD0510-00.iec958-stereo.monitor 0x10000
set-source-mute alsa_output.usb-Bose_Corporation_Bose_Revolve_SoundLink_Q9218012609742956KD0510-00.iec958-stereo.monitor no
suspend-source alsa_output.usb-Bose_Corporation_Bose_Revolve_SoundLink_Q9218012609742956KD0510-00.iec958-stereo.monitor yes

set-card-profile alsa_card.pci-0000_01_00.1 off
set-card-profile alsa_card.usb-SYDNEY_USB_SYDNEY_USB_20200521-00 input:mono-fallback
set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo
set-card-profile alsa_card.usb-Bose_Corporation_Bose_Revolve_SoundLink_Q9218012609742956KD0510-00 output:iec958-stereo

set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo
set-default-source alsa_input.usb-SYDNEY_USB_SYDNEY_USB_20200521-00.mono-fallback

### EOF

Yes, of course. All USB speakers (and microphones) work that way. What you have to learn is how audio routing works in KDE Plasma (which basically just a PulseAudio wrapper).

I don’t think this option below is set by default:

which is used to behave like some other OSes out there, explanation should be straightforward. Check that if you want that behavior.

Otherwise, go to previous page:

and select which device you want to use for audio output.

Also available from the volume control widget (just click it):

Hi Mate,

I’ve tried to tinker with the configuration settings as you’ve stated but still no sound

I’ve selected “play all audio through this device” and have also toggled between iec985 -stereo-output and analog in the pavu config. Not sure if its a bose soundlink specific issue.

Try checking in alsamixer, sometimes the volume at pulseaudio level doesn’t correctly reflect the actual one in the hardware. Also try playing something and check the output device tab in pavucontrol, even if you can’t hear anything, does the monitor bar shows a signal change?

Alright, I removed manjaro-pulse and ran sudo pacman -Rdd pavucontrol pulseaudio pulseaudio-alsa

Then installed pipewire and increased DB in alsamixer to 100 and everything is working LOL

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.