USB and bluetooth stop working soon after boot

Hello all. I used pamac to install all my pending updates yesterday. After rebooting, my usb mouse and keyboard, which were connected, stopped working about 10s after the login screen appeared. Reconnecting doesnt work. Later i found that my bluetooth also just stops working. As in, it says “connect bluetooth dongle”. Im using a laptop with windows 10 dual boot, and both bluetooth and my usb peripherals work fine on windows . Also while The peripherals stop working, I can still use the laptop keyboard and trackpad.

I tried changing kernels from 5.10 to 5.4 but that doesnt work. . I tried searching online for similar issues, but all I could find were problems of usb devices not working outright. For me, it does work but only for a few seconds after boot. Then its like they got disconnected.
lsusb gives ,

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID c0f4:05e0 SZH usb keyboard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Any help is appreciated. Im still not that good at using the terminal, so commands to do stuff would be really helpful. Thank you!!

Same problem for me since last update. I don’t find a solution but I think it’s because of this :

warning: /etc/tlp.conf installed as /etc/tlp.conf.pacnew

I have two tlp conf in etc.

hmm, I checked /etc. I only have /tlp.conf. I honestly dont know what it is. I have tlpui installed and all the typical culprits like us autodisable etc., are disabled.

i expect that whatever you did in the tlp.conf is without effect as it was the same here with me. I spend the last whole day and night to fix it. is the output of cat /sys/module/usbcore/parameters/autosuspend still 2 ? This means the usb-port is shutdown as soon as the port is in idle for 2 seconds. That setting is insane and causes that the devices get disconnected all the time . This tlp gets more and more worse. And i had the same problems with bluetooth, but i was able to fix it after the usb problems are fixed. impossible to get bluetooth running if the usb-plattform is so inconstitent.

Yes!! Should I change that? If so how? And did it work for you @Olli ?

I noticed that the mouse and keyboard stops working even if i just keep on zig-zagging the cursor. Or does it need ALL the ports to be under use?

yes and it worked out now ! even my apple wireless keyboard and mouse works perfect now. I have a question, do you have a usb hub with it’s own power supply that is independent from the power of the computer ? If so a quick fix is to connect this devices to this hub, that causes that it gets better but for the final fix you need to set the usbcore.autosuspend = -1 at the kernel parameters. that forces that the usb bus must disable power saving even this piece of crap called tlp tries to interfere. that’s the hard way, but the only one. afterwards you can setup bluetooth by activating it from boot and make it responsible. this is done in the main.conf of the bluetooth settings.

I tried setting


then updating grub. Still didnt work.

Also, im not using a USB hub. The ports are the inbuilt ports on the laptop.

The problem for me was TLP 1.4. As mentioned in this post:

removing tlp fixed the issue:

pamac remove --no-save tlp

@lupo2010 see if it works?


as i already explained the first step is to set autosuspend to -1. is the output of cat /sys/module/usbcore/parameters/autosuspend -1 after updating grub and rebooting -1 ? If so the usb-ports are forced to stay on and this prevents to go in energy-saving mode. the next step is to edit the /etc/bluetooth/main.conf file of the bluetooth settings. let me know if autosuspend is -1, i will post the entrys i changed in the main.conf.

these are the settings i changed at /etc/bluetooth/main.conf:
NameResolving = false
FastConnectable = true

I edited and updated grub. Checked

cat /sys/module/usbcore/parameters/autosuspend

before and after rebooting. It returned -1 both times. But the problem still persists.

yes so please edit the main.conf as described and reboot and report if there is a change. there’s also the possibility to reset this rfkill and the bluetooth-controller. i have to dig my links for it but first try to change main.conf and check for changes.

I wonder if removing tlp may occur unstability? In any case, thank you it solved the problem.

I’m a bit occupied right now, but I’ll get back to you soon :slightly_smiling_face:

Dont ignore pacnews …

PS - missing TLP probably wont make your system unstable, unless you were relying on it to keep heat down, it will just probably result in things like higher power consumption, etc.

If you dont know TLP, see here:

Editing main.conf changes nothing. Problem persists.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.