USB 3.0 Gigabit Ethernet Dongle Compatible with Raspberry Pi 4?

I’d like the ability to have a second ethernet interface running into my Pi 4, for frankly ridiculous reasons involving pi-hole hogging port 443 within docker that I’m in the mood to just throw hardware at until the problem goes away.

Is anyone using one of these adapters? What chipsets/products are supported by Manjaro’s ARM distribution?


So far every usb-ethernet adapter I have thrown at Manjaro has worked, but maybe I was just lucky. Although the last one I grabbed from a drawer at work seems to crash networkmanager occasionally…



1 Like

I have usb3 to Ethernet dongle chip used, ASIX AX88178 worked with all my devices running manjaro.

I have a clone version of Plugable USB2-E1000 both having the same chipset.

1 Like

There are too many to list. Find a dongle you like and look in the config and see if the chipset is there. If the module is not enabled (saying “is not set”) then I will enable it.

1 Like

Thanks, everybody! The UGreen will be here tomorrow.

Update: The USB NIC came today, and is working. It gets a reserved IP from the router and the traffic lights on the device light up.

A couple of questions:

  1. Is it possible to rename an interface? Right now, it’s en****u1. Very inelegant compared to eth0.
  2. Is there a way I can run a speed test from the command line while specifying a specific NIC? I’m curious about the performance differences. It’s a gigabit ethernet card, so I can’t imagine it would perform noticeably worse than the onboard interface.
1 Like
  1. Change interface name on Arch wiki
  2. You can find speedtest_cli in the repositories. Afaik it doesn’t let you select a network interface, but you can disable/enable one of your network interfaces and then run the test.
1 Like

One more question: Do I need to do anything to make sure the two interfaces don’t step on each other during normal operations? from what I can see, they just each take traffic as they have bandwidth to do so.

I ask because I have noticed a slight decrease in my speediest-cli results since installing it.

At its worst, I was down 50 Mbps from my top speed. Sometimes it’s just 20 Mbps lower than where it should be. Other times it’s only 3 off.

I used to get extremely consistent speeds on this test, so I’m wondering if the USB NIC is causing a conflict. My total available speed is so high that it doesn’t really matter in practice, but if it’s a symptom something is set up wrong…