URxvt (rxvt-unicode) Lags

Running Manjaro i3 community edition.
URxvt is currently lagging in a small way. I don’t notice any particular keystoke that causes it but it will freeze momentarily then will catch up after a few moments or after more input is entered. This didn’t start happening until a recent update and doesn’t seem to hurt anything but it throws me off when it freezes and annoys me.
Anybody else experiencing this? Any quick fixes?

Edit: I’ve tried other terminal-emulators and they work just fine.

share .Xdefaults or .Xresources

Xft.dpi: 97
Xft.antialias: true
Xft.hinting: true
Xft.rgba: rgb
Xft.autohint: false
Xft.hintstyle: hintslight
Xft.lcdfilter: lcddefault

XTermbackground: #222D31
foreground: #d8d8d8
XTermpointerColor: #1ABB9B
faceName: Fixed
XTermfaceSize: 11
reverseVideo: on
XTerm*selectToClipboard: true

*background: #222D31
*foreground: #d8d8d8
*fading: 8
*fadeColor: black
*cursorColor: #1ABB9B
*pointerColorBackground: #2B2C2B
*pointerColorForeground: #16A084

!! black dark/light
*color0: #222D31
*color8: #585858

!! red dark/light
*color1: #ab4642
*color9: #ab4642

!! green dark/light
*color2: #7E807E
*color10: #8D8F8D

!! yellow dark/light
*color3: #f7ca88
*color11: #f7ca88

!! blue dark/light
*color4: #7cafc2
*color12: #7cafc2

!! magenta dark/light
*color5: #ba8baf
*color13: #ba8baf

!! cyan dark/light
*color6: #1ABB9B
*color14: #1ABB9B

!! white dark/light
*color7: #d9d8d8
*color15: #f8f8f8

Xcursor.theme: xcursor-breeze
Xcursor.size: 0

URxvt.font: xft:mononoki Nerd Font:size=13

!!URxvt.font: 9x15,xft:TerminessTTFNerdFontMono

! alternative font settings with ‘terminus’:
! URxvt.font: -xos4-terminus-medium-r-normal–16-160-72-72-c-80-iso10646-1
! URxvt.bold.font: -xos4-terminus-bold-r-normal–16-160-72-72-c-80-iso10646-1
!! terminus names see end of file!

URxvt.depth: 32
URxvt.background: [100]#222D31
URxvtscrollBar: false
mouseWheelScrollPage: false
URxvtcursorBlink: true
background: black
URxvtforeground: grey
saveLines: 10000

! for ‘fake’ transparency (without Compton) uncomment the following three lines
URxvtinheritPixmap: true
transparent: true
URxvt*shading: 25

! Normal copy-paste keybindings without perls
URxvt.iso14755: false
URxvt.keysym.Shift-Control-V: eval:paste_clipboard
URxvt.keysym.Shift-Control-C: eval:selection_to_clipboard
!Xterm escape codes, word by word movement
URxvt.keysym.Control-Left: \033[1;5D
URxvt.keysym.Shift-Control-Left: \033[1;6D
URxvt.keysym.Control-Right: \033[1;5C
URxvt.keysym.Shift-Control-Right: \033[1;6C
URxvt.keysym.Control-Up: \033[1;5A
URxvt.keysym.Shift-Control-Up: \033[1;6A
URxvt.keysym.Control-Down: \033[1;5B
URxvt.keysym.Shift-Control-Down: \033[1;6B
! Rxvt.perl-ext-common: …,clipboard
! URxvt.keysym.M-C-c: perl:clipboard:copy
! URxvt.keysym.M-v: perl:clipboard:paste
! URxvt.keysym.M-C-v: perl:clipboard:paste_escaped
! URxvttermName: string
! URxvt
geometry: geometry
! URxvtchdir: string
! URxvt
loginShell: boolean
! URxvtmultiClickTime: number
! URxvt
jumpScroll: boolean
! URxvtskipScroll: boolean
! URxvt
pastableTabs: boolean
! URxvtscrollstyle: plain
! URxvt
scrollBar_right: boolean
! URxvtscrollBar_floating: true
! URxvt
scrollBar_align: mode
! URxvtthickness: number
! URxvt
scrollTtyOutput: boolean
! URxvtscrollTtyKeypress: boolean
! URxvt
scrollWithBuffer: boolean
! URxvttintColor: !7DA55
! URxvt
blurRadius: HxV
! URxvtfading: number
! URxvt
fadeColor: color
! URxvtutmpInhibit: boolean
! URxvt
urgentOnBell: boolean
! URxvtvisualBell: boolean
! URxvt
mapAlert: boolean
! URxvtmeta8: boolean
! URxvt
tripleclickwords: boolean
! URxvtinsecure: boolean
! URxvt
cursorUnderline: boolean
! URxvtpointerBlank: boolean
! URxvt
color0: color
! URxvtcolor1: color
! URxvt
color2: color
! URxvtcolor3: color
! URxvt
color4: color
! URxvtcolor5: color
! URxvt
color6: color
! URxvtcolor7: color
! URxvt
color8: color
! URxvtcolor9: color
! URxvt
color10: color
! URxvtcolor11: color
! URxvt
color12: color
! URxvtcolor13: color
! URxvt
color14: color
! URxvtcolor15: color
! URxvt
colorBD: color
! URxvtcolorIT: color
! URxvt
colorUL: color
! URxvtcolorRV: color
! URxvt
underlineColor: color
! URxvtscrollColor: color
! URxvt
troughColor: color
! URxvthighlightColor: color
! URxvt
highlightTextColor: color
! URxvtcursorColor: color
! URxvt
cursorColor2: color
! URxvtpointerColor: color
! URxvt
pointerColor2: color
! URxvtborderColor: color
! URxvt
iconFile: file
! URxvtfont: fontname
! URxvt
boldFont: fontname
! URxvtitalicFont: fontname
! URxvt
boldItalicFont: fontname
! URxvtintensityStyles: boolean
! URxvt
inputMethod: name
! URxvtpreeditType: style
! URxvt
imLocale: string
! URxvtimFont: fontname
! URxvt
title: string
! URxvticonName: string
! URxvt
buffered: boolean
! URxvtdepth: number
! URxvt
visual: number
! URxvttransient-for: windowid
! URxvt
override-redirect: boolean
! URxvthold: boolean
! URxvt
externalBorder: number
! URxvtinternalBorder: number
! URxvt
borderLess: true
! URxvtlineSpace: number
! URxvt
letterSpace: number
! URxvtskipBuiltinGlyphs: boolean
! URxvt
pointerBlankDelay: number
! URxvtbackspacekey: string
! URxvt
deletekey: string
! URxvtprint-pipe: string
! URxvt
modifier: modifier
! URxvtcutchars: string
! URxvt
answerbackString: string
! URxvtsecondaryScreen: boolean
! URxvt
secondaryScroll: boolean
! URxvtperl-lib: string
! URxvt
perl-eval: perl-eval
! URxvtperl-ext-common: string
! URxvt
perl-ext: string
! URxvtiso14755: boolean
! URxvt
iso14755_52: boolean
! URxvtxrm: string
! URxvt
keysym.sym: keysym
! URxvtbackground.border: boolean
! URxvt
background.expr: string
! URxvtbackground.interval: seconds
! URxvt
bell-command: string
! URxvtkuake.hotkey: string
! URxvt
matcher.button: string
! URxvtmatcher.launcher: string
! URxvt
matcher.launcher.: string
! URxvt
matcher.pattern.: string
! URxvt
matcher.rend.: string
! URxvt
remote-clipboard.fetch: string
! URxvtremote-clipboard.store: string
! URxvt
searchable-scrollback: string
! URxvtselection-autotransform.: string
! URxvtselection-pastebin.cmd: string
! URxvt
selection-pastebin.url: string
! URxvtselection.pattern-0: string
! URxvt
tab-bg: colour
! URxvttab-fg: colour
! URxvt
tabbar-bg: colour
! URxvttabbar-fg: colour
! URxvt
url-launcher: string

! The Terminus font uses the following X-names:
! -xos4-terminus-medium-r-normal–12-120-72-72-c-60-iso10646-1
! -xos4-terminus-medium-r-normal–14-140-72-72-c-80-iso10646-1
! -xos4-terminus-medium-r-normal–16-160-72-72-c-80-iso10646-1
! -xos4-terminus-medium-r-normal–20-200-72-72-c-100-iso10646-1
! -xos4-terminus-medium-r-normal–22-220-72-72-c-110-iso10646-1
! -xos4-terminus-medium-r-normal–24-240-72-72-c-120-iso10646-1
! -xos4-terminus-medium-r-normal–28-280-72-72-c-140-iso10646-1
! -xos4-terminus-medium-r-normal–32-320-72-72-c-160-iso10646-1
! -xos4-terminus-bold-r-normal–12-120-72-72-c-60-iso10646-1
! -xos4-terminus-bold-r-normal–14-140-72-72-c-80-iso10646-1
! -xos4-terminus-bold-r-normal–16-160-72-72-c-80-iso10646-1
! -xos4-terminus-bold-r-normal–20-200-72-72-c-100-iso10646-1
! -xos4-terminus-bold-r-normal–24-240-72-72-c-120-iso10646-1
! -xos4-terminus-bold-r-normal–28-280-72-72-c-140-iso10646-1
! -xos4-terminus-bold-r-normal–32-320-72-72-c-160-iso10646-1

remove this :point_down:

This does not seem to help. And how would that affect the confiuration if it is commented out?

Also something I forgot to add in the initial post: the cursor jumps around sometimes- even in vim.

Edit: tried xterm and it is happening there as well.

Thanks for helping out!

similar issue :point_down:

unfortunately that is definitely not the issue.

So I’ve actually reinstalled (fresh install) Manjaro i3 since. Upon re-installation I updated and found that urxvt was doing the exact same thing- I hadn’t touched the .Xresources at all either. Even the first time I took out the line of code thought to be the culprit, it continued doing the same thing. I personally believe it is an issue with the current version of xterm- mind you I don’t know much about how these terminals are structured. I’ve switched to Alacritty for the time being.

it’s a aur package as far i can tell. fully update your system, if you have not already and rebuild that software against python 3.10.

from the stable update announcement of 1/2/2022 :point_down:

You may need to rebuild any AUR packages that install files to site-packages …
yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

sorry about the delay in responding- I’ve tried deleting the lines in .Xresources and have no python packages to update/rebuild.

It is still doing it- however I have recently found that input into other programs are doing the same- I just didn’t notice because I’m not usually in “interfaced” programs that much. I’m starting to think it has something to do with the graphics driver…

edit: Blenders interface has gone south as well and I did not connect the 2… will try down grading the driver…

It was the kernal. I uninstalled the kernal my computer was running and found that it was an RT (real time kernal). Don’t know why this happened but it was in fact an supported one that I had not chosen to run.

Problem solved!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.