Upgrading my graphics card

I have added a second graphics card to my system - Radeon to move away from the Nvidia card no longer supported.
My question is how do I test the Radeon card is working ok before I can safely remove the Nvidia card?

My setup is:
Manjaro 20.2.1 Nibia
DE - Xfce 4.16.0
Kernel - 5.10.7-3
GPU 1 - NVIDIA GT215 [GeForce GT 240] driver: nvidia v: 340.108
GPU 2 - AMD Cedar [Radeon HD 5000/6000/7350/8350 Series] driver: radeon

[peter@peter ~]$ lspci -k | grep -A 2 -i "VGA"
02:00.0 VGA compatible controller: NVIDIA Corporation GT215 [GeForce GT 240] (rev a2)
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]
	Subsystem: XFX Pine Group Inc. Device 304a
	Kernel driver in use: radeon

Simply replace the Nvidia by the Radeon card and boot a live ISO. Then you know if it’s working within your hardware environment. Choose the open-source video driver if asked. If it’s not working - change it back.

If it’s working remove all specific adjustments from your boot settings (e.g. blacklisting, special kernel modules etc.) If it’s not booting you need to chroot into your system from the live ISO and re-install the right graphic driver within manjaro-chroot environment.

1 Like

Thanks Wollie.
I booted into both 20.2.1 and 21.0 live distros and it’s recognising the new card ok using the free drivers.
Can you point me towards the instructions to reset or remove my old card files.
Thanks again

I booted into the iso removed the video-linux driver and reinstalled the free driver rebooted but still get a black screen.
Did I miss something?

You need to
a) Boot into live ISO,
b) Manjaro-chroot into your system,
c) install open-source driver,
d) exit,
e) reboot into your system.

1 Like

That is what I did.
Still receiving a blank screen
I removed the existing video-linux driver first
New driver dated 2018-05-04
I removed the quiet option during boot and there’s an error against light manager failed when I run systemctl status lightdm
I tried booting in 5.4 kernel but same result as 5.10

Systemctl status lightdm

Launching process 1446: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch  
Process 1446 exited with return value 1

The replacement Radeon card works ok when booting into the live iso

I reminded myself to remove the Nvidia driver first, then replace Nvidia with Radeon card, Manjaro started without any problems, then installed Radeon driver in “Manjaro settings manager”.

1 Like

This is now resolved. I upgraded to the next release Pahvo v21.1.0 and everything is now working using the free driver.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.