Upgraded Entire System But Now Running Into Dependency Issues

I upgraded my system using pacman -Syu because I was running into some issues with gdb (GNU debugger) saying it couldn’t find the shared object file libpython3.10.so.1.0. I’m thinking, “Alright. I haven’t upgraded in awhile. I’ll try that.” So, I upgraded and was able to make gdb work! However, after the upgrade was completed , I tried opening vim and now I get this:

vim: error while loading shared libraries: libpython3.9.so.1.0: cannot open shared object file: No such file or directory.

I’m also running into issues with NeoVim because when I run nvim I get this error:

Error detected while processing /home/czar/.vim/plugged/vim-fugitive/plugin/fugitive.vim:
line  471:
E1208: -complete used without -nargs

and when I close out neovim, I get this

function remote#define#AutocmdBootstrap[1]..remote#host#Require[10]..provider#pythonx#Require[12]..provider#Poll, line 7
Vim(if):Error invoking 'poll' on channel 4:^@ch 4 was closed by the client
Error detected while processing function remote#define#AutocmdBootstrap[1]..remote#host#Require[10]..provider#pythonx#Require[12]..provi
line   17:
E605: Exception not caught: Failed to load python3 host. You can try to see what happened by starting nvim with $NVIM_PYTHON_LOG_FILE se
t and opening the generated log file. Also, the host stderr is available in messages.
Error detected while processing function remote#define#AutocmdBootstrap[1]..remote#host#Require:
line   10:
E171: Missing :endif

I have no idea where to even look in the first place to even ATTEMPT to solve this issue. My best guess so far is it has something to do with some python dependencies (libpython3.-*.so and such?). And it’s not so much vim and neovim I care about, but really just making everything work after upgrading my system.

How can I resolve these dependency issues? Please let me know what information I should provide. I’m completely out of my element here. Thank you in advance!

I’m running on kernel 5.11.22.

Yeah no kidding.

Save yourself a headache and re-install Manjaro with the latest stable ISO. Otherwise, you might be putting duct-tape on everything to make it work. The reason I say this is because between updates since kernel 5.11, much of the underlying system has been changed. Think of “installing the latest ISO” as a clean “update” to the latest packages and configurations.

You know how to keep the data on your /home/ safe?

Alternatively, someone else might be able to chime in and get your system working, which is hopefully only limited to the python issue.

Yeah, I thought that might be the most prudent route. I’m actually backing up my system as we speak. No, how do you keep data on /home/ safe?

First of all, as you alluded, you have a complete backup of everything under /home.

Secondly (with the above condition met), if you’re using a separate partition for /home, then you can tell the installer to use that existing partition and mount it to /home, and make darn sure to not format that partition.

What do you mean? You’re “backing up” the system with Timeshift? Or you’re actually properly backing up all your user’s data?

If you want to learn anything, then try fixing your own system and your own mistakes.
How, you might ask?
First by changing kernel, rebuilding any AUR packages and then taking your time to search this forum or google any errors you come by. Reading archwiki about maintenance would help too.
More time you put in, more you will learn and longer will your system work. Or you can wipe your system clean and forget about it and come back in a year with the same problem.