Updating packages with Pamac fails

Hello everyone,

a few months ago I couldn’t update packages with Pamac anymore. I tried a bunch of tutorials to fix this. Among others I tried what is marked as solution at "error: GPGME error: No data" when I'm trying to update a couple of times. At my last attempt I left out the step of restoring the original Pacman configuration (thus the security checks are still disabled) and I disabled the AUR in the pamac settings.
For a few days I thought I had fixed the problem, but when I try to update the packages in Pamac, the refreshing of the database hangs at 22 percent and I get the error “database synchronization failed”.
I tried to update the packages with Pacman in the terminal and that gave a GPGME error.
I saw at Fehler „Fehler: GPGME-Fehler: Keine Daten. Fehler: Alle Datenbanken konnten nicht synchronisiert werden (unerwarteter Fehler)“ (GELÖST) that I should enter rm -R /var/lib/pacman/sync and then sudo pacman -Syu, and that worked insofar as the GPGME error disappeared and I could update the packages that way, but Pamac still gives the same database synchronization error message every time I try it.
How could I solve this problem?

pamac has its own place for the databases:


Usually a force refresh should solve it:

pamac update --force-refresh

Same goes for pacman:

sudo pacman -Syyu
1 Like

Try this first… :arrow_down:

Then make sure you fully update your system, but do it from a tty while completely logged out of the GUI environment. :arrow_down:

sudo pacman-mirrors -f && sudo pacman -Fy && sudo pacman -Syyu
pamac checkupdates --force-refresh

Be sure to let the above commands finish. Do not interrupt the update process.


Thank you!
I did what the TL,DR section of the tutorial you linked said.
Than I logged out of my account from the GUI. Is that what you meant by "completely logged out of the GUI environment?
I entered a tty and entered the commands you gave. The second command either did nothing or did what it did very quickly without feedback, so I entered that one a few times.
Then I shut down the computer and rebooted.

Since then Pamac seems to work as I expect, even with the AUR enabled.

Should I change anything (back) about the Pacman configuration, or is it secure as it is now?

Yes, exactly. :wink:

If it didn’t do anything, then there were no updates to your AUR packages. :wink:


It is fine now. You had a corrupted package database, and now it’s fixed again. :wink:

Thank you!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.