Updating joplin-desktop via pamac hangs

I just tried to update joplin-desktop via sudo pamac upgrade and it keeps hanging at:

install dependencies: verb installed leaf @joplin/app-desktop

It stays like that for more than an hour and not sure how to debug it further in order to fix the issue, since the output doesn’t tell me anything reg. the possible issue.

$ sudo pamac checkupdates
1 available update:
joplin-desktop  2.2.7-1 -> 2.3.5-1         AUR

The same error was reported a couple days ago. If the Maintainer ignores it, that most likely means they cannot reproduce it.

Either way, a one-liner doesn’t help anyone troubleshoot the issue. Paste the full build log to a pastebin service and link it here.

You can always use the AppImage instead.

That was me who reported it to the packager. I assumed he probably uses Arch, therefore doesn’t even use pamac (hence, won’t be able to reproduce it), so I posted the issue here as well.

Most probably the full output won’t help either: https://pastebin.com/raw/2aRdhe5K

My idea was to post it here as an example, in case the output of pamac could be improved (by including --verbose, perhaps?).

Figures. :laughing:

Pamac can only print what’s given to it. The commands in the PKGBUILD are what govern the output.

In the future, never report a problem with AUR packages when using Pamac or any other AUR helper. If you can reproduce it manually (aka "the Arch way), then go for it. See:

1 Like

Personally I actually HATE AppImage that’s usually why ppl use Arch based distro’s right because of AUR? I hate snaps, flatpak, AppImage etc. I deleted Snap, Flatpak on all my computers, on Ubuntu, Linux Mint, Zorin OS.