Updating causing issues

Hi guys, I boot manjaro from an external SSD. I use it for programming tasks while in school. I’ve had little issues as I don’t mess with it very much other than doing my programming. However yesterday I was getting notifications that my firefox was out of date, so I went in and updated all my files that needed to be updated. Then on top of that I decided to update my kernel. Once I did this my computer restarted and when I tried to boot back into Manjaro I get the following message:

The message:

mount: /new_root: cant find UUID=…
You are now being dropped into an emergency shell.
sh: cant access tty; job control turned off
[rootfs ]#

I can’t do anything from this point. It seems like the boot manager can’t find the correct UUID, is this due to installing a new UUID and needing to update it somewhere?

I tried googling around and tried a few things but no luck, I’m not the most experienced with Linux as a whole.

Any help would be greatly appreciated
Thanks in advance

Hi @Jkharris, and welcome!

I suspect you’ll have to chroot into your installed system and run update-grub from there.

You would need to figure out which device is your external SSD by:


After that, you can try this:

mkdir /tmp/chroot
mount /dev/<your device> /tmp/chroot  || OR: mount /dev/disk/by-uuid/<according GUUID>
chroot /tmp/chroot
\# now within the chroot
mount /dev/<device of UEFI of SSD>   /boot/efi  || OR: mount /dev/disk/by-uuid/<according GUUID of SSD-UEFI>    /boot/efi
grub-mkconfig -o /boot/grub/grub.cfg

Of course, if you have MBR you would just mount the boot partition to /boot, instead of /boot/efi.

Hope this helps

With Manjaro and manjaro-chroot these step are unnecessary, as well as these:

Manjaro is that awesome yeah!



The same steps, or no, the same end result:

  1. Ensure you’ve got a relatively new ISO or at least one with an LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot environment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

Once in the live environment, you have to reinstall GRUB. To do so, run the following:


When successfully completed, exit the chroot environment:


Followed by rebooting and seeing if it worked.

If it did, feel free to heap on the praise. If, however, it didn’t, well, then I’m not here. (Mostly, I suspect, I’ll have to be off then.)


Sweet, and thanks for the heads up :slight_smile:
Havent had such issues yet - so I was still using the “old commands” that I was used to by other distros.

I understand perfectly. And they’re still here, AFAIK, they’re just not necessary. :grin:

Further reading: