Updates fail - unable to find libnvme - libnvme unavailable in repos

see title
can’t install libnvme so I can’t update

Update your mirrors first, then do an update.

sudo pacman-mirrors --geoip
pamac update --force-refresh

I’ll try different mirrors

Same error with CLI
Tried three different mirrors, Global, Taiwan. US and refreshing databases each time

always same error

Which error?


 $ pamac search libnvme
libnvme                                   1.5-1  extra 
    C Library for NVM Express on Linux

target not found: libnvme

every time i get this

target not found: libnvme

sudo pacman -Syu libnvme worked
it installed all the other updates
then libnvme installed from package manager

My hunch is that you tried to install using pacman -S libnvme and therefore the metadata (package dataabase) was not up-to-date.

That is why pacman -Syu libnvme worked - the y sync metadata and u updates the system.

Lesson learned - always use -Syu when syncing new packages to the system - so you get the correct metadata and the updated system packages.

pacman -Syu libnvme

didn’t work for me. I did

sudo pacman-mirrors --geoip
pamac update --force-refresh

and got

https://repo.skni.umcs.pl/manjaro/stable/extra/x86_64/ttf-hack-3.003-6-any.pkg.tar.zst: HTTP/2 Error: NO_ERROR  
Error: Operation failed: could not download some files

sudo pacman -Syu

error:  failed to prepare transaction (cannot resolve the dependencies)
:: installation of nvidia-utils (535.54.03-1) breakes dependecies of 'nvidia-utils=530.41.03' which are required by linux62-nvidia.

I get the same error after pacman -Syu libnvme.

You should first update your system and clear up the dependecy issues, then you can continue installing new packages.

But this what I tried to do - update the system and this is when I get the error ‘target not found: libnvme’. I wrote about it: https://forum.manjaro.org/t/target-not-found-libnvme/143891 but you kind of redirected me here. So I did what has been suggested here.

See papajoke’s response to sicklepause1’s identical error message:

So, removing the linux62 did the trick and I was able to update the system. Thanks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.