Updates broke the Networking, again... Internet only through a VPN connection

Before you ask, no I don’t know which updates, and I only vaguely remember it started a few weeks ago, maybe a month ago. Restoring to an earlier snapshot is not an option.
WIFI started showing an exclamation mark and saying limited connectivity. The weird thing is it still would work when I connect through a VPN but it won’t work without it (ping or ping to manjaro.org brings no results).
I’m almost always connected through a VPN so other then an exclamation mark it didn’t bother me as such I couldn’t really pinpoint when it happened exactly. My VPN is set to autoconnect.
I’m back to work now, the internet is really bad here and my VPN doesn’t always connect which basically leaves me without internet.
I’ve had a few min to look into it and it’s not my wifi adapter or router/access point issue or a combination of the above, I have another Linux distro installed on my system that I booted onto today (it’s been years) and wifi works wine there with and without a VPN connection.
It seems like Manjaro keeps breaking my system every 1.5-2 years, last time it happened I couldn’t fix it and after fighting with it for a while I reinstalled from scratch. I really like Manjaro and hope i can fix it this time, don’t wan to be reinstalling every few years.
Where would I start? Other than confirming that it isn’t a hardware issue I couldn’t find an issue similar to mine to replicate the steps and try to fix it.

Without VPN connection:

    ~  ping manjaro.org                                                                    ✔ 
ping: manjaro.org: Temporary failure in name resolution
    ~  ping                                                                      2 ✘ 
PING ( 56(84) bytes of data.

What are you using to handle your connections?
Seems you need to add DNS servers., should do it.

“Networks” widget, the one that sits in system tray by default.
my system by the way:

Operating System: Manjaro Linux 
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.1.25-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-4800MQ CPU @ 2.70GHz
Memory: 11.6 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 4600
Manufacturer: Micro-Star International Co., Ltd.
Product Name: GT70 2PE
System Version: REV:0.C

How do I add DNS servers? Go to each network settings and do it or is there a way to do it for all connections at once?

It should carry over for all connections through that device I beleive.

I don’t use KDE so I have no idea what the “widget” is by default. If Network Manager then right click and choose edit connections. Select your connection>ipv4 settings and fill in the DNS server line.

Did that, no changes. Tried disconnecting / reconnecting to network and tried reboot, no changes, still no internet until I connect VPN.

Have you paid your internet bill?

I’ve seen this sometimes on ISPs that arent very good about their ‘reroute traffic to bill collection page’ … VPN users could continue using the internet for even a few days after the ‘soft disconnect’.

Haha, that was funny. Nah as mentioned I am at work so no bills to pay, also as mentioned I have tried booting into another Linux distro and have no connection issues with or without VPN connection.

What you describe to me is not a DNS issue, you don’t need a DNS server to ping an IP. It looks like you did not properly disconnect the VPN and it locks the connection, the feature can be called a killswitch (to disable your internet if not connected through VPN.

1 Like

Some VPN providers (ehm, Nord) don’t really support Arch based distros and indeed that particular provider is somewhat broken these days (mainly their very nice NordLynx, must fallback to OpenVPN).

However, you can try what I have to do almost everytime I reboot (due to altered network settings needed for Nord to integrate well):

$ sudo iptables -F

somehow any domain resolving always fails without flushing the ip tables. In case that doesn’t help, let’s see what resolvectl status (don’t connect to VPN for sure).

WHAT VPN are you using?

This is caused by absence of a functional DNS on the system in question - possibly because your VPN provided DNS is in your resolv.conf and your VPN connection is not starting as expected.

You can verify the content using

cat /etc/resolv.conf

No Manjaro is not breaking your system. Without knowing which VPN provider you use - it is purely guessing.

Not many vpn providers - surfshark as an exception - provides installation instrucitons for Arch based distributions.

When you sync your system - any custom AUR package may break as a result of the system being updated.

The rule of thumb is - rebuild your custom package(s) when you have synced your system.

1 Like

Duh… I recalled I turned it on (temporary) as soon as you have mentioned it. I hardly ever touch that option and my “temporary” turned into permanent and started giving me headaches.

~  nordvpn settings                                                                                                                                                                              ✔  AU  
Technology: OPENVPN
Protocol: UDP
Firewall: enabled
Firewall Mark: 0xe1f1
Routing: enabled
Analytics: enabled
Kill Switch: enabled
Threat Protection Lite: enabled
Obfuscate: disabled
Notify: enabled
Auto-connect: enabled
IPv6: disabled
Meshnet: disabled
DNS: disabled

Set it to off and switched off/on my wifi connection and exclamation mark is gone as well as I can connect without a VPN.

Mine is NordVPN for all of you asking but you’ve already figured it out from the code I posted.
Thanks all, it was a dumb moment on my part.

You can keep the killswitch, just issue proper commands to disconnect:

nordvpn set killswitch off
nordvpn disconnect

and when you connect you enable it again

nordvpn connect COUNTRY_CODE_HERE
nordvpn set killswitch on

Side note, you can add DNS servers to your VPN config, for example or whatever you prefer, I’m not sure what it uses if you don’t configure it in the VPN (the VPN DNS server, or your ISP DNS server).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.