Updates borked CS:GO and Gnome Extensions

Recently, After lots of alcohol consumption, I did a bunch of updates including the manjaro updates, steam app updates and updated cs:go. I was intoxicated during the updates and don’t remember if I rebooted immediately after doing them or know if that’s relevent.

I tried to play cs:go and got an error screen that took up my whole monitor. I continue to get this error even since rebooting and checking for updates again:

:frowning: Oh no! Something has gone wrong. A problem has occurred and the system can’t recover. Please log out and try again. [Log Out]”

On one occasion CS:GO worked, but after I was done and exited, later in the evening I went to play again, and now I’m getting the error again.

I’m not sure what to do or where to start for help. Also, after these updates all my extensions are disabled on each boot-up and login now. I have to touch activities and type in extensions after each login and boot, and enable them every time now.

~ >>> inxi -F                                                                                                                                                                                                
System:    Host: karen-main-game Kernel: 5.4.74-1-MANJARO x86_64 bits: 64 Desktop: GNOME 3.38.1 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: X99 Taichi serial: <superuser/root required> UEFI: American Megatrends v: P1.80 
           date: 04/06/2018 
CPU:       Info: 6-Core model: Intel Core i7-5930K bits: 64 type: MCP L2 cache: 15.0 MiB 
           Speed: 1197 MHz min/max: 1200/3700 MHz Core speeds (MHz): 1: 1197 2: 1197 3: 1198 4: 1197 5: 1197 6: 1197 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega 56/64] driver: amdgpu v: kernel 
           Display: x11 server: X.Org 1.20.9 driver: amdgpu,ati unloaded: modesetting,radeon resolution: 1920x1080~60Hz 
           OpenGL: renderer: Radeon RX Vega (VEGA10 DRM 3.35.0 5.4.74-1-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.2.1 
Audio:     Device-1: Intel C610/X99 series HD Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD/ATI] Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.74-1-MANJARO 
Network:   Device-1: Intel Ethernet I218-V driver: e1000e 
           IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: 70:85:c2:2a:e9:15 
           Device-2: Intel Wireless 3160 driver: iwlwifi 
           IF: wlp7s0 state: down mac: 06:6d:fe:df:77:55 
Drives:    Local Storage: total: 4.56 TiB used: 418.60 GiB (9.0%) 
           ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P1SSD8 size: 931.51 GiB 
           ID-2: /dev/sda vendor: Western Digital model: WD4001FAEX-00MJRA0 size: 3.64 TiB 
           ID-3: /dev/sdb type: USB vendor: Verbatim model: STORE N GO size: 14.42 GiB 
Partition: ID-1: / size: 915.60 GiB used: 418.60 GiB (45.7%) fs: ext4 dev: /dev/dm-0 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 22.0 C mobo: N/A gpu: amdgpu temp: 29.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 817 
Info:      Processes: 263 Uptime: 7m Memory: 31.29 GiB used: 1.82 GiB (5.8%) Shell: Zsh inxi: 3.1.08

~ >>> sudo dmesg -l emerg,alert,crit,err,warn                                                                                           
[    0.644515] pmd_set_huge: Cannot satisfy [mem 0xe0000000-0xe0200000] with a huge-page mapping due to MTRR override.
[    0.889001] nvme nvme0: missing or invalid SUBNQN field.
[    1.124563] i8042: PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp
[    2.383747] hid-generic 0003:264A:1004.0002: ignoring exceeding usage max
[    4.108898] sd 6:0:0:0: [sdb] No Caching mode page found
[    4.108900] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[   24.065463] kauditd_printk_skb: 18 callbacks suppressed
[   24.324745] iwlwifi 0000:07:00.0: reporting RF_KILL (radio disabled)
[   24.324761] iwlwifi 0000:07:00.0: RF_KILL bit toggled to disable radio.
[   24.360679] EDAC sbridge: CPU SrcID #0, Ha #0, Channel #0 has DIMMs, but ECC is disabled
[   24.360681] EDAC sbridge: Couldn't find mci handler
[   24.360682] EDAC sbridge: Failed to register device with error -19.
[   24.390422] EDAC sbridge: CPU SrcID #0, Ha #0, Channel #0 has DIMMs, but ECC is disabled
[   24.390424] EDAC sbridge: Couldn't find mci handler
[   24.390425] EDAC sbridge: Failed to register device with error -19.
[   24.394304] CRAT table not found
[   24.439205] EDAC sbridge: CPU SrcID #0, Ha #0, Channel #0 has DIMMs, but ECC is disabled
[   24.439208] EDAC sbridge: Couldn't find mci handler
[   24.439209] EDAC sbridge: Failed to register device with error -19.
[   24.509310] EDAC sbridge: CPU SrcID #0, Ha #0, Channel #0 has DIMMs, but ECC is disabled
[   24.509312] EDAC sbridge: Couldn't find mci handler
[   24.509313] EDAC sbridge: Failed to register device with error -19.
[   24.572370] EDAC sbridge: CPU SrcID #0, Ha #0, Channel #0 has DIMMs, but ECC is disabled
[   24.572372] EDAC sbridge: Couldn't find mci handler
[   24.572373] EDAC sbridge: Failed to register device with error -19.
[   24.639008] EDAC sbridge: CPU SrcID #0, Ha #0, Channel #0 has DIMMs, but ECC is disabled
[   24.639011] EDAC sbridge: Couldn't find mci handler
[   24.639012] EDAC sbridge: Failed to register device with error -19.
[   29.477075] kauditd_printk_skb: 27 callbacks suppressed
[   61.004567] kauditd_printk_skb: 4 callbacks suppressed
[ 1059.205041] kauditd_printk_skb: 10 callbacks suppressed

I feel as though I’m getting this error screen that forces me to log out in error. The application seems to be running in the background, and I can even see the menu screen briefly before it puts me back at the login screen and then disables all my extentions.

Also possibly relevant, but it also says “cs:go is not responding” when it’s loading the menu the first time (always has, since installing manjaro 20 even when it worked), with the option to force quit or wait…

control+alt+F5 and then top shows CS:GO and all the steam stuff running as per usual.

When you get the oh no error, steps to fox are:

  1. disable all extensions. If login still doesn’t work, set shell theme to adwaita
  2. when logged in, enable your extensions one by one and see which one crashes gnome shell. Extensions that come pre-installed with manjaro have been tested to he stable, so start with stuff you have installed from the gnome website, and then proceed to Manjaro extensions of that doesn’t show the culprit.

Bro there is a bug in gnome 1:3.38.1. I researched on this problem. GNOME 3.38.1 crashes when returning to desktop from full-screen game. It got fixed in 3.38.2 minor version.

And for the hot fix only for cs-go:
Steam --> CS:GO —> Properties —> Launch options and in launch options add " -windowed " in the end and after that launch cs-go and wait for it to load , once the game gets loaded go to settings --> video and then switch to full-screen and its done

No more crashing of gnome and you can play peacefully and grind to GE xD


@dev-the-code-reaper this fixed it - im running it in “windowed fullscreen” and now it works again, although it still says it’s not responding for a bit when it launches, if I just wait, it does load and doesn’t crash anymore. @Chrysostomus I will see if any of the 3 extensions I have running affect the other error I get, as well if they prevent the crash at all. I have Dash to Dock, Kstatusnotifier (for snap-repo app to work in notification area), pamac updates indicator and downloaded from gnome website system-monitor extension for my top bar, so i can see current ram, disk access, network access, gpu&cpu temp…

Thanks for the help and thanks for the link

I found a “crash_20201108212744_6.dmp” related to this crash - is there a way I can provide it to the manjaro or gnome team?

it got fixed in gnome 3.38.2 version

im on manjaro, and it’s still using 3.38.1

wait for the next minor update. i think manjaro team is working on it

I’m still having this problem, not fixed yet.