Updated kernels do not detect USB WiFi connection

I am running kernel 5.11.22-2 and I use a USB WiFi dongle to connect to my router. When I upgrade to a newer kernel like 5.12.19–1 or 5.13.5-1, the system does not detect the WiFi connection. I wondering why this is and need help on how to fix this. My USB WiFi dongle’s driver is rtl88x2bu.

Can anyone help?

I guess it is this driver: AUR (en) - rtl88x2bu-dkms-git

Are the kernel headers installed?

Are you sure the DKMS Module has been been compiled?

I used Manjaro Settings Manager to install the kernels so I guess that installs the headers as well?

Nope, don’t have to. Check it.

Well, headers are installed.


What next?


I don’t know if this would help… but when I do a modprobe of 882xbu I get this error:

modprobe: FATAL: Module 88x2bu not found in directory /lib/modules/5.13.5-1-MANJARO

Oh, btw. I had to download and install rtl88x2bu manually the first time since I do not have an Ethernet connection to my router. So I was unable to install the dkms-git version from AUR.

Try going through this guide, I have the same driver and used this to install everything correctly.

Okay, I am trying the uninstall procedure. But I ran into an error when executing the first command, in CLI specifically the sudo modprobe r $MODULE part.

It is returning a:

modprobe: ERROR: missing parameters. See -h.

The full command, btw, is:

MODULE=$(hwinfo --wlan | grep "Driver Activation Cmd" | cut -d " " -f9 | tr -d '"') && sudo modprobe -r $MODULE

lsmod should list all loaded modules… search there for the module. The command there just tries to filter the module name and unload it with sudo modeprobe -r module_name

The filtering did not work, so no module has been found. Therefore the parameter module was not there.

I got it solved.

I was not able to find the module even using lsmod because the module was not installed for the kernel. So what I did was I borrowed a long ethernet cable from a friend, connected my machine to the router and I was able to get online. I then proceeded to download and install rtl88x2bu-dkms-git from the package manager, rebooted, and was able to connect to the web using my USB dongle.

Thanks to @megavolt and @gnoblin_44 for your inputs. :slight_smile:


I remember it taking me a week to solve this issue, I hope it did not take that long for you

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.