Updated and reset. Now I can only access BIOS menu

I downloaded today’s major upgrade. After personally seeing no warnings or errors, I saw the usual window, stating a reset was necessary. Nothing looked out of place so I reset like normal.

Now, the only activity I can get out of my entire machine is opening the BIOS menu, which is just the hardware, if course.

Beyond that, all I get is the “Welcome to GRUB!” screen. And after that, it’s all just a black screen. It can shut down with a touch of the power button, but that’s about it.

Is there any way to get it running in some kind of safe mode?

Aschewing possible troubleshooting, if its related to plymouth, you can

1 Like

I cannot even get to the GRUB menu. I hit ‘e’ at every point imaginable, and i still end up at the black screen.

Your grub is likely hidden then.

You probably need only hit Esc to make it show.

Heres general things like chroot etc.

Since reading this post, i attempted to restart many times.

One time, i lucked out, and got to the f2 text screen, but couldn’t log in because i couldn’t find my actual login name. It’s my computer alone, and i took that detail for granted.

The second time, i actually managed to get to the GRUB menu. I don’t know for the life of me why i shut it down again, but i assumed i could get back to it if i wanted.

I have not managed to repeat either instance since.

My screen is blank, so I’m doing all this blind. Does that make this all exceedingly difficult, or am i just stupid?

If you boot non-graphically you are going to have to know your username and password.

Trying to unhide grub by hitting Esc, or whatever other magic dance you can do, is about it for using as-is. Unless its an old machine with an HDD be mindful that the time between BIOS and Grub can be very short, so you might want to start tapping Esc immediately after power on.

If something like that cannot be accomplished then the next best step is probably to use a Live USB and chroot in. If its not funky/encrypted setup then thats just manjaro-chroot -a from the live environment.

See this page for more info (like extra steps if using btrfs)

1 Like

You don’t get to the Grub menu by tapping “e”.
You do that by tapping “ESC” - and then, once you see the menu, you can use"e" to get into edit mode.
Don’t forget to read the text at the bottom - it is “CTRL-x” or F10 to boot when you are finished editing.

It turns out, many silly things happen when you try to enter in keyboard shortcuts

And the screen isn’t being a screen, you know, showing you things.

If i remove the word ‘splash’ from the linuz line in GRUB, will that disable Plymouth?

yes - while you are at it, remove quiet as well

This is only temporary - just for this one boot.

I have managed to remove quiet and splash from etc/mkinitcpio.conf and /etc/default/grub , respectively.

I’ll see if this solves my booting problems. So far, this looks like this solution.

Thanks, everyone.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.