Update Tuxedo packages for latest hardware (Aura 15 Gen1)


Hope this is the right place to post this… Aura is not listed as an official Manjaro Hardware.

I just got a new Tuxedo Aura 15 Gen1. It’s an Ryzen 4700U with Vega graphics. I tried the following packages:

  • tuxedo-cc-wmi
  • tuxedo-control-center
  • tuxedo-keyboard-dkms

The keyboard (packager: @oberon) package is working fine, I’m able to use the keys to change backlight and all Fn keys work as expected (though I had to modify the config manually to persist the settings after reboot). However Tuxedo Control Center (packager: @nightmare-2021 ) and related cc-wmi) say that the hardware is not supported.

I then tried to build the packages directly from Tuxedo’s GitHub repos and then Control Center works - I can see the CPU temp and also set the processor speed.

I wonder if the owners of the packages could rebuild the above mentioned packages, so that I would not have to compile the packages myself.

Also if you can explain how you build the Tuxedo Manjaro packages… in the official repository I can’t find build scripts/instructions to build pacman packages.

Thank you for the heads up. I will look into updating those packages.

1 Like

We are currently in progress to update those packages. There were some updates and some packages got dropped. Since we have direct contact with Tuxedo, a soluton will be available shortly.

Thank you both. I’ll keep an eye for new packages.

tuxedo-control-center 1.0.8-1.1 (unstable) should solve your problem :wink:

I’ll give it a try, thanks.

… or maybe it’s best to wait for the stable package… I saw that in order to use unstable it’s best to upgrade the whole system… I already have working packages built manually, don’t want to change the whole system for just a few packages :slight_smile:

Regarding tuxedo-keyboard-dkms… I stand corrected - if I use the AUR package the system fails to boot to graphics mode… I just get a black screen, can enter the console and uninstall, though.

It seems that I installed tuxedo-keyboard from source.

can you please explain it better? we should install the package by source or not? and which one exactly?

@Terence64w It seems that the latest update brings rebuilt packages… I did not try them yet though.
Problem is that the latest update removed the 5.7 kernel - and 5.10 is buggy as hell on Aura 15 (resume does not work, graphics locks up, backlight)…

I installed the new tuxedo-keyboard and tuxedo-control-center. Everything works as expected. Thanks guys!

I also did some testing compiling a project in Java:

  • tuxedo cc profile balanced: 1:15 (fans spin like when not using cc, though speed changes seem more jerky)
  • tuxedo cc profile cool and breezy: 2:09 (can’t hear fans at all)
  • tuxedo cc profile powersave extreme: 2:27 (totally silent)
  • no tuxedo cc: 1:15

Update: After some more testing I decide to disable tuxedo-control-center (systemctl disable tccd). You need to shutdown and restart or the cpu speeds will be kept. Control center version: 1.0.8-1.1. System: Tuxedo Aura 15 Gen1

Why: I noticed that the fan control was turning on-off and changing it’s speed too often - which was resulting in clicks coming from the fan. In one case it also did a not inspiring grinding sound. I reckon that changing the fan speed too often will wear the fan too soon.

Too describe it in more detail:

  • with mode Balanced and computer idle: at start the fan is at 0%… after some light load cpu temp goes up and fan starts at 15% which results in a click… after 5 seconds or so cpu is cool again and fan stops… 10 seconds later it again starts click…
  • with mode Freezy: fan start at around 10-15% (this mode I suspect want to keep the cpu temperature freezy)… after 1-2 seconds it increases the speed slightly which results in a click (because fan accelerates)… after 1-2 second it changes speed again.

There is no way I found to set some kind of hystersis without coding… I’ll report the same issue upstream.

The good guys at Tuxedo are working on a feature that will allow using TC only to control CPU speed (i.e. it will leave fan control to the BIOS):

Clicking on the fan shouldn’t happen otherwise didn’t respect PWM-specifications.

PWM specification say: Starting at (about) 30% and hold continuous voltage on the fan increasing by arise of temp/voltage proportionally (or through a self defined curve in the BIOS/UEFI) but still continuous.

The “clicking” is given by rectangular voltage (on, off, on, off, etc.), that’s out of specs (See PWM-specs 1.4).

Maybe this indication can help to resolve the problem.

Anyway, it make sense and is useful to can adjust the CPU-behavior/speed through Tuxedo manager let me say “online” e.g. if you want start gaming or video-edit, but make less sense to “manipulate” PWM twice in BIOS/UEFI and through additional mechanism.