Update to kernel 5.15.72-1 failed Realtek RTL8852AE Wireless

I have been using Manjaro for 6-7 months and I have Lenovo ThinkPad E14 with a wireless
Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter

I have been using driver from rtw89-dkms-git which is provided by AUR pamac manager since I installed Manjaro.

After the update to kernel 5.15.72-1 and reboot the wireless was gone which was typical.
but i was able rebuild by running make and make install and reboot ; everything used to work typically.

However this time i did the same and I rebooted ; the wireless did not work . I did it again and rebooted but no chance.

So I tried a clean update and used AUR to delete the rtw89 package and reinstall but this time package manager was trying to install a dependency debugedit 5.0.4 and it fails if i try to install it errors out
“no server configured repositories”

I tried both from terminal via pacman and pamac both gave me this error and honestly I don t understand why package manager is asking for dependency that was not before.

And dont also understand why it did not for the work just rebuilding with make and make install that was working for 6-7 months.

Really appreciate the help. thanks

update: I was able to install the wireless drivers from the github repo; https://github.com/lwfinger/rtw89
just used instruction make and make install and reboot and it worked.

but why pacman or pamac both terminal giving that error . There is something wrong there.

Is there a server issue and also suddenly unneccessary dependency from pamac or AUR.
Is there something I need to do because that worries if i want to install anything will fail for reasons like that.

it looks like if i try to install anything both from pacman and pamac i get an error

    ~  sudo pacman -S neofetch                                        1 ✘ 
resolving dependencies...
looking for conflicting packages...

Packages (1) neofetch-7.1.0-2

Total Download Size:   0.08 MiB
Total Installed Size:  0.33 MiB

:: Proceed with installation? [Y/n] y
error: no servers configured for repository: community
error: failed to commit transaction (no servers configured for repository)
Errors occurred, no packages were upgraded.


Maybe try the commands in this post:

1 Like

thank you it worked …I was so worried. I guess Linux is endless route to learn but fun. thnks a lot

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.