Update stopped x86_64 Linux 4.14.65-1-MANJARO

hello community
i’m new to manjaro and i have issues with update and kernel update

my profile is:

 ██████████████████  ████████     rodi@rodi-pc
 ██████████████████  ████████     OS: Manjaro 17.1.12 Hakoila
 ██████████████████  ████████     Kernel: x86_64 Linux 4.14.65-1-MANJARO
 ██████████████████  ████████     Uptime: 21m
 ████████            ████████     Packages: 1273
 ████████  ████████  ████████     Shell: bash 4.4.23
 ████████  ████████  ████████     Resolution: 1366x768
 ████████  ████████  ████████     DE: Xfce4
 ████████  ████████  ████████     WM: Xfwm4
 ████████  ████████  ████████     WM Theme: Numix_By_MM
 ████████  ████████  ████████     GTK Theme: Numix_By_MM [GTK2]
 ████████  ████████  ████████     Icon Theme: Vertex-Maia
 ████████  ████████  ████████     Font: Cantarell 10
 ████████  ████████  ████████     CPU: Genuine Intel U4100 @ 2x 1.197GHz
                                  GPU: Unknown
                                  RAM: 1247MiB / 3881MiB

what am i doing wrong
when i installed manjaro i had an upcoming window telling me to secure that there is a folder for /home/ben/Downloads
i suppose “ben” is my name
opening file manager i see a Downloads folder, so…
this same windows tells me to configure in pacman-services this issue but i cannot find pacman-services
please help…

It’s called “Add/Remove Software” in the menu.

thank you
i tried add&remove but it says failed to commit transaction
i tried sudo pacman --Syu in the terminal and same issue
something with the keyring…

core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Some packages should be upgraded first…
resolving dependencies…
looking for conflicting packages…

Packages (3) archlinux-keyring-20210616-1 manjaro-keyring-20210622-1

after proceeding appears

(3/3) checking keys in keyring [######################] 100%
downloading required keys…
error: key “6D42BDD116E0068F” could not be looked up remotely
error: key “428F7ECC7117F726” could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

:: Starting full system upgrade…

shall i provide more information, sytem etc…?

Mmh… :face_with_monocle:
Just to be sure… When did you install Manjaro? And since when have you not updated your system?

Because your kernel is old as time, and this “version” of Manjaro is from 2017…

Unless you somewhat downloaded recently a 4 years old iso, you try to update a 4 years old Manjaro system.

In any cases, stop.
Download a recent iso, backup your files and reinstall. A rolling release must be updated regularly.

i was looking for a distro which will work on my 32bit samsung x420 and i found this x86-64 to download
i installed it yesterday and had 3 notifications

  1. if home/ben/Downloads was installed, if not use pacman-services
  2. more than 1000 updates
  3. kernel update, please
    maybe its not possible to use manjaro on 32bit
    really i was looking for deepin os in 32bit, seems impossible but there is the option of manjaro deepin…
    so i went for it

Manjaro has got no 32 bit compatibility for some years now.

Do a forum search, there are related topics presenting alternatives, such as 32 bit Arch Linux.

Edit: just did, take a look at https://archlinux32.org by example.

ooooh what a shame
i will have a look around
thanks a lot so i look into your link

While it technically should be possible to update such old installation - it requires a very knowledgable user to complete it.

You installed Manjaro using a very - very old ISO - you should have used the most recent version linked from the manjaro.org web

Then your system is not 32-bit but 64-bit and will work with the latest Manjaro ISO