Update problems with ckbcomp

When updating my manjaro today I came across this error in the update:


I accept and appreciate suggestions

PS: I can’t put long codes here, it’s badly formatted

T+ = See you later

You have “update from the AUR” checked in your Package Manager. ckbcomp is version 194 in the Manjaro repositories.

curl: (22) The requested URL returned error: 404
==> ERRO: Falha ao baixar http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.202.tar.xz
Erro: Falha ao compilar ckbcomp

ckbcomp 1.204 is out and 1.202 no longer exists. The package has already been flagged out of date. You’ll have to wait for the maintainer to update it or you can edit the PKGBUILD and bump the pkgver and update the checksums yourself.

Thanks for the answers @Yochanan @Strit

As I don’t know how to edit the PKGBUILD, let alone update the checksums, I’m still on the same question, since a problem seems to be calling another, is there a way to remove this package from the system without affecting its functioning?

As I said, one problem calls another one to other missing dependencies in my system as thermite; termite-terminfo


I looked here the manjaro-settings-manager says to him, now it’s ugly for me :rofl: :rofl: :rofl:

T+ = See you later

For some reason you have it installed from the AUR. Install it from the repos.

1 Like

My dear @Yochanan,

It is installed from the extra repository, see below:

pamac search ckbcomp                                      ✔  4s  
ckbcomp-bin                                                      1.203-1  AUR 
Compile a XKB keyboard description to a keymap suitable for
loadkeys or kbdcontrol
ckbcomp                                              [Instalado] 1.194-1  extra 
Compile a XKB keyboard description to a keymap suitable for
loadkeys or kbdcontrol

The problem comes if I update with the command:

pamac update

==== EDITED ====

Sorry everyone removed the termite packages; termite-terminfo that were also giving a problem and the case was resolved

pamac update                                              ✔  4s  
Sincronizando banco de dados de pacotes...
Nada para fazer.
Transação finalizada com êxito.

T+ = See you later

Everyone has ckbcomp installed as manjaro-settings-manager depends on it. You’re the only one having an issue. If it was installed from the repo, it will not prompt to update from the AUR. Reinstall it to make sure it’s the repo version:

pamac install ckbcomp

Tip: When pasting terminal output on Discourse forums, one can either…

  • Highlight it and use the Preformatted text </> toolbar button.

  • Add three backticks ` above and below the text (Markdown):


  • Use HTML:


Please edit your post accordingly.

1 Like

I tried to edit it by copying back the back of your message and I still don’t know if it was right

pamac install ckbcomp                                            ✔ 
Aviso: ckbcomp-1.194-1 está atualizado -- ignorando
Nada para fazer.
Transação finalizada com êxito.

T+ = See you later

There is no try, only do. :wink:


So it is

I do it here but either I’m too dumb, or the forum tools don’t like me very much, see below for your tip:

inxi -SMC                                                        ✔ 
  Host: wallcreto Kernel: 5.10.49-1-MANJARO x86_64 bits: 64 
  Desktop: LXQt 0.17.1 Distro: Manjaro Linux 
  Type: Laptop System: Positivo Informatica SA product: C14RV01 
  v: 1.00.05_SIM serial: <superuser required> 
  Mobo: Positivo Informatica SA model: C14RV01 v: SIM 
  serial: <superuser required> UEFI: American Megatrends v: 1.00.05 
  date: 10/03/2012 
  Info: Dual Core model: AMD C-60 APU with Radeon HD Graphics bits: 64 
  type: MCP cache: L2: 512 KiB 
  Speed: 799 MHz min/max: 800/1000 MHz Core speeds (MHz): 1: 799 2: 1122

That’s right @Yochanan?

T+ = See you later

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.