Update missing after restoring using timeshift

I today ran sudo pacman -Syu. There were plenty updates available, I started downloading it. Halfway through the download I quit the update and restored my PC with timeshift. Now when I run sudo pacman -Syu, it says everything is up to date. Why is it happening?


sudo pacman -Scc
sudo pacman-mirrors -f && sudo pacman -Syyu

The first command cleans your pacman cache, which might be slightly corrupted due to the interrupted update. If you get error messages please post them here.


What do we mean by Sudo pacman -Syyu?

The second y is needed whenever you update your mirror-list (here by pacman-mirrors -f) as this forces a full refresh of the package database and update all packages on the system.

1 Like

I did sudo pacman-Scc and now everything is fine.

1 Like

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.