Update KILLS internet connection

this week’s Manjaro update kills the ethernet driver, it still displays in the list of Manjaro Settings/Network Configuration, but it doesn’t work, Advanced Network Settings does not recognize any device (the field to select a network card is greyed out).

I updated two times with different methods, but both times I had to use Timeshift to go get a functioning machine. I’m still unsure if the upgrade breaks just the eth driver or it breaks networkmanager as well, but I’d like to prevent this from happening (having an updated OS is a good thing, but updates that break workflow aren’t).

What can I do? thanks for any input!

First of all, let forum members know at least of what ethernet model you have …

1 Like

you’re damn right, my bad:

in “Hardware Configuration” the Network Controller is listed as:
RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller: “network-r8168”

in “Network Connections” is listed as “Ethernet/Wired Connection”, Device: enp3s0

But you still didn’t read the link i provided, to know how is proper to provide your system info … Is quite important to see the kernel version, what driver is installed/used … :slight_smile:
For that model, as many we have, check if you do not have blacklisted the r8169 driver inside /etc/modprobe.d/ … Make sure you have a LTS kernel or the latest supported one …

1 Like
  Kernel: 5.10.23-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=514bc2a8-24be-4520-b68a-df36e748cc23 rw usbcore.autosuspend=-1 
  Desktop: Budgie 10.5.2 info: budgie-panel wm: budgie-wm dm: LightDM 1.30.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASUSTeK model: PRIME B350-PLUS v: Rev X.0x 
  serial: <filter> UEFI-[Legacy]: American Megatrends v: 4207 date: 12/07/2018 
  RAM: total: 31.36 GiB used: 3.3 GiB (10.5%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ 
  family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D cache: L2: 4 MiB 
  bogomips: 127782 
  Speed: 1908 MHz min/max: 2200/4000 MHz boost: disabled Core speeds (MHz): 
  1: 1908 2: 1907 3: 1885 4: 1894 5: 1887 6: 1886 7: 2140 8: 2194 9: 1883 
  10: 1890 11: 1885 12: 1895 13: 1935 14: 1893 15: 1887 16: 1891 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca 
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl 
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme 
  smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce 
  topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt 
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 07:00.0 
  chip-ID: 1002:67df class-ID: 0300 
  Display: x11 server: X.org 1.20.10 compositor: budgie-wm driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.40.0 
  5.10.23-1-MANJARO LLVM 11.1.0) 
  v: 4.6 Mesa 20.3.4 direct render: Yes 
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 07:00.1 
  chip-ID: 1002:aaf0 class-ID: 0403 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 09:00.3 chip-ID: 1022:1457 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.23-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.17 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.23 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI modules: r8169 port: f000 
  bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No Bluetooth data was found. 
  Message: No LVM data was found. 
  Message: No RAID data was found. 
  Local Storage: total: 294.38 GiB used: 28.02 GiB (9.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: OCZ model: VERTEX3 size: 55.9 GiB 
  block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD 
  serial: <filter> rev: 2.25 scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 PRO 256GB 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 4B6Q scheme: GPT 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw-size: 55.9 GiB size: 54.89 GiB (98.20%) used: 28.02 GiB (51.0%) 
  fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 514bc2a8-24be-4520-b68a-df36e748cc23 
  Alert: No Swap data was found. 
  ID-1: /dev/sdb1 maj-min: 8:17 size: 238.47 GiB fs: ext4 label: secondary 
  uuid: 7040a776-f63d-416c-8b23-0a3424ab868b 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-3:2 info: Holtek Gaming keyboard type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 4 rev: 1.1 speed: 12 Mb/s 
  power: 100mA chip-ID: 04d9:a1cd class-ID: 0300 
  Device-2: 3-4:3 info: SteelSeries ApS SteelSeries Sensei Ten type: HID,Mouse 
  driver: hid-generic,usbhid interfaces: 4 rev: 1.1 speed: 12 Mb/s 
  power: 200mA chip-ID: 1038:1832 class-ID: 0300 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 35.2 C mobo: N/A gpu: amdgpu temp: 34.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1008 
  Processes: 372 Uptime: 35m wakeups: 0 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: 1438 pacman: 1432 lib: 411 
  flatpak: 6 Shell: Bash v: 5.1.0 running-in: gnome-terminal inxi: 3.3.03 

Remove it from MHWD and look inside /etc/modprobe.d/ and delete any occurrence of blacklist r8169 if they exist … The network is up, but is failing to properly work because of the r8168 driver.

uhm wait a minute: the “tech stuff” listed in the message before, is from the fully functioning timeshifted installation. The error manifests only if I upgrade, something I do not intend to do until I find a workaround that prevents any mess between eth driver and networkmanager or whatever the problem is. :slight_smile:

  1. Install 5.4 LTS on top of 5.10 LTS
  2. Upgrade
  3. If 5.10 fails, do an inxi there
  4. reboot into 5.4 using grub’s Advanced options
  5. Post the failed inxi because now we’re as much in the dark as you.

also please read this:

especially the section Linux has multiple kernels and the need to have a fall-back kernel.


Well, if a person wants to find a solution himself, don’t stop him. :man_shrugging:

I understand the apparent paradox, but this is a production workstation, I can’t exactly halt the work to tinker with it as I do with my “side machines” (out of the production cycle).
For now, I disabled networkmanager from updates , and will make a third attempt: should this fail too, I will disable all updates for 45 days.
I appreciate immensely the help received on this and other communities, but the primary goals is to keep operations going until there is a favorable scenario that allows to explore alternatives (at a certain point of the summer the company will close for some days, during those days I will have the opportunity to do all tests that I want).
Many thanks to all

I’m sorry to say but if you want rock-stable, you need Debian. Although it was designed as a server OS, that’s what I give my non-technical family and friends for their desktops and it just simply works and keeps on working. The disadvantage of Debian is that you don’t get the newest and shiniest versions of any application neither, but you get the most stable ones.

Manjaro (and Arch) are on the cutting edge of Linux development and I nor my technical-savvy nephew wouldn’t want anything else on our desktops, and we don’t mind filing bugs every now and then to help advance the success of the Linux story.


In the past I used Debian too, but I prefer Manjaro by a long shot and want to prove that it can be used in my field with 99.9% uptime :slight_smile:

anyway, editing /etc/pacman.conf and preventing everything ‘networkmanager’ related to update, allowed for a smooth system update. The issue is solved, thanks everyone for all the help

Just as a comment: That it’s not a solution, it’s just a temporal workaround and at some point it’s going to cause some problems. Partial updates are best to avoid in general.

1 Like