Update infinite loop

This set of updates today causes an infinite loop of Software Update progress bar moving back & forth & flashing something like wxbase-light-dependencies - it flashes so fast i cant read it, but it continues over & over & never ends.

I rebooted a few times & tried again, but the same result.

Screenshot from 2022-02-22 19-18-16

wxbase-light no longer exists, I would remove it.

Please post the output of pamac update with proper formatting.

1 Like

pamac update reports ‘checking’ for a long list of items & gets to a point where it starts going crazy with wxbase, which seems like it may continue forever. Terminal seems stuck & I cant q or esc. So I have to close window.

I am sorry I am unable to post the output because the terminal window becomes unusable.

According to software update wxcommon & wxbase-light are not installed.??

I found this reference: Pamac build AUR package stuck in an infinite loop with wxcommon-light/wxbase-light

Which packages need the wxwidegets stuff?

Not entirely sure, but I found wxgtk2 & wxgtk-common are required by woeusb-gui
Searching pamac installed for ‘wx’ these are the only 2 that show up.

After reading the other thread AUR - please restrain yourself (& being a semi-professional idiot) ; I realise this is probably my own carelessness.
I must have enabled AUR at some point to browse or acquire a certain software & then left it enabled, so I may have since inadvertently installed AUR software without noticing.
Although I was aware of the AUR risk at the time, i since forgot it was enabled.

I disabled AUR & those 8 updates went away.

1 Like

We will look into this and optimize pamac to handle this smarter.


Fixed via libpamac 11.2.0-11 and higher.


Thank you! :pray:t4:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.