Update has hung up

Update has hung up here. What should I do?

This depends.

  • If the kernel , initrd and modules are present, reboot. Then restart the update.
  • If not, you may need to boot from a Live manjaro to rerun the update.

Can you switch to a tty ? (CTRL-ALT-F3) ?

Okay, I think I’m going to need some help.

I need to chroot into my system to fix this, but I’m not sure the steps to use. I have an NVME drive and use ZFS. The pool has two partitions:

manjaro@manjaro ~]$ lsblk -f
NAME FSTYPE FSVER LABEL            UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
     squash 4.0                                                               0   100% /run/miso/sfs/livefs
     squash 4.0                                                               0   100% /run/miso/sfs/mhwdfs
     squash 4.0                                                               0   100% /run/miso/sfs/desktopfs
     squash 4.0                                                               0   100% /run/miso/sfs/rootfs
sda  iso966 Jolie MANJARO_XFCE_230 2023-09-03-04-56-45-00                              
│    iso966 Jolie MANJARO_XFCE_230 2023-09-03-04-56-45-00                     0   100% /run/miso/bootmnt
     vfat   FAT12 MISO_EFI         B395-6A0B                                           
     zfs_me 5000  rpool            11018531562457871074                                
│    vfat   FAT32                  75D9-9D09                                           
     crypto 1                      af1815ee-0155-4906-a12c-7ba8ccbe3154                

fdisk -l details:

manjaro@manjaro ~]$ sudo fdisk -l
Disk /dev/nvme0n1: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: Sabrent Rocket Q                        
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 0E732033-A74D-C54B-A391-F4164B04CCCE

Device          Start        End    Sectors   Size Type
/dev/nvme0n1p1   4096     618495     614400   300M EFI System
/dev/nvme0n1p2 618496 1953520064 1952901569 931.2G Linux filesystem

I’ve reviewed the instructions and am just stuck due to my system profile. Any help would be appreciated.

I did try to switch to TTY, but the entire system was unresponsive.

No kernal found when rebooting, so I’m going to have to use chroot via USB.

chroot, rerun update again, if no errors reinstall kernels …

Attempting to use manjaro-chroot with my encrypted root partition and I have a discovered a problem.

I’ve booted using a USB iso I downloaded a few minutes ago.

manjaro mapper]# cryptsetup luksOpen /dev/nvme0n1p2 crypt
Enter passphrase for /dev/nvme0n1p2: 
[manjaro mapper]# mount /dev/mapper/crypt /mnt
[manjaro mapper]# mount /dev/nvme0n1p1 /mnt/boot/efi
[manjaro mapper]# manjaro-chroot /mnt
chroot: failed to run command '/bin/sh': Exec format error

Not sure what the error means.

Is this serious?

I never knew that ZFS lets you create two partitions on the ZFS pool. The first of the two is FAT32 partition, the other is the encrypted partition. Is there any document about this?

Your setup would be pretty special and probably not supported by general chroot, or maybe I’m wrong.

The picture in your original post seems to indicate the update process hung while upgrading noto-fonts. I seem to remember that particular font package being quite large (in excess of a gigabyte) and taking a long time to both download and extract.
It might be a case of mistaking an exceptionally long wait time for it being hung up. If you’re confident that wasn’t the case, just ignore this. Cheers.

Indeed, that package is huge, but I waited for quite awhile. I tried opening a terminal to check on progress and that’s when I noticed the entire system had become unresponsive.

you not able to chroot is probably related to ZFS… check this from arch wiki:

maybe it would look like this?:

sudo zpool import -a -R /mnt
sudo cryptsetup luksOpen /dev/nvme0n1p2 crypt
sudo mount /dev/mapper/crypt /mnt
sudo mount /dev/nvme0n1p1 /mnt/boot/efi
sudo manjaro-chroot /mnt

Did you try the automatic switch?

manjaro-chroot -a 

or, changing to /mnt while also specifying your shell? Normally it shouldn’t be needed as the default shell would be assumed and used, but you could try it manually in case that makes a difference. Or, try bash instead (if it’s installed and active on the USB).

manjaro-chroot /mnt /bin/sh -i
manjaro-chroot /mnt /bin/bash -i

I did try the automatic switch, it did not work as it could not detect any linux partitions given my drive configuration.

I did also specify a shell in another attempt (‘/bin/bash’) and received the same error.

Ridiculously, I could not even recall how I ended up with ZFS. I ended up installilng a brand new nvme and installed the latest Manjaro. I’m now just copying the user data from the old drive (which I can still mount) and all seems well.

Also, I switched to BTFRS on the new drive. :slightly_smiling_face:

I’ve marked this as the solution as my issue is now moot. Thanks to everyone who made suggestions!

I have no experience with BTRFS - hope it works out well for you. I did find, however, an article Restore the GRUB bootloader that you might want to hold on to in case of emergencies. In particular, the brief note about BTRFS. Cheers.

Thank you, @soundofthunder

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.