Update-grub error message

When I run “update-grub” on EXT4 manjaro, I get these results:

sudo update-grub
[sudo] password for alucard:
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.14-x86_64.img
Found initrd fallback image: /boot/initramfs-5.14-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings …
Detecting snapshots …
Root partition isn’t a btrfs filesystem.
This script only supports snapshots of the btrfs filesystem.
If you think an error has occurred , please file a bug report at " GitHub - Antynea/grub-btrfs: Include btrfs snapshots at boot options. (Grub menu) "
Nothing to do. Abort.
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

When I boot up Manjaro it doesn’t show the GRUB menu instead it boots into the default kernel…

[alucard@manjaro ~]$ inxi -Fx
System:    Host: manjaro Kernel: 5.14.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: Xfce 4.16.0 
           Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: ASRock model: J5040-ITX serial: <superuser required> UEFI: American Megatrends v: P1.70 
           date: 08/13/2021 
Battery:   Device-1: hidpp_battery_0 model: Logitech K520 charge: 70% (should be ignored) status: Discharging 
           Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 3 charge: 100% (should be ignored) 
           status: Discharging 
CPU:       Info: Quad Core model: Intel Pentium Silver J5040 bits: 64 type: MCP arch: Goldmont Plus rev: 8 cache: L2: 4 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15980 
           Speed: 799 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 799 2: 799 3: 1243 4: 1241 
Graphics:  Device-1: Intel GeminiLake [UHD Graphics 605] vendor: ASRock driver: i915 v: kernel bus-ID: 00:02.0 
           Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting resolution: 2560x1440 
           OpenGL: renderer: Mesa Intel UHD Graphics 605 (GLK 3) v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio vendor: ASRock driver: snd_hda_intel 
           v: kernel bus-ID: 00:0e.0 
           Sound Server-1: ALSA v: k5.14.2-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
Network:   Device-1: Intel Gemini Lake PCH CNVi WiFi driver: iwlwifi v: kernel port: f000 bus-ID: 00:0c.0 
           IF: wlo2 state: down mac: 2a:1d:47:60:75:86 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169 v: kernel port: e000 
           bus-ID: 03:00.0 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: a8:a1:59:64:80:70 
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 bus-ID: 1-9:3 
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
Drives:    Local Storage: total: 558.92 GiB used: 25.07 GiB (4.5%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB 
           ID-2: /dev/sdb vendor: Crucial model: CT120BX500SSD1 size: 111.79 GiB 
Partition: ID-1: / size: 438.75 GiB used: 25.07 GiB (5.7%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 210 Uptime: 8m Memory: 7.18 GiB used: 1.76 GiB (24.6%) Init: systemd Compilers: gcc: 11.1.0 
           Packages: 927 Shell: Bash v: 5.1.8 inxi: 3.3.06

Hello and Welcome,

Just an idea… Open Settings go to Session and Startup → click on Application autostart
Unthick Snapshot detect reboot and try again.

:crossed_fingers:

I think the error is not important. I suppose you installed grub-btrfs package. Uninstall it and try again.

By default grub is not shown if you have only one operating system. You can show it pressing Escape key during boot (around the time grub should be shown. It’s just hidden).
You can also change the GRUB_TIMEOUT_STYLE parameter in /etc/default/grub

GRUB_TIMEOUT_STYLE=menu

After that you have to execute sudo update-grub

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.