Update failed to synchronize to databases

good morning hive mind.

I’m new to manjaro not sure what made me switch from installing linux mint idk…
anyway i’m having an issue updating the system. only error it gives is unable to synchronize to databases. i also cant install anything from the app store thing.
when i go to download an app it just says target not found…

i have internet that was fun to figure out but easy once i remembered i had a linux wifi dongle so i guess that would be another issue i have plasma wont use my onboard wifi from my motherboard…

sorry im fairly new i know somethings are the same some are not i also primarily use windows but afew things made me switch back to linux figured try out a different distro

running KDE plasma 6.0.4
kernel 6.9.0-1

System specs:
MOBO Asus Rog Strix X570-I gaming
ram 32GB
cpu Ryzen 7 5700X
storage way more then i need lol

if you guys need any more info let me know.

I’m not new, but I also don’t know of all the possible reasons and the remedies for them off the top of my head.

What I usually do is ask Google.

So, to be able to help you, I’d have to google and read and then link you back to what I found.

Why don’t you try to do that - copy paste your thread title into a search engine or the forum search here
possibly by adding Manjaro to the search term
and read some
and then tell us what you did if you could not solve your issue?


1 Like

i tried searching the forum but ill try google next thank you

Even if you are connected to the internet - a new installation is likely to require a sync of metadata (database) from a current mirror - up-to-date that is

sudo pacman-mirrors --continent

Then sync your system

sudo pacman -Syu

If you do not have internet connection

For a user new to Manjaro world


I think you’ll find most of us are individuals, in the forum, in fact some can be quite, err… unique…

Without going into details, I’d simply like to offer an opinion - always use pacman to perform updates, as @linux-aarhus has already described in the post before this. Avoid using pamac or it’s GUI equivalent ‘Add/Remove Software’ wherever possible (for reasons that will become obvious as you spend time on these forums).

That is all. Cheers.

1 Like

how would you update if you dont recommend using pacman GUI?
im fairly new to linux i no sudo can do alot in terminal

sudo pacman -syu and -syyu dont work just says error invalid option -s

when i go to update one pkg in terminal i get the update failed to sycronize to database…

There is no pacman GUI - the GUI you mean is the frontend to pamac.
Looks similar, but is a different name and program.

Similarly here:

… case sensitive - not -s but -S


well that worked… good to know lol
thank you!

Just to confuse you even more…

sudo pacman-mirrors --continent && sudo pacman -Syu

This strings both commands given earlier together; thereby refreshing the mirrors and performing an update with the same command combo.

See? You’re learning already!


sweet! now to write this all down!

thank you!

sudo pacman-mirrors -g -f5
pamac upgrade --force-refresh

that command allowed me to be able to download stuff from the gui over getting target not found errors. this forum im going to learn alot from i think lol

Welcome to the forum! :vulcan_salute:

You need to refresh your mirrors. :point_down:

sudo pacman-mirrors -f && sudo pacman -Fy && sudo pacman -Syu

Be sure to let it finish, no matter how long it takes. Do not interrupt the process!