Update error - unsure of update cycles/consequences

At least linux58-nvidia-450xx 450.80.02-3 has been pushed to stable. And of course it depends on other package that hasn’t been pushed to stable.

I’m pretty sure I’m on stable and I got this update and dependency error too. I don’t think this thread title is correct. It’s not about being unsure. The issue is that the stable is getting testing updates, which doesn’t work properly.

1 Like

Sounds correct. I’m on stable as well.

The fix has been pushed to stable now. Just wait a while for your mirror to update before running the update.

4 Likes

Thanks a lot for taking care of this @Chrysostomus

Not quite the same … less packages.

Sometimes this can happen. Hopefully this will not trigger a bad vibe :slight_smile:
All should be fine.

1 Like

Hi! It looks like the linux-nvidia packages were updated but not its nvidia-xxx-utils counterparts, causing unresolvable dependencies.

warning: cannot resolve "nvidia-450xx-utils=450.80.02", a dependency of "linux54-nvidia-450xx"
:: The following package cannot be upgraded due to unresolvable dependencies:
  linux54-nvidia-450xx

I see the updates on the gitlab, so they should have been included in the update (/nvidia-450xx-utils/-/commit/c279e9aee38ed027fec56a1763c7591ba8d66c80). Last packager was @schinfo.

Did you make sure to refresh your mirrors and force refresh your database and try the update again? I’m maybe mistaken but from the Branch Compare website it seems to be OK to me.

Yep, refreshed my db and still the same issue. In fact, nvidia-450xx-utils is not on the list of upgraded packages, and this seems to be a widespread issue (/t/dependency-of-nvidia/32713/5).

I don’t know then Manjaro - Branch Compare what should I look for? To me it’s OK, all on 450.80.02.

1 Like

Same issue with nvidia dependencies here. By the way, I’m on Stable branch, but received update notification a minute go, so I guess the update is going from testing to Stable?

Why do you report Stable branch issues in the Testing branch thread then? Is the issue with Nvidia in this update on Testing branch?

1 Like

Because I just received this update (which is marked as Testing at the moment) as Stable update. It’s not the first time forum information is a bit out-of-date regarding updates (for example, Testing update is released as Stable update and is available to all users, but such information is posted to forums just a day later or so).

Because this is the only update today… So please point me to where I should post this instead.

By the way, your branch compare link (very useful) shows exactly the issue we’re talking about for the Stable branch.

OK then, but this is the thread for the Testing branch so if you report here for the Stable branch, which you shouldn’t, at least say it so that nobody waste his time trying to figure it out.

Here you go Stable Updates - Manjaro Linux Forum

1 Like

getting dependency errors with libvirt:

:: unable to satisfy dependency ‘libvirt=6.5.0’ required by libvirt-storage-gluster
:: unable to satisfy dependency ‘libvirt=6.5.0’ required by libvirt-storage-iscsi-direct
:: unable to satisfy dependency ‘libvirt=6.5.0’ required by libvirt-storage-rbd

Is this maybe to do with the update from 6.5.0-2 to 1:6.5.0-2?

regards

I think you are being a little bit arrogant. A user is informing you that an update that is supposed to be to the testing branch has being pushed to the stable branch. So something is odd here.

3 Likes

[Stabiles Update] 2020-10-19 ??

:: Starte vollständige Systemaktualisierung…
Warnung: sndio: Lokale Version (20180120-1) ist neuer als community (1.7.0-1)
Löse Abhängigkeiten auf…
Warnung: Kann “nvidia-450xx-utils=450.80.02” nicht auflösen (eine Abhängigkeit von “linux419-nvidia-450xx”)
Warnung: Kann “nvidia-450xx-utils=450.80.02” nicht auflösen (eine Abhängigkeit von “linux54-nvidia-450xx”)
:: Die folgenden Pakete können aufgrund nicht auflösbarer Abhängigkeiten nicht aktualisiert werden:
linux419-nvidia-450xx linux54-nvidia-450xx

:: Möchten Sie die obengenannten Pakete bei dieser Aktualisierung überspringen? [j/N] N
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Unerfüllbare Abhängigkeit ‘nvidia-450xx-utils=450.80.02’, benötigt von linux419-nvidia-450xx
:: Unerfüllbare Abhängigkeit ‘nvidia-450xx-utils=450.80.02’, benötigt von linux54-nvidia-450xx

nvidia-450xx-utils=450.80.02

Same happends me today. im on stable, but I got this update …?

You can think what you want I don’t really care. The crucial information, the issue being on STABLE BRANCH, was missing all along. I tried to figure it out to end up reading “by the way, I’m on STABLE”, so… yeah I’m arrogant?

please wait mirror end updating

and philm will put an announce in stable