Update error no matter what I try, It is not helping

No matter what I do it is never updating.

Neither from Cli or pamac - GUI update manager.

Please help me out, I need updates as I am a aspiring software developer and still a student in university.

sudo pacman -Syudd
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 sublime-text.db failed to download
error: failed retrieving file 'sublime-text.db' from download.sublimetext.com : Resolving timed out after 10001 milliseconds
error: failed to synchronize all databases (download library error)

Here is the error, but whatever I do, even when the error is not there it still doesn’t update.

Help me, soon. I love Manjaro but facing this issue from months.

Even I tried updating using the command:

sudo pacman -Syyu

or similars.
I tried even


all the things I could have done with the help of this webpage.

That is not a repository managed by Manjaro. You should remove it from /etc/pacman.conf.


If it is not a repository managed by Manjaro, then it was there?
I wasn’t the one to put it there.
I infer if it was there, then some functional value it must be possessing, right?
Hope you understand what I am trying to know.

In short, Trying to know that, if it is there, then it must be for some use to something, right? or else why a line will exist in a place where it should’nt be?

You probably installed sublime text in some non-supported way that automatically added it there.


You or someone else added it, presumably so you could install sublime-text.


However it’s also in the AUR, and that’s less likely to cause issues.

So as @maycne.sonahoz said, remove the repo from /etc/pacman.conf. If you want sublime-text install it from the AUR.

1 Like

It appears sublime-text was installed as suggested by sublimetext.com/docs/linux_repositories - pacman

The echo | tee command suggested would add this to pacman configuration


Server = https://download.sublimetext.com/arch/dev/x86_64

But that download link is borken - File not Found

I suggest:

  • remove current version of sublime-text

  • remove changes to /etc/pacman.conf

  • install sublime-text-4 from AUR - pamac build sublime-text4

  • Read forum guidelines and stop posting text as headlines


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.