Update error: installing icu (74.2-1) breaks dependency 'icu<74.2' required by manjaro-settings-manager

I’m finally able to start the latest update process and hit an error:
:: installing icu (74.2-1) breaks dependency ‘icu<74.2’ required by manjaro-settings-manager

I noticed that this is similar to a previous post
(Cannot upgrade due to new icu v74 dependency) and thought that maybe my mirrors weren’t up to date, but after trying all of the mirrors in my country (and some neighboring countries) as well as a couple other ones I would expect to be up to date (MIT and Sweden), I’m guessing that there is simply a dependency mismatch(?)

(I can’t access https://repo.manjaro.org to check the actual mirror sync status.)

Any tips would be appreciated~

Happy New Year!

Please try resetting mirror list

sudo pacman-mirrors -c all && sudo pacman -Syu

(PS. If I may make some inference from ‘mandarin’ … no chinese mirrors are currently fully synced)

(PPS. One taiwanese mirror is currently fully synced)

HI cscs,
Thank you for your reply!
I tried running pacman-mirrors before, but it just hangs.
Inference correct! Although I’d expect at least some of the other ones I tried to be synced (SK, Singapore, MIT, etc.?)
Good to know about the TW mirror! (If that’s okay to use here…)

So it’s most likely a syncing issue then? (I just have to pick the right mirror or wait a couple days?)

I just tried another way to access repo.manjaro.org and was able to look up the servers - it’s a little different from what you posted, so I don’t know if that’s just because more servers have synced in the last 2 hours or not. Regardless, I still get this error even if I use one of the servers shown as fully synced (tried nju, sjtug, freedif (Singapore) and kku (Thailand), all with no success…

If you are inside China, this is possible due to limitations imposed on your network traffic.

In such case you can use pacman-mirrors to set a specific mirror e.g.

sudo pacman-mirrors -aU https://mirrors.sjtug.sjtu.edu.cn/manjaro

Hi @linux-aarhus,
Thank you for this tip! Unfortunately, the original error remains (even if I select one of the in-sync mirrors).

Just to clarify: I ran the command you suggested (with sjtug). I had previously manually edited the mirror list to prioritize the nearest in-sync mirrors that I found.

You can remove the package - then sync the system - and when done reinstall the package - note that you may get an error if you are using Plasma. Simply add those packages to the removal command.

sudo pacman -Rns manjaro-settings-manager

Package info (unstable branch)

 $ pamac info manjaro-settings-manager
Name                  : manjaro-settings-manager
Version               : 0.5.7-20
Description           : Manjaro Linux System Settings Tool
URL                   : https://gitlab.manjaro.org/applications/manjaro-settings-manager
Licenses              : GPL
Repository            : extra
Installed Size        : 6,0 MB
Groups                : --
Depends On            : icu<75 qt5-base hwinfo kitemmodels5 kauth5 kcoreaddons5 ckbcomp xdg-utils
Optional Dependencies : manjaro-settings-manager-notifier: qt-based
                        manjaro-settings-manager-knotifier: knotifications-based
Provides              : --
Replaces              : --
Conflicts With        : kcm-msm
Packager              : Mark Wagie <mark@manjaro.org>
Build Date            : tir 26 dec 2023 17:54:24 CET
Validated By          : MD5 Sum  SHA-256 Sum  Signature

1 Like

@linux-aarhus Thank you for your suggestion!

I followed your instructions (I had to uninstall 3 packages), ran sudo pacman -Syu and it worked!
(Well, it took a couple tries - I had to ignore one package that was giving me errors, run the update, then update that package and reinstall the 3 removed packages).

I believe I’m good now. There is a weird mis-match between the GUI package manager telling me that I have updates while pacman says I’m all updated.

Details are posted for curiosity. However, I’m going to mark your last post as the answer since it solved my update error.

After updating, the package manager GUI tells me there are 44 updates available, but when I run it, I just get

Synchronizing package databases...
Warning: archlinux-keyring: local (20231222-1) is newer than core (20231207-1)
Warning: dkms: local (3.0.11-2) is newer than extra (3.0.11-1)
Warning: inxi: local ( is newer than extra (
Warning: nano-syntax-highlighting: local (2020.10.10+10+g1aa64a8-2) is newer than extra (2020.10.10-1)
Warning: plymouth: local (22.02.122-15) is newer than extra (22.02.122-7)
Warning: steam: local ( is newer than multilib (
Warning: steam-native-runtime: local ( is newer than multilib (
Resolving dependencies...
Checking inter-conflicts...
Transaction successfully finished.

And running sudo pacman -Syu gives

:: Starting full system upgrade...
warning: archlinux-keyring: local (20231222-1) is newer than core (20231207-1)
 there is nothing to do

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.