Update broke SMPlayer/mpv (libglslang.so.12)

We got a large Manjaro update yesterday and now SMPlayer isn’t working anymore (using mpv).
Here’s the error:

/usr/bin/mpv: error while loading shared libraries: libglslang.so.12: cannot open shared object file: No such file or directory

Sorry for my English.

Is owned by glslang and is the same version on all branches now. Did you reboot the system after update, did you reinstalled glslang?

I did reboot after the update and never touched glslang.
I’m looking at it right now. For some reason, I have glslang-git package from the AUR instead of the official glslang package.

After replacing glslang-git with glslang, I get another error:

Warning: option --input-x11-keyboard was replaced with --input-vo-keyboard and might be removed in the future.
Warning: option --ass-line-spacing was replaced with --sub-ass-line-spacing and might be removed in the future.
Warning: option --sub-text-shadow-color was replaced with --sub-shadow-color and might be removed in the future.
Error parsing option softvol (option not found)
Setting commandline option --softvol=yes failed.
Exiting... (Fatal error)

I checked SMPlayed config but so far, I couldn’t find this softvol option anywhere.
Note: mplayer is working just fine, only mpv crashes.

Found it. In SMPlayer, settings, general, audio tab → unckeck “use software volume control”.
Now it works.

Cannot reproduce (and never experienced similar with mpv engine and software volume control) on Unstable branch. Though maybe I should note that the multimedia engine section is set to
'Other' > /usr/bin/mpv for whatever thats worth.

I was facing this issue with mpv a few months ago, where video becomes laggy and sound sync goes off after a pause. (mpv loses audio/sub sync (and laggy video) when pause/resume the video · Issue #10795 · mpv-player/mpv · GitHub)
At that time, I installed pipewire to try and fix it. It didn’t work. I can’t remember but I guess this is when I installed glslang-git, which probably solved the issue at that time.
Now mpv has been updated to use glslang 12 but glslang-git is still version 11, which caused the first issue.
I have no idea where the softvol problem comes from, but I may have broken something when installing pipewire a few months ago. If it works on a fresh install, then it’s definitely a problem on my setup.

I solved the same problem (audio sync) by adding in
but i use pulseaudio and i don’t know if it works with pipewire
you can try if it works by starting a video from terminal with
mpv --pulse-latency-hacks=yes videofilename.mp4

Just to note here - a git package in AUR rarely have their listed version bumped. Rather building or rebuilding the package should source the latest upstream git.
Secondary note - It is common that AUR packages may need to be rebuilt after a regular system upgrade.

1 Like