Update broke my NVIDIA drivers

Hi, I just recently did “sudo pacman -Syu” to upgrade my system, but my Nvidia Driver was therefore broken.

I’m using 5.12.1 kernel, and 460.80 driver.

Since lsmod | grep nvidia gives me nothing, I thought the driver was not loaded, so I tried sudo modprobe nvidia to load the driver manually, but I got modprobe: ERROR: could not insert 'nvidia': Exec format error

I’ve disabled nouveau, so there should be no problem with the open-source driver?

Any idea would be appreciated!


nouveau is the open-source driver, so not sure what kind of problem you talk about.
To me it looks like a broken or partial update. From TTY:
sudo pacman-mirrors -f5 && sudo pacman -Syyu
and see if something changes, then reboot, and if is not working, try to force the reinstall of nvidia drivers.
sudo mhwd -f -i pci video-nvidia


Welcome to the forum! :wave:

Please post your system info as outlined here:

Also please post the output of:

mhwd -li

It’s modprobe, not mod probe. :wink:

How? You can only have one driver installed. Either the proprietary driver is installed and working (which is not) or vice versa.

I’ve tried those two, but sadly both of the methods did not work :frowning:
I just got informed that all of my packages are already the newest, so nothing was updated.

For the system information:

  Kernel: 5.12.1-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64
  root=UUID=9e257a78-e75a-4100-ac44-5b8c360a439e ro quiet splash apparmor=1
  security=apparmor resume=UUID=a121aca2-4950-4a87-a927-f30dfa9eadff
  Console: tty pts/0 DM: GDM 40.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX Z370-F GAMING v: Rev X.0x
  serial: <filter> UEFI: American Megatrends v: 0606 date: 12/12/2017
  Message: No system battery data found. Is one present?
  RAM: total: 15.56 GiB used: 456.3 MiB (2.9%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: 6-Core model: Intel Core i7-8700 bits: 64 type: MT MCP arch: Kaby Lake
  note: check family: 6 model-id: 9E (158) stepping: A (10) microcode: DE
  cache: L2: 12 MiB bogomips: 76831
  Speed: 800 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800
  4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep smx ss ssbd sse sse2
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
  xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Micro-Star MSI driver: N/A
  alternate: nouveau, nvidia_drm, nvidia bus-ID: 01:00.0 chip-ID: 10de:1b80
  class-ID: 0300
  Display: server: X.org 1.20.11 driver: loaded: nvidia unloaded: modesetting
  alternate: fbdev,nouveau,nv,vesa tty: 80x25
  Message: Advanced graphics data unavailable in console. Try -G --display
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
  class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f0
  class-ID: 0403
  Sound Server-1: ALSA v: k5.12.1-2-MANJARO running: yes
  Sound Server-2: JACK v: 0.125.0 running: no
  Sound Server-3: PulseAudio v: 14.2 running: no
  Sound Server-4: PipeWire v: 0.3.28 running: no
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
  port: f000 bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.96 TiB used: 57.78 GiB (1.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Plextor model: PX-256M8PeGN
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 rotation: SSD serial: <filter> rev: 1.06 scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA200 size: 1.82 TiB
  block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  rotation: 7200 rpm serial: <filter> rev: ABB0 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA100
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  rotation: 7200 rpm serial: <filter> rev: A750 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 229.37 GiB size: 224.77 GiB (97.99%)
  used: 57.78 GiB (25.7%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: 9e257a78-e75a-4100-ac44-5b8c360a439e
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
  uuid: 4D1E-63F7
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A
  uuid: a121aca2-4950-4a87-a927-f30dfa9eadff
  ID-1: /dev/sda1 maj-min: 8:1 size: 1.82 TiB fs: ntfs label: N/A
  uuid: 1E747C6A2A2679F8
  ID-2: /dev/sdb1 maj-min: 8:17 size: 931.51 GiB fs: ntfs label: N/A
  uuid: 069AEF0E7015C576
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: Genesys Logic microSD Card Reader type: Mass Storage
  driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 98mA
  chip-ID: 05e3:0751 class-ID: 0806
  Device-2: 1-6:3 info: Holtek USB-HID Keyboard type: Keyboard,HID
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 04d9:0296 class-ID: 0300
  Device-3: 1-8:4 info: ASUSTek AURA LED Controller type: HID
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 0b05:1872 class-ID: 0300 serial: <filter>
  Device-4: 1-13:5 info: Logitech Unifying Receiver type: Mouse,HID
  driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
  power: 98mA chip-ID: 046d:c52f class-ID: 0300
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 29.8 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
  Processes: 196 Uptime: 8h 37m wakeups: 0 Init: systemd v: 248
  tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1484
  lib: 379 flatpak: 0 Shell: Zsh v: 5.8 running-in: tty pts/0 (SSH)
  inxi: 3.3.04

I got this with mhwd -li

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!

Sorry I knew it should be modprobe, just a typo.

For disabling nouveau, all I did was basically put

blacklist nouveau
options nouveau modeset=0

in a .conf file, and update the initramfs then reboot, and I thought it did work?

You do not have the proper driver installed, but rather the unwanted one … please run:
sudo mhwd -r pci video-modesetting
sudo mhwd -i pci video-nvidia

Also you have to enable early KMS on that ROG STRIX model according to this Asus Strix ROG RTX 3090 OC not working with latest NVIDIA drivers. / Installation / Arch Linux Forums regardless is a different Nvidia GPU model.

1 Like