Update broke 2-in-1/tablet screen rotation

Hi there,

Sorry if this is off topic or in the wrong category, this is my first post. I have a dell 2-in-1 (model number 7425 running a AMD 5625U CPU) laptop running Manjaro KDE stable, and on the previous version of Manjaro (23.1?) I used the package iio-sensor-proxy to automatically rotate the screen when I flipped the screen backwards into tablet mode, but ever since upgrading to Manjaro 24 (and plasama 6?) the screen no longer automatically rotates, I tired switching to the iio-sensor-proxy-git package and noting changed. The issue happens on both x11 and Wayland, hopefully writing this post helps other people with 2-in-1 laptops running into the same issue.


Hi hopefully you can help me. Just upgraded to dell 7630 2-in-1. Can you get KDE to launch the on screen keyboard when entering tablet mode? So far the only DE that works properly (rotate and on screen keyboard) is gnome but I’d much rather use KDE


Sadly I never got the onscreen keyboard to work, however, the Steam Deck uses KDE and has an onscreen keyboard so it should be possible, maybe poking around in that direction could lead to results. Do let me know if you solve the issue

1 Like

Shame, really want to use KDE on this 2-in-1 but everything just works out of the box on gnome. Rotation, touch, tablet mode it all just works out of the box on gnome. Guess it’s probably easier to learn how to theme/customise gnome

The virtual keyboard works only on Wayland.

Just install maliit-keyboard
sudo pacman -S maliit-keyboard

then enable it

Log to Wayland and set Touch mode

I was blind, the auto rotation issue is an easy fix, go into “Display configuration”, under “Orientation” make sure “Automatic” is selected and make sure “Only in tablet mode” is unchecked! I don’t know what tablet mode is, could someone enlighten me.
I’m on wayland and haven’t yet figured out how to do the virtual keyboard, but will get around to it soon.

I could get the on-screen keyboard working but couldn’t get it to automatically activate when in tablet mode. I had to toggle it on each time I needed it

“Tablet mode” is an event sent by the kernel based on hardware switch input such as lid switch. Tablet mode is when the 2-in1 laptop is in tent or tablet position.
Kernel events are EV_SW or SW_TABLET_MODE .
Run terminal evtest and / or sudo libinput debug-events to see if your laptop kernel sends this event out (when folding lid from normal to tablet position).
As far as I understand both DE’s, gnome 46 and kde 6, do auto-activate when in tablet-mode: screen auto-rotation, touchpad disabled, keyboard disabled, onboard keyboard enabled .
But that is theory for some (or most?) 2-in-1’s because there are no EV_SW or SW_TABLET_MODE kernel events regardless lid position even with latest kernels (linux69 at time of this comment).
For some 2-in-1 models there are workarounds on AUR or github that generate this kernel event purely based on touchscreen orientation, such as https://github.com/asus-linux-drivers/asus-accel-tablet-mode-driver
Background for kernel event see here: https://wayland.freedesktop.org/libinput/doc/latest/switches.html#tablet-mode-switch-handling
Based on the kde developer string on kde.org that I read, I believe “touch mode” in the KDE menu screenshot above actually means “tablet mode” as soon “automatically enable as needed” is enabled. Quite confusing.