Update Breakage with nvidia GPU (RTX3060) linux 512 and X

I have updated my Install yesterday, which included upgrades from Kernel 5.12.1 to 5.12.2 and some other stuff. Starting X instantly deadlocks and i can’t access ttys. Doesn’t matter if nvidia drivers are installed via mhwd or manually using the nvidia-dkms package. I am now on my Intel iGPU but would like to use my GPU again, what can i do?

There is a known issue posted in the update with workarounds. Most likely you use Display Port and a large resolution screen.

I use two Display Port outputs and have WQHD monitors. Will report later if using HDMI worked

Have the same setup but with a GTX1080 instead … and I ran into the same issue - was close to reinstalling to be honest.

Hooking the display up with HDMI worked immediately.
How the f*** this glaring issue was 1. Not found in testing or 2. totally ignored when releasing this to stable is completely beyond me, tbh. It’s not like DP and/or high resolutions are uncommon when using dedicated GPUs …

Edit: I even tried testing branch - ( 465.27 ) but nope does not work either … have to use HDMI for now ffs.

Its not in the behold of the Manjaro maintainers, this has already been an issue known to Nvidia. Blame them for not making proper drivers. You can still roll back to the old driver and then pin the version in your pacman.conf (will do that later and tell you how to do that, promised).

ok so:
if you really want the older drivers make sure that the old version of your nvidia drivers are still in the pacman cache located at /var/cache/pacman/pkg

I for myself installed them manually with the dkms package so for me my pacman line is
sudo pacman -U /var/cache/pacman/pkg/nvidia-dkms-460.73.01-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/nvidia-utils-460.73.01-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/lib32-nvidia-utils-460.73.01-1-x86_64.pkg.tar.zst
460.73 was the latest working version for me
phil linked the blog post where a link to the old drivers are, if you dont find them in your cache you can still download them from there and use the same command like me just with a different location. Then you can reboot to try if it worked for you.

After reboot you need to edit your pacman.conf or else you will just update again with the 460.80 packages that broke everything. For that do sudo vim /etc/pacman.conf (or use nano, your choice, I am used to vim). Look for the line that says IgnorePkg, uncomment and type in the names of the packages you just downgraded, for me the line would be IgnorePkg = nvidia-dkms nvidia-utils lib32-nvidia-utils after editing. You can confirm that your edit did its job by opening pamac and and looking at the updates tab, it should show the downgraded packages but shouldn’t offer you to upgrade them.

This should fix it until Nvidia did their f***ing job.



For my part, I was relying on the video-nvidia package provided via mhwd on the stable branch which proved to be an issue since when doing my regular morning update and reboot, I was hit by a black screen.

About the downgrade:
I was punished with compatibility issues when trying to install the packages via the PKBUILD file provided in the link above.

Maybe I had issues since I’m not experienced enough with building dkms and deploying them - which is why I trusted mhwd to take care of it.

Anyway what I ended up doing (in case someone else got this issue) - which is most likely not the most elegant way:

  • download the nvidia-460.73.01-PKGBUILDs.zip from the sourceforge repo and unzip
  • remove the video-nvidia in Hardware Configuration tool
  • reboot
  • get stuck in terminal and switch to next tty ( ctrl+alt+F2)
  • login and build the PKGBUILD file in nvidia-utils where you unzipped the file earlier
    • makepkg -si
  • regenerate new xorg.conf using nvidia-xconfig
  • reboot and pray

As mentioned, this is most definitely NOT the best way and someone might come along and provide a better way but for me at least it worked and I’m (back) on 460.73.01 … with working Display-Port…

well in your case you could try downgrading mhwd-nvidia which should force a driver downgrade as well. I don’t really know about the vanilla nvidia package tho as I always used the dkms drivers since i know about them. They will compile the needed modules appropriate for your kernel when you update which is easier for troubleshooting and allows you to use different kernels as well. If you feel unsure about installing the drivers manually tho you can just rely on mhwd, you would have to downgrade mhwd then tho, to not update your graphics driver on accident.

Oh… yeah… thanks for the reminder.
What I ALSO did was to put it, just like you did in IgnorePkg.

  • in /etc/pacmman.conf
  • IgnorePkg = mhwd-nvidia nvidia-dkms nvidia-utils opencl-nvidia

As you are using the vanilla nvidia driver I would suggest you also pin that one, just to make sure
when an update fixes the problem you can still unpin the packages

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.