[Unstable Update] November 2023 Edition

Anybody else noticed that screen-sleeping has turned into screen-dimming?
Not sure if it is kernel66 or latest nvidia drivers.

Nvidia introduced the possibility for night colors in wayland, might have had strange effects on x11?


I don’t know if you’re using KDE, but in it it seems there’s a new option now to dimm the screen before it goes into sleep. If you have wide ranged values it can appear that the screen only goes dimm until the screen sleep timer kicks in.

Still presuming you’re on KDE, the setting can be found in System settings → Power management

1 Like

OMFG!!! I would never have looked there. I checked it the first time it happened and there was DEFINATELY no checkbox so I would not go back and check again!
Must have been updated after, or I was blind.

Thank you! :heart:

Now I have to make sure the rest is working, because I THINK it went into sleep instead of turning the monitor off after dim time ended.

1 Like

Yeah! I think it came very recently with one of the updates :yum: You’re very welcome, cheers! :beers:

Regarding kpeoplevcard: this is only a matter of versioning schema convention, the newest package version is supposed to be 0.1-2 but the previously installed (Manjaro packaged) version is 0.1+r38.32d50a9-1 which semantically seems more recent.

This is the manual bypass that worked for me:

sudo pacman -S kpeoplevcard=0.1-2

Yay was trying to offer all sorts of modifications (upgrades/downgrades) to make it work but no option seemed to work, same goes for pamac, running this command fixed it.

Yes, see

Continuing the discussion from [Unstable Update] 2023-10-08 - GNOME 45:

Well, dude, its in the other branches now.

The point was to report and inquire. For some reason you couldnt respond to either in a reasonable manner.

So its going to continue to be asked … and continue to look like a mistake.

Even if no other action is taken … you could clarify that its intentional for debugging or something instead of getting mad at the question.

Though … if that were the purpose … why in production to the branches and for so long? …

In case you forgot, this is a reminder :wink:

The problem I brought up in the previous thread seems to be an Nvidia issue:

I can live with dips to 72 frames-per-second 'til the fix, but this is awful for people with 75 Hz monitors…

3 posts were split to a new topic: Problems updating latte-dock-git

Feature drivers need time to mature. That is why we kept production drivers in stable and testing branches of Nvidia for now.

I’m on unstable also - fully updated - but I see no problem with octopi here ?
As a matter of fact, I don’t see problems anywhere ! :slight_smile:

Turns out it was a false alarm at the OP’s system…




You should have read the linked thread: a config file was identified as the culprit and it was resolved by removing it and letting it recreate.


The update to sudo 1.9.15.p2-1 generated /etc/sudoers.pacnew. Are there any important changes that I should merge?

Thats what the pacnew is for.


the new Linux 67 kernel has been named as rc7 rather than rc1 which is current…
[New Packages]

firefox developer edition is behaving strange after kernel rebuilding.

One could suspect that hardware acceleration is in play - I am not completely sure why it is hanging - actually completely freezing the system - a switch to console (TTY)
takes 5s to complete - running a pkill firefox brings system back from the ‘dead’

[master U:1 ?:4] $ uname -r
[master U:1 ?:4] $ inxi -SCGm
  Host: tiger
    Kernel: 6.7.0-rc1-next-20231114-1-next-git-01346-g5ba73bec5e7b-dirty
    arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.27.9 Distro: Manjaro Linux
  System RAM: total: 64 GiB note: est. available: 62.63 GiB
    used: 4.35 GiB (6.9%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: 12-core model: AMD Ryzen Threadripper PRO 5945WX s bits: 64
    type: MT MCP cache: L2: 6 MiB
  Speed (MHz): avg: 1893 min/max: 1800/7015 cores: 1: 1800 2: 1800 3: 1800
    4: 1777 5: 1800 6: 1800 7: 1800 8: 1800 9: 1800 10: 1800 11: 1800 12: 1800
    13: 1800 14: 1800 15: 1800 16: 1800 17: 1800 18: 1800 19: 1800 20: 1777
    21: 1800 22: 4100 23: 1800 24: 1800
  Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX] driver: amdgpu v: kernel
  Display: wayland server: X.org v: with: Xwayland v: 23.2.2
    compositor: kwin_wayland driver: X: loaded: modesetting dri: radeonsi
    gpu: amdgpu resolution: 5120x1440~120Hz
  API: EGL v: 1.5 drivers: radeonsi,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.1.9-manjaro1.1
    renderer: AMD Radeon RX 7900 XTX (gfx1100 LLVM 16.0.6 DRM 3.56

Using backup browser Vivaldi to write this.

Normal firefox seems to be less unaffected … although hanging can be observed for a few seconds - system becomes unresponsive - no mouse movement etc. - the returns to normal after a few seconds.

No problems here but everything here is so different I doubt it will help…
I have been using 6.7 since the middle of the merge window, all Manjaro patches are commented out for my build
Firefox Dev 120.0b9 (64-bit) is the Mozilla build

[hjw@tux ~]$ inxi -SCGm
  Host: tux Kernel: 6.7.0-1-TUX arch: x86_64 bits: 64 Desktop: Xfce v: 4.18.1
    Distro: Manjaro Linux
  System RAM: total: 16 GiB available: 15.51 GiB used: 2.01 GiB (13.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: quad core model: Intel Core i5-6500 bits: 64 type: MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 800 min/max: 800/3600 cores: 1: 800 2: 800 3: 800 4: 800
  Device-1: Intel HD Graphics 530 driver: i915 v: kernel
  Display: x11 server: X.Org v: 21.1.9 driver: X: loaded: modesetting
    dri: iris gpu: i915 s-res: 1920x1080 resolution: 1920x1080
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.

Whoooops! Thank you. I was a little tired when I pushed that PKGBUILD last night, I guess …
Fixed now and currently rebuilding.

After a rest and returning to my computer - I find the freeze and hanging to be more widespread.

Vivaldi is hanging so I am thinking GPU driver - all kernel based on my system.

I have rebuilt kernel to

 $ uname -r

But I had to use Xorg where I usually use plasma-wayland-session - to be able to open a brower to do followup

EDIT: switching between wayland and xorg is ATM the difference between a working system or a hung system - so I am thinking

 $ grep /var/log/pacman.log -e wayland
[2023-10-03T13:08:36+0200] [ALPM] removed kwayland (5.110.0-1)
[2023-10-03T13:08:41+0200] [ALPM] upgraded qt5-wayland (5.15.10+kde+r57-1 -> 5.15.10+kde+r62-1)
[2023-10-03T13:08:42+0200] [ALPM] installed kwayland5 (5.110.0-1)
[2023-10-03T13:08:43+0200] [ALPM] upgraded kwayland-integration (5.27.8-1 -> 5.27.8-2)
[2023-10-06T08:18:50+0200] [PACMAN] Running 'pacman -Syu plasma-wayland-session'
[2023-10-06T08:18:52+0200] [ALPM] installed xorg-xwayland (23.2.1-1)
[2023-10-06T08:18:52+0200] [ALPM] installed plasma-wayland-session (5.27.8-2)
[2023-10-09T13:20:52+0200] [ALPM] upgraded qt5-wayland (5.15.10+kde+r62-1 -> 5.15.11+kde+r59-1)
[2023-10-10T07:39:54+0200] [ALPM] removed wayland-utils (1.2.0-1)
[2023-10-18T06:07:51+0200] [ALPM] installed qt6-wayland (6.6.0-1)
[2023-10-22T07:25:13+0200] [ALPM] upgraded kwayland5 (5.110.0-1 -> 5.111.0-1)
[2023-10-25T11:03:14+0200] [ALPM] upgraded qt5-wayland (5.15.11+kde+r59-1 -> 5.15.11+kde+r60-1)
[2023-10-25T11:03:16+0200] [ALPM] upgraded kwayland-integration (5.27.8-2 -> 5.27.9-1)
[2023-10-25T11:03:16+0200] [ALPM] upgraded plasma-wayland-session (5.27.8-2 -> 5.27.9-1)
[2023-10-26T10:28:49+0200] [ALPM] upgraded xorg-xwayland (23.2.1-1 -> 23.2.2-1)
[2023-10-26T10:28:49+0200] [ALPM] upgraded plasma-wayland-session (5.27.9-1 ->
[2023-11-09T01:04:41+0100] [ALPM] upgraded plasma-wayland-session ( ->
[2023-11-14T10:17:37+0100] [ALPM] upgraded kwayland5 (5.111.0-1 -> 5.112.0-1)
[2023-11-14T10:17:39+0100] [ALPM] installed lib32-wayland (1.22.0-1)

And since the freeze started Nov. 14 - it appears to be kwayland5 optionally also lib32-wayland