[Unstable Update] March 2024 Edition

khotkeys(5) was discontinued.
This wont be changing.
So you need to set your shortcuts again. Thats all there is to it.

I also experience visual glitches on moving windows, but thats all it appears to be.

Dont know about the rest. I’m pretty sure window shading is present on X11.

Oops, listed kglobalaccel instead of khotkeys before @Aragorn pointed it out.
one of them is gone :sweat_smile:

1 Like

One advice after applying a major upgrade in Plasma, don’t forget to remove ~/.cache folder, and sometimes it’s better to create new user to get rid of some hard to reproduce bugs.

Yes, window shading is present on X11.

As planned, I created a timeshift backup with /home, moved to unstable and did the update with Plasma 6.

I also had to do this mkinitcpio shenanigans before the reboot. It seemed to work, as the system booted successfully.

  1. The first thing that greeted me was the humongous virtual keyboard… It turned out that the update didn’t update confs so SDDM was still pointing to old, non-existent theme, hence the fallback SDDM version. I was able to log in.
  2. latte-dock failed to launch, so I was greeted by an empty desktop. This wasn’t a surprise. I expected it to happen, but hopped that latte will perceive, since it was already compiled with some newer Plasma packages but not Plasma 6. I guess I will try to adjust the PKGBUILD and compile it again. In the meantime, I launched the default panel and default menu panel.
  3. Systray is not launching, as if it wasn’t updated… Tried to delete and add it anew, but it won’t add, because it’s not Plasma 6 compatible. Something is missing. Will investigate.
  4. I went through theming settings and set them anew.

It is working, but since my Plasma was heavy personalized, I expected some bumps in the road, and they definitely came, so it isn’t a smooth transition.

I was using Wayland before, so in this regard nothing changed, and it still works normally.

After playing with Plasma 6, I realized that the systray issue was because of my user files. I removed them, relogged the session and now it looks all right.

I had to delete a lot of my settings, because the old ones created a mess.

I expected Plasma 6 to have some kind of config script that would fix this automatically. It’s a let-down that it hasn’t. Old configs will create issues, so it’s good to delete .config and restore only those app configs that you know and let the rest default. Now I need to hunt for settings again and personalize my system, but there is no other way. Old configs had to die with Plasma 6.
Configs were not enough, some .local/share/ files were also influencing my experience, so I just went to local/share/plasma/plasmoids/ and delete most of what I had there.

This cleaned not only systray, but many other problems, that I wasn’t even aware off… like weird shadows here and there, etc.

P.S. This new overview is incredible! I had to change virtual desktops to 1 row and regular window presentation (not natural) and it works awesome with pad gestures on Wayland. Now I can finally try using virtual desktops. Previously it was too problematic. Now it’s easy to manage it with gestures on the overview screen just by swiping left/right/up/down, dragging/dropping, etc.


Hey look, it’s GNOME! :gnome: :stuck_out_tongue_winking_eye:


Yeah, that was one thing that Gnome did better. Now I can’t think of anything else…

On topic of restoring configs to defaults, how to return to bash? I just discovered that konsole is set to zsh, which I don’t like. I have no history and searching for commands is more troublesome.

This isnt really the proper place … but until these things get moved …

This has been addressed multiple times.

Plasma, or rather konsole, shell is set by the konsole profile.

1 Like

S’okay, s’alright. I appreciate you providing feedback. :+1:

By the way, I installed KDE in a VM via yesterday’s daily ISO, updated and mostly everything was okay. Yes, the Manjaro Breath themes are broken. I’ve added a note to the Known Issues in the first post.

…'course, I don’t really know what to test as KDE is an overly complicated strange beast to me. I like to keep things simple with GNOME. :man_shrugging:

In Plasma 6, libreoffice doesn’t scale correctly on 1400p monitor. The thing is, the scaling that Plasma does is doubled on LO, so we have humongous icons, text, UI. Previously it was doing OK.

OK, found the culprit, but I’m not sure how to fix it. LO opens with qt-5, hence the scaling issue.
Unfortunately, using:

env SAL_USE_VCLPLUGIN=qt6 libreoffice

is not fixing it.

Found some temporary solution. This works:

env SAL_USE_VCLPLUGIN=gtk3 libreoffice

or… use flatpack version, which is more convenient, because adding variables to LO is a PITA.

1 Like

Updating to plasma 6 broke Manjaro Breath theme.
No biggie, system still runs fine, but SDDM obv looked like a**, and icons and colors are a bit mixed up.

1 Like

Well, there is a troubleshoot section …

I’m fine, I am informing that it happened, I just use another theme.

For Plasma 6 Wayland + only AMD users

Check some issues that could be fixed manually:

1 Like

I think you mean khotkeys. :wink:

1 Like

Manjaro settings section is not present in Plasma 6 settings.

1 Like

manjaro-zsh-config might need updating, since my shell looks like this after the update. No profile or colour setting changes made the icons or text reappear

1 Like

It’s Manjaro Breath profile that’s broken, if you create a new profile it will look fine


You may need to report this here: GitHub - romkatv/powerlevel10k-media: Media files for powerlevel10k
as this might be an issue on font rendering in the terminal. @romkatv

Thanks. I tried making a new profile, but that doesn’t seem to help :thinking:
Even tried a different appearance than Breath.

@Jaypee please check:

Konsole: Open Settings → Edit Current Profile → Appearance,
click Select Font and select MesloLGS NF Regular.