[Unstable Update] January 2024 Edition

Setup KMS: NVIDIA - ArchWiki or wait for the update …

Still does not work for me in Virtualbox

EDIT: Works as it should now

1 Like

thanks for pushing 1:23.3.2-2 no mesa problems anymore. Arch, garuda, manjaro unstable booting as they should.

1 Like

3 posts were split to a new topic: Reboot and shutdown issues with recent kernels

:information_source: Making dbus-broker our default D-Bus daemon

2024-01-09 - Jan Alexander Steffens

We are making dbus-broker our default implementation of D-Bus, for improved performance, reliability and integration with systemd.

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation. Pacman will ask you whether to install dbus-broker-units or dbus-daemon-units. We recommend picking the default.

For a more detailed rationale, please see our RFC 25.


I got new error messages after updating dbus and installing dbus-broker-units (Do not worry, they are harmless. You can ignore them)

$ journalctl --no-pager -p 3 -b -3 --output=cat
Ignoring duplicate name 'org.freedesktop.Notifications' in service file '/usr/share//dbus-1/services/org.knopwob.dunst.service'
Ignoring duplicate name 'org.freedesktop.Notifications' in service file '/usr/share//dbus-1/services/org.kde.plasma.Notifications.service'
Ignoring duplicate name 'org.freedesktop.Notifications' in service file '/usr/share//dbus-1/services/org.knopwob.dunst.service'

A possible solution for KDE users:

  1. Remove all duplicate files for example: You do not need org.knopwob.dunst.service
$ sudo rm /usr/share/dbus-1/services/org.knopwob.dunst.service

However, when you update dunst, this file will be overwritten again. You can add it to NoExtract to not overwrite it, if you want. But I would not do that for some reason.

  1. But I got an error message:
Ignoring duplicate name 'org.freedesktop.Notifications' in service file '/usr/share//dbus-1/services/org.kde.plasma.Notifications.service'

This error message is related to fixing the old issue of KDE notification

Just remove the file ~/.local/share/dbus-1/services/org.kde.plasma.Notifications.service in the home directory.

  1. Reboot. Done, no more error message.

I am uncertain how to proceed as I get the following message after I chose Default (dbus-broker-units):

conflicting files:
- dbus-broker-units: /usr/lib/systemd/system/dbus.service already exists in filesystem (owned by dbus)
- dbus-broker-units: /usr/lib/systemd/user/dbus.service already exists in filesystem (owned by dbus)

I was missing dbus-daemon-units. All fixed. I apologize. I forgot to update my custom PKGBUILD


I switched to dbus-broker-units as going forward that is default. It is working fine with this as well.

I didn’t get any errors or warnings during the dbus update, but I can’t reach SDDM after reboot. Problems with amdgpu perhaps, since the monitor loses signal. Happens on both 6.6 and 6.7 kernels.
I had to Timeshift via live environment, so I lost the logs.

Edit: To clarify, I did pick dbus-broker-units when asked by pacman.


I have the same problem, I can’t reach sddm too.

“Not possible to comunicate with the configuration server
Not possible to connect: Archive or directory nonexistent”

Using kernel 6.1 happens too. Not possible to change to another tty. Not possible to shutdown.

No problems with dbus-broker here … but I replaced it shortly after install however long ago.
I also dont remember issues doing it on any longer lasting installs either though.

1 Like

Don’t know what happened, after some tries to solve this problem, none of them worked, at least was the response in the chroot, and some reboots, it back to shows SDDM.
I tried to install dbus-daemon-units but pacman ended with “not possible to complete the transaction”.

Now my system is up and running. An old processor doing things, maybe.

No issues with the default dbus selection here, although I did perform the update over TTY to be ultra-conservative. I never bothered switching from lightdm and I’ve also masked avahi-daemon.


I tried the update again today. Now I can reach SDDM, and the system appears to be fine. :person_shrugging:

Edit: I do not know how many Guild Wars 2 players are here, but the only issue I have is with this game now. Its launcher seems to cause a GPU hang on Wayland. Can’t switch to another TTY, but SysRq works.
On X11, the launcher is frozen, but still responds to input (entering password, and pressing Enter to launch the game proper etc.), and GPU isn’t hung.
An Arch user can confirm the same behaviour on two different machines, using Plasma:

Reverting today’s update with Timeshift fixes this issue.
I don’t know if this is an Arch (seems more likely) or a Proton problem. I’ve tested both official and GE versions of Proton.

Edit2: This person pinpointed the issue to pixman: Playing Guild Wars 2 on Linux - Performance optimizations and more. - Page 85 - Account & Technical Support - Guild Wars 2 Forums

1 Like

For some reason initramfs generated on my laptop for linux 6.7 is very big, and I’m sure I have no specific options for 6.7 that differ from 6.6 or 6.1. Why is it so?


If you are on btrfs, you can avoid loosing any logs, if you create a separate subvolume for the logs. (like @varlog for /var/log)

The size is absolutely ridiculous, feature ‘packed’ or not (it broke my /boot partition, I’ve had to move it to a larger one), seems it’s similar for all distros (certainly for arch and manjaro), I’m sure it’s because it’s 6.7.0 (the first official, still experimenting I guess), that’s not going to stay like that.

Just for the fallback image on my machines though (which I’ve always disabled). default image size looks fine to me.


The latest update mesa 23.3.3-1 pushed yesterday fixed the problem of running pure GTK4 and LibAdwaita apps on my laptops (intel CPUs <=gen5), and now all my installed GTK4/LibAdwaita apps work fine without any crash or graphical glitches.

On ext4, unfortunately.

When I start “SystemdGenie” (repo extra) and try to perform any action (system) in systemd:

Unable to authenticate/execute the action: 3

(even when started by sudo or pkexec)

The requester for password does not come up, the mentioned error is shown.
Using “sudo SystemdGenie” there are many complains “too many open files”
whereas “pkexec SystemdGenie” the output is not helpfull at all.

only user accounts using x11 are affected - wayland works
So I have to replace “Plank” by an other DOCK and switch to wayland…

change in qt6 / qt5 theme papirus to something else
==> otherwise “sudo SystemdGenie” from zsh output: too many open files.
Now requester comes up and app is working normal “as before”.