[Unstable Update] 2023-05-06 - GNOME 44.1

Hello community,

Another unstable branch update with some usual package updates for you.

Notable Package Updates:

Additional Info

Get our latest daily developer images now from Github: Plasma, GNOME, Xfce. You get the latest stable releases of Manjaro from CDN77.

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Unstable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-05-06

Many applications (firefox, thunderbird, etc) slow to start on desktops other than Gnome

There is a bug with xdg-desktop-portal-gnome (more details here).

Workaround for gtk-based desktops (including Xfce)
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-gtk
Workaround for KDE
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-kde
Workaround for Lxqt
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-lxqt
Workaround for desktops using hyprland
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-hyprland
Workaround for desktops using wlroots
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-wlr


Help with upgrading Python packages that were installed from AUR or PyPI

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.10.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.10/ :

pacman -Qoq /usr/lib/python3.10/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.10)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:


See also:
[HowTo] After a Python interpreter upgrade, reinstall non-working Python packages



GRUB: some backwards hardware compatibility has been restored

A modification has been reverted in order to restore support to old motherboards: [Unstable Update] 2023-02-17 - Plasma 5.27 LTS, GNOME, Python - #51 by philm

GRUB, LUKS and full disk encryption: 'no such cryptodisk found'

Following grub’s update, new configuration may be needed to be manually applied:

  • Check for modifications to /etc/default/grub
    Most notably, if you use LUKS with full disk encryption, you may need to:
    • check that GRUB_ENABLE_CRYPTODISK=y is not commented out
  • Don’t use tools like grub-customizer as it may create issues with the grub.cfg file.
  • Check if the UUID of your encrypted drive matches in your config files.
  • Based on the manual, unlike filesystem UUIDs, UUIDs for encrypted devices must be specified without dash separators. So check /boot/grub/grub.cfg for entries like cryptomount -u 3722dfb2-3b32-414b-bd59-4329fa92b6a9 and try to remove the dash separators.
  • If you modified the above configuration, you then need to update the grub menu with sudo update-grub.
  • A message “no such cryptodisk found” may appear on the following reboot, but should not prevent you from continuing by typing any key.

You may still want to have a liveUSB ready, in the rare case your bootloader does break, in which case you will need to reinstall grub.

For more details:

Info about recent NVIDIA packaging changes

[Testing Update] 2023-03-25 - Kernels, Firefox, Deepin, GNOME, NVIDIA, Wine - #42 by philm

Possible kernel fs block code regression in 6.2.3 umounting usb drives

With kernel 6.2.3 when you simply plug in a usb external drive, mount it and umount it, then the journal has a kernel Oops. A bug report, that includes the journal output was submitted at. 217174 – Plugging in usb external drive, mount and umount causes kernel Oops Discussion can be found here: Re: Possible kernel fs block code regression in 6.2.3 umounting usb drives — Linux Stable Kernel Updates

kernel 5.15.99+ Black/empty screen during boot with i915 Intel gfx. No ways to do anything

Seems there is a regression introduced with 5.15.99 kernel update: [i915]drm:add_taint_for_CI [i915]] CI tainted:0x9 by intel_gt_init+0xae/0x2d0 [i915] (#8284) · Issues · drm / intel · GitLab. My thoughts here: [Testing Update] 2023-03-11 - Kernels, Mesa 22.3.7, Phosh, LibreOffice 7.4.6 - #31 by philm

NVIDIA 530.41.03-1 high refresh rate problems

FS#77975 - [nvidia] 530.41.03-1 high refresh rate problems


Switch to the base-devel meta package requires manual intervention

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention


vlc player crashes while playing videos

A solution, regarding to rob215x, is:
VLC would crash immediately when trying to play any video. I opened VLC directly, and changed Preferences > Video > Output from “Automatic” to “VDPAU” and it works now. I found that solution on another thread but I still don’t understand the problem and why VDPAU works.


PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.

Arch Linux - News: PHP 8.2 update and introduction of legacy branch


pacman-mirrors was temporarily renamed to manjaro-mirrors (changed has been reverted)

This was done to avoid confusion with an AUR / WSL package with the same name and avoid possible breakage. It should be a seamless transition.

Sign in · GitLab You will need to rebuild any AUR Python packages that install files to site-packages. :information_source:

Print a list of them:

pacman -Qoq /usr/lib/python3.10

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.10)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.s/-/issues/183

dbus-x11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

XFCE Classic project became obsolete with the 4.18 series and is no longer required. If you still have it installed, please replace it with the normal package:

sudo pacman -S libxfce4ui

Smooth update, no repo extension or packages seem to have broken. Even pop shell is working. New bluetooth menu is really nice.


Firefox and Thunderbird start up terribly slow now. Not sure what the issue is.

edit: I’m on xfce


Same here.

I have Gnome and XFCE as login choices. Launching Firefox and Thunderbird in Gnome (Wayland) is normal and almost instantaneous. Launching in XFCE, there is a very long lag, probably 20-30 seconds.

This started happening immediately after this particular unstable update.

EDIT: I have the same setup with EndeavorOS, and the same thing is happening there.

There was an issue:
Matcha themes are “broken” / my replacement: yaru
Some gnome-shell-extensions had to be edited ==> metadata.json added “44” / everyone works now

Try to clear caches (e.g. with: Stacer)

2 posts were split to a new topic: Mutter43 and mutter are in conflict

Do you have 20230403-2 installed?

What extensions? All extensions we ship support 44.

Thank you - i missed the update…

Some by:
But the authors corrected nearly all - I was too fast…

I used Stacer and cleaned all the caches and logs too, to no avail. This is a weird bug.

Continuing the discussion from [Unstable Update] 2023-05-03 - Python 3.11, GCC 13:

Yeah let them be there man. Octopi has at least one advantage over pamac: its listing of files provided by a package is not just a bunch of text strings, it allows opening these files in text editor and file manager, for example, which is super handy.

After the latest Update I can’t login to Gnome Wayland Session. Monitor stays black (no input Signal).
In Mate Session some Apps have heavy Startup Delay, like Libre Office, Firefox, Thunderbird.

1 Like

The upgrade worked fine, but gnome 44 bluetooth quick settings is not behaving as expected.

I have two paired bluetooth devices, but quick settings only lists the last one connected so it is not possible to switch between them…

“bluetoothctl devices Paired” shows both devices correctly. They both show as disconnected in gnome bluetooth settings, yet the bluetooth quick settings only shows one of them…

Removing xdg-desktop-portal-gnome fixed the problem for me.

From the Arch forum:

[SOLVED] Some programs taking a long time to launch


Great! That solved my issues. :+1:

1 Like

Problem solved. Thanks!

1 Like

The more informative thread linked from the other one posted here
Mentions cases in which users were not on GNOME (sway, etc) and/or needed a portal for something like flatpaks.
If this is you then, as mentioned in that thread, you may wish to use a different portal, such as xdg-desktop-portal-gtk.
(For KDE users - if you use one you should have xdg-desktop-portal-kde, which does not appear affected either.)

The last 2 posts there offer some assurance that a fix is coming, as well as a suggestion to mask the offending service in the case one does not wish to uninstall.

Heres the more upstream bug stuff:

xdg-desktop-portal-gnome 44 causes delays in non-GNOME desktops (#74) · Issues · GNOME / xdg-desktop-portal-gnome · GitLab

portal-impl: Only return found implementation if it launched by jadahl · Pull Request #985 · flatpak/xdg-desktop-portal · GitHub


Great update, all is well here. Xorg + Gnome 44 + Nvidia.

to solve this:

I have added to /etc/mkinitcpio.conf:

MODULES=[lz4], then run $ sudo mkinitcpio -P

and to /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT: zswap.compressor=lz4 zswap.zpool=z3fold

Resulting in:

$ grep -r . /sys/module/zswap/parameters/

This doesnt matter, thought nobody is using swap this days.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text