[Unstable Update] 2022-11-25 - Mkinitcpio, NVIDIA, Qt, Gtk, SDL, LibreOffice, Cinnamon

bash 5.2.0 is apparently breaking makepkg:
Granted, that is for Arch but I don’t see any patches being applied to Manjaros bash build.

Seems to be downgraded in the Manjaro repos now :+1:

1 Like

Today’s updates were interrupted by:
python-cairo: /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc exists in filesystem
Seems the file was created in the system just yesterday. Had to remove/rename it to proceed.

the path looks like cache contained only.
I would try to reboot PC (in order to close all active running apps), then to remove it’s all content and to retry upgrade.

(Yes, I saw your solution with the only single file deletion in your post above, but we aware that a cache files could prevent new versions to work normally (sometimes KDE stuff could be example of it)).

New one was generated in its place. I renamed the old file, just in case.

The file was previously not part of the package, now it is.

Remove it, no need to rename it or back it up. It’s only cached compiled byte code.

EDIT: Added to the current #announcements:testing-updates wiki:

So since current version, [some / all] content of the __pycache__ path should not be removed manually cause now even those cached files are a part of current package version content? Wow.

How good is to provide cache files inside of a package? For me it looks like spamming package content with the data, which could be easily auto-generated on any user’s end.

Moreover: what content does that cached files store? It is non user-unique but shared for all users, thus it does not represent full cache state of all python applications on a user PC. So such built-in cache files could be only as a partial cache state.

To include cache files into a package installer looks like unwanted package content.

It’s actually the opposite. Compiling the byte code and including it in the package makes programs run faster.


…it can be useful when installing modules for shared use, especially if some of the users may not have permission to write the byte-code cache files in the directory containing the source code.

py_compile — Compile Python source files — Python 3.11.0 documentation

See also https://stackoverflow.com/questions/2998215/if-python-is-interpreted-what-are-pyc-files

Just in case someone did not (yet) notice here on unstable:

Those who have not a graphic card will be affected?

Everybody has a GPU implementation.
Otherwise there is no any video signal output available from a PC.

A GPU could be:
-) dedicated as inject-able module into AGP / PCI / PCIe internal ports;
-) as compact separate chip soldered down on a motherboard;
-) as iGPU - video cores integrated into a CPU chip (located on it’s substrate).

1 Like

So, I will not have h264 and h265 decode and enconde by hardware.

as iGPU - video cores integrated into a CPU chip (located in it’s substrate).

Good Morning: Today I had an issue that appears to be related to the Mesa 22.2.5-1 update. After the update, my system hung on “Finished TLP system/startup/shutdown”. I tried chroot and a few other methods to get the system up, including going to TTY and startx. It did not work.

I restored from an image dated 12/6/2022 and proceeded to update while ignoring the following and all is well again:
mesa, lib32-mesa-vdpau, vulkan-intel, mesa-vdpau, libva-mesa-driver and lib32-vulkan-intel.
I don’t see any comments from users with the same issue at this point. I just wanted to get this out there as it might be possible this is not unique to my system. Thanks. inxi below:

  Kernel: 6.0.12-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.0-x86_64
    root=UUID=c63cf222-2a4b-4818-9b5a-c77ee7eb0bdf ro ipv6.disable=1
    mitigations=off apparmor=1 security=apparmor nowatchdog nmi_watchdog=0
    udev.log_priority=3 intel_pstate=active usbcore.autosuspend=-1
  Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Portable System: Dell product: Inspiron 5520 v: A17
    serial: <superuser required> Chassis: type: 8 v: A17
    serial: <superuser required>
  Mobo: Dell model: 04G65K v: A00 serial: <superuser required>
    UEFI-[Legacy]: Dell v: A17 date: 05/17/2018
  ID-1: BAT1 charge: 48.8 Wh (100.0%) condition: 48.8/48.8 Wh (100.0%)
    volts: 12.5 min: 11.1 model: SDI DELL 04NW928L type: Unknown serial: <filter>
    status: full
  RAM: total: 7.64 GiB used: 1.49 GiB (19.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-3632QM bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 2118 high: 2195 min/max: 1200/3200 scaling:
    driver: intel_pstate governor: performance cores: 1: 2195 2: 2195 3: 2195
    4: 2195 5: 1585 6: 2195 7: 2195 8: 2195 bogomips: 35132
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov
    constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb
    ept erms est f16c flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs
    ida lahf_lm lm mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl nx
    pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pts
    rdrand rdtscp rep_good sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid x2apic
    xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: vulnerable
  Type: mds status: Vulnerable; SMT vulnerable
  Type: meltdown status: Vulnerable
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
    usercopy barriers only; no swapgs barriers
  Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: HDMI-A-1 off: LVDS-1 empty: DP-1,VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0166 class-ID: 0300
  Device-2: Suyin Laptop_Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-1.5:4 chip-ID: 064e:8126 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa dri: i965 gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.00x9.37")
    s-diag: 449mm (17.69")
  Monitor-1: HDMI-A-1 mapped: HDMI1 pos: primary
    model: HannSpree/HannStar HF199H serial: <filter> built: 2008 res: 1440x900
    hz: 60 dpi: 81 gamma: 1.2 size: 450x260mm (17.72x10.24")
    diag: 520mm (20.5") ratio: 16:9 modes: max: 1440x900 min: 720x400
  Monitor-2: LVDS-1 mapped: LVDS1 note: disabled model: LG Display 0x033a
    built: 2012 res: 1440x900 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
  API: OpenGL v: 4.2 Mesa 22.2.4 renderer: Mesa Intel HD Graphics 4000 (IVB
    GT2) direct render: Yes
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Sound API: ALSA v: k6.0.12-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000
    bus-ID: 01:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:0887
    class-ID: 0280
  IF: wlp2s0 state: down mac: <filter>
  Device-3: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a
    bus-ID: 4-3:3 chip-ID: 0b95:1790 class-ID: ff00 serial: <filter>
  IF: enp0s20u3 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  WAN IP: <filter>
  Device-1: Intel Centrino Bluetooth Wireless Transceiver type: USB
    driver: btusb v: 0.8 bus-ID: 2-1.5:3 chip-ID: 8087:07da class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.76 GiB used: 294.01 GiB (63.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS500G1B0A-00H9H0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 00WD
    scheme: MBR
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVD+-RW GT80N rev: A103
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 97.66 GiB size: 95.56 GiB (97.86%) used: 14.8 GiB (15.5%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: c63cf222-2a4b-4818-9b5a-c77ee7eb0bdf
  ID-2: /mnt/5299b066-ebf8-4757-8d68-7792f15750d1 raw-size: 186.26 GiB
    size: 182.28 GiB (97.86%) used: 130.73 GiB (71.7%) fs: ext4 dev: /dev/sda3
    maj-min: 8:3 label: Linux Data 1 uuid: 5299b066-ebf8-4757-8d68-7792f15750d1
  ID-3: /mnt/799f6b71-bc76-4840-a624-5acd5f521af6 raw-size: 173.37 GiB
    size: 169.59 GiB (97.82%) used: 148.49 GiB (87.6%) fs: ext4 dev: /dev/sda4
    maj-min: 8:4 label: Linux Data 2 uuid: 799f6b71-bc76-4840-a624-5acd5f521af6
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.46 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 7a880025-39b0-47b5-834a-14e79f0e7b45
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 1-1.3:3 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
    class-ID: ff00 serial: <filter>
  Device-2: 1-1.5:4 info: Suyin Laptop_Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 064e:8126 class-ID: 0e02
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 2-1.5:3 info: Intel Centrino Bluetooth Wireless Transceiver
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    chip-ID: 8087:07da class-ID: e001
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 3-2:2 info: Hitachi ports: 4 rev: 2.1 speed: 480 Mb/s
    chip-ID: 045b:0209 class-ID: 0900
  Hub-7: 3-2.1:3 info: Hitachi ports: 4 rev: 2.1 speed: 480 Mb/s
    chip-ID: 045b:0209 class-ID: 0900
  Device-1: 3-2.3:4 info: Logitech Keyboard K120 type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s power: 90mA
    chip-ID: 046d:c31c class-ID: 0300
  Device-2: 3-2.4:5 info: Logitech Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 046d:c077 class-ID: 0301
  Hub-8: 4-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-9: 4-2:2 info: Hitachi ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 045b:0210 class-ID: 0900
  Hub-10: 4-2.1:4 info: Hitachi ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 045b:0210 class-ID: 0900
  Device-1: 4-3:3 info: ASIX AX88179 Gigabit Ethernet type: Network
    driver: ax88179_178a interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 496mA
    chip-ID: 0b95:1790 class-ID: ff00 serial: <filter>
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2700
  Processes: 238 Uptime: 1m wakeups: 1 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1200
  libs: 342 tools: pamac Shell: Zsh v: 5.9 running-in: xfce4-terminal
  inxi: 3.3.23

Yes, Mesa-22.2.5 is bad. The game Undecember stopped to work anymore after Mesa update, it crashes after start. When I restored Mesa-22.2.4, it works.


Mesa 22.2.5 is the last update of the Mesa 22.2 series
So maybe 22.3 will be pushed in a few days…

1 Like

Same here. In unstable and testing …
But maybe “archlinux-appstream-data” was the problem I don´t know…
Downgrade mesa solved.

For me todays update broke system (in VM virtualbox).
No boot to SDDM, Kernels 5.15 5.19 6.0 6.1
Tried different things, nothings works. “Startx” get a lot of driver errors.
VideoDrives mhwd looks ok.
Only branch change to stable solved for me…
In unstable (other VM vitualbox it looks like the same …)

Probably the downgrade of mesa is the simple solution !
(See unstable)

remove kernel EOL ( kernel 5.19 )
and redo sudo mkinitcpio -P
check also if you have pacnew file ,
on /etc/mkinitcpio.conf.pacnew

5.19 is EOL, but still supported. And the problem was not the kernel.
It seems to be MESA 22.2.5.

mesa 22.2.5 is only in the unstable branch. I’ve moved your posts.

Because, obviously an EOL kernel is not getting updates and fixes anymore, it is by definition not supported (not sure where you get the idea that an EOL kernel is still “supported”, maybe you need to share your definition of “supported”), but yeah, by definition, an EOL kernel is not supported, as it is End Of Life, it is in the name. So basically, when you report issues, you don’t report them by testing on EOL kernel, it is common practices. You use the current and recommended kernels.

1 Like