[Unstable Update] 2022-04-07 - GNOME 42, Mesa 22.0.1, Octopi 0.13.0, KDE-git, Haskell

Hello community,

Another unstable branch update with some usual updates for you.

GNOME 42 is out. Find out more

  • GNOME got updated to 42. More infos about theme changes below!
  • Mesa 22 got its first stable release
  • Octopi saw a new release
  • More updates to KDE-git
  • As usual a lot of Haskell updates

Additional Info

GNOME 42 changed how theming works and other information about this release

See [Unstable Update] 2022-04-07 - GNOME 42, Mesa 22.0.1, Octopi 0.13.0, KDE-git, Haskell - #2 by Yochanan

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Annoucement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux49 4.9.309
  • linux414 4.14.274
  • linux419 4.19.236
  • linux54 5.4.188
  • linux510 5.10.109
  • linux515 5.15.32
  • linux516 5.16.18
  • linux517 5.17.1
  • linux518 5.18-rc1
  • linux515-rt 5.15.32_rt39
  • linux516-rt 5.16.2_rt19
  • linux517-rt 5.17.1_rt16

Package Updates (Thu Apr 7 08:28:14 CEST 2022)

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


:information_source: GNOME 42 has arrived! :partying_face:

Gtk 4 theming and Libadwaita
Unfortunately, there will be no custom theming available for Libadwaita applications. However, once the Libadwaita Recoloring API is implemented, we should be able to add Maia to the color palette.

I suggest installing the adw-gtk-theme from our community repo to make all Gtk applications have a matching theme. In Tweaks, set the Legacy Applications theme to Adw or Adw-dark. I recommend setting the Shell theme to Default or another shell theme you prefer that has GNOME 42 support.

To automatically switch the system theme and legacy application theme when toggling between the Light and Dark style in Settings, install the Legacy (GTK3) Theme Scheme Auto Switcher extension (gnome-shell-extension-legacy-theme-auto-switcher).

Qt application theming
For Qt application theming, we have switched back to QGnomePlatform for GNOME 42. qt5ct and qt6ct (Qt Configuration Utilities) may be marked as orphans. If you want to use QGnomePlatform with the Adwaita Qt style, you’ll need remove or comment the QT_QPA_PLATFORMTHEME variable in /etc/environment. You’ll want both qgnomeplatform and qgnomeplatform-qt6 for Qt 5 and Qt 6 applications.

New Adwaita folder icon style
If you want the new Adwaita folder icon style with Papirus, you can use papirus-folders to set it:

For example, with Papirus-Dark:

papirus-folders -C adwaita --theme Papirus-Dark

Manjaro COSMIC status
For those using the Manjaro COSMIC packages, you will need to remove them. I’ve dropped them from the repos. Once System76 finishes their new Gtk 4 applications for Pop!_OS, I’ll see about adding them.


If you’re not using GNOME

If you want to change the theme of Libadwaita applications on another Gtk desktop like Xfce or Cinnamon, you can use the following commands:

Light Adwaita theme:

gsettings set org.gnome.desktop.interface color-scheme default

Dark Adwaita theme:

gsettings set org.gnome.desktop.interface color-scheme prefer-dark

I wish I had read this announcement thread before upgrading :sleepy:

Those using dark themes will have to switch to dark mode in SettingsAppearance to get rid of that, IMO, plain default Adw light.

Tweaks in its current state does not integrate at all with gnome-shell 42, so I guess it needs to be updated once available upstream.

Pamac updates Indicator stopped working right after the upgrade and it’s throwing the following message:

Object 0x254b420269a0 is not a subclass of GObject_Object, it's a Object

I have the impression that dash-to-dock is not working as it should. At least, I noticed it’s failing to hide but I’m not 100% sure and will have to test further.

That’s what I noticed so far. Probably more to come on the way down.

What do you mean? Do you have gnome-tweaks 42beta+r9+gc66d8c3-1 installed?

Fixed with pamac-gtk 10.3.0-7.

Fixed with mutter 42.0-2.

1 Like

Now updating to mesa-22.0.1 easyeffects back to work.

PSA: This is an Annoucement thread. Posts not related to feedback about unstable updates will be moved or removed. AUR packages have nothing to do with Manjaro updates. Please post about them in #support:aur


edk2-ovmf-202202-1 breaks secure boot/bitlocker on KVM Windows guests.

manually downgrading to edk2-ovmf-202111-5-any.pkg.tar.zst temporarily fixes the issue. I’d post the links but I’m unable to.

The optional dependency

to set correct wireless channels…

should be changed/switched from crda to wireless-regdb on all Kernels which provide this

1 Like

This is still not working on my side, could anyone confirm a working indicator?

New Pamac Version is out:

PKGBUILD will be updated soon…


It worked almost perfectly for me. However, my screenshot tool is broken.
I attached a photo of my screen to show you what it does.

No extensions are enabled, it persists after a restart. Installing vanilla Arch in a VM doesn’t reproduce the issue.

Anyone has an idea how to fix it ?

1 Like

The usual crappy Gnome release indeed. Let me be clear, this has nothing to do with Manjaro devs, as you can only work within the limits of the empty shell that Gnome becomes.

The theming in Gnome-Settings is broken for Matcha-sea and seems to fallback on adwaita dark (adwaita being the ugliest and most amateur theme ever). It looks like absolute trash when compared to Matcha-sea.

Theming in Tweaks-Nautilus-SystemMonitor (etc…) is falling back to Matcha-dark-sea. Either full light or dark themes are stupid imho as there is no differenciation between titlebars and the actual content, which is “confusing” to say it politely. Gnome devs just made it more complicated and time-consuming for 3rd parties to implement decent themes. It’s a real shame they’re bunkered so far away from their user base.
In Tweaks, they even have the arrogance to call this “Legacy Applications” now instead of “GTK”. The only legacy here is their implementation, let’s be honest.

Dash-to-dock has not been updated yet and doesn’t work properly indeed. It shows but it doesn’t autohide in desktop mode and the huge playskool icon size Gnome shell original dash is unexpectedly displayed below D2D in overview mode, meaning they’re overlapping.

Finally, I think GTK theming is broken in MS Edge (any channel). No clue what it has to do with though.


I have experienced that as well. In the end I deleted all manjaro theming, now it shows correctly. I think manjaro-gdm-theme is what needs to be fixed.


I removed manjaro-gdm-theme logged out and back in it it was fixed !
Thanks ! :smile:

It works for everyone else as far as I know. Are you fully up to date? Did you restart GNOME Shell / logout?

1 Like

Yep, works for me after updating to the latest pamac-cli and pamac-gtk packages

1 Like

you are right. is done in gitlab and will be implemented with next rebuilds.


After the very last updates and an umpteenth log out/log back in, it seems at least Matcha-sea is working again (= dark titlebars/light content) at least for Gnome Tweaks, Gnome System monitor, Nautilus, Gnome-Disks, etc…

Thanks to Manjaro devs/theme designers for fixing Gnome shortcomings.

Currently broken (falling back on the disgusting adwaita theme):

  • Gnome-control-center a.k.a Settings (but pantheon switchboard fork works fine with Matcha)
  • Gnome-characters
  • Gnome Calculator
  • Gnome-Calendar
  • Gnome-Contacts
  • Gnome Extensions
  • Gnome-Clocks
  • Sound Recorder
  • Gnome Weather
  • Some indicators settings

Yep, I mean gnome-tweaks won’t let you switch themes for the shell (I get an exclamation mark in the UI). I believe this is due to the fact that the shell now depends on GTK4 (which forces users to choose only the Default themes in Settings → Appearance).

On the other hand, Tweaks is a GTK3 app, which might explain the above behaviour (Apologies if I’m wrong, not an expert on this matter).

Do you know any GTK4 theming out there available right now? :thinking:

1 Like

I can pick any theme in Gnome Tweaks, either for the “(Non) Legacy Applications” (=GTK) or the shell.
The weird thing is even with Matcha-sea selected I can also change from light to dark in Settings → Appearance and it actually applies for the new legacy GTK4 apps inheriting adwaita.