[Unstable Update] 2020-12-02 - BREAKAGE EXPECTED - Python 3.9, Nvidia driver simplification, KDE-git

Hello community,

Another unstable branch update with some usual updates for you!

Deepin Nibia 20.2-pre1 can be tested now! #stayhome, #staysafe, #stayhealthy

  • Python 3.9 update rolled in. It might take a while until we have rebuild our packages as needed. We recommend to switch to testing branch if you need a working system
  • KDE-Git packages got updated as usual
  • We simplified Nvidia driver installation

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Nibia 20.2 release candidate! KDE, XFCE and Gnome

Our current supported kernels

  • linux44 4.4.246
  • linux49 4.9.246
  • linux414 4.14.209
  • linux419 4.19.160
  • linux54 5.4.80
  • linux57 5.7.19 [EOL]
  • linux58 5.8.18 [EOL]
  • linux59 5.9.11
  • linux510 5.10-rc6
  • linux54-rt 5.4.78_rt44
  • linux59-rt 5.9.1_rt19

Packages Changes (Wed Dec 2 09:16:47 CET 2020)

  • unstable core x86_64: 22 new and 21 removed package(s)
  • unstable extra x86_64: 293 new and 293 removed package(s)
  • unstable community x86_64: 2089 new and 2089 removed package(s)
  • unstable community x86_64: 25 new and 25 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


pacman-mirrors is broken.

Traceback (most recent call last):
  File "/usr/bin/pacman-mirrors", line 20, in <module>
    from pacman_mirrors import pacman_mirrors
ModuleNotFoundError: No module named 'pacman_mirrors' 

A potential list of packages needed a rebuild can be found here.

1 Like

Only problem I ran into was:

installing python (3.9.0-1) breaks dependency ‘python<3.9’ required by pkgbrowser

So I uninstalled pkgbrowser, and everything else updated.

Something seems to be wrong with the new pacman-mirrors 4.18.2-2 package.

Upgrading pacman-mirrors (4.16.4-2 -> 4.18.2-2)...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Configuring pacman-mirrors ...
/usr/share/libalpm/scripts/pacman-mirrors-upgrade: line 3: pacman-mirrors: command not found
hint: use `pacman-mirrors` to generate and update your pacman mirrorlist.
Transaction successfully finished.

pacman-mirrors 4.18.2-2 misses the actual pacman-mirrors script :roll_eyes:

$ pacman -Ql pacman-mirrors
pacman-mirrors /usr/
pacman-mirrors /usr/share/
pacman-mirrors /usr/share/libalpm/
pacman-mirrors /usr/share/libalpm/hooks/
pacman-mirrors /usr/share/libalpm/hooks/pacman-mirrors-install.hook
pacman-mirrors /usr/share/libalpm/hooks/pacman-mirrors-upgrade.hook
pacman-mirrors /usr/share/libalpm/scripts/
pacman-mirrors /usr/share/libalpm/scripts/pacman-mirrors-install
pacman-mirrors /usr/share/libalpm/scripts/pacman-mirrors-upgrade
[computer@manjaro-pc ~]$ pacman -Qdt
mhwd-nvidia-340xx 340.108-1
mhwd-nvidia-418xx 418.113-1
mhwd-nvidia-430xx 430.64-1.0
mhwd-nvidia-435xx 435.21-1.0
mhwd-nvidia-440xx 440.100-1
mhwd-nvidia-450xx 450.80.02-1
mhwd-nvidia-455xx 455.45.01-1
[computer@manjaro-pc ~]$ sudo DIFFPROG=meld pacdiff
[sudo] password di computer: 
==> pacsave file found for /etc/pacman-mirrors.conf
==> WARNING: /etc/pacman-mirrors.conf does not exist
rm: rimuovere file regolare '/etc/pacman-mirrors.conf.pacsave'? n
==> pacnew file found for /etc/systemd/homed.conf
:: (V)iew, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/s/r/o/q] V
:: (V)iew, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/s/r/o/q] R
[soong@soong-dell ~]$ sudo pacman-mirrors --fasttrack && sudo pacman -Syyu
[sudo] heslo pro soong: 
Traceback (most recent call last):
  File "/usr/bin/pacman-mirrors", line 20, in <module>
    from pacman_mirrors import pacman_mirrors
ModuleNotFoundError: No module named 'pacman_mirrors'

tlpui needs to be rebuild.

pacman-mirrors is ok now with -3

Can confirm, pacman-mirrors 4.18.3-1 fix the issue.

python 3.9.0-1 also breaks menulibre, uninstalled and everything is fine. almost one year using unstable branch and no breakages at all :tada: :confetti_ball:

1 Like

Was already updated in the meantime (2.2.1-3). Working fine here.

1 Like

@philm not sure if you missed it but calamares is still looking for python8 and so will not launch.

METoo - > looks like python 3.9 breaks everything
sudo pacman-mirrors --api --set-branch testing
casts error:
Traceback (most recent call last):
File “/usr/bin/pacman-mirrors”, line 28, in
File “/usr/lib/python3.9/site-packages/pacman_mirrors/pacman_mirrors.py”, line 93, in run
cliFn.parse_command_line(self, gtk_available=GTK_AVAILABLE)
File “/usr/lib/python3.9/site-packages/pacman_mirrors/functions/cliFn.py”, line 325, in parse_command_line
api_handler.set_config(self, set_pfx=args.prefix,
File “/usr/lib/python3.9/site-packages/pacman_mirrors/api/api_handler.py”, line 67, in set_config
util.i686_check(self=self, write=False)
AttributeError: module ‘pacman_mirrors.functions.util’ has no attribute ‘i686_check’
Set branch manually to testing in /etc/pacman-mirrors.conf and /etc/pacman.d/mirrorlist
EDIT. system working again after TTY 3 pacman -Syyuu
EDIT2: “We recommend to switch to testing branch if you need a working system” :cool:

1 Like

Fixed with 4.18.4-1


Bug report from @GaVenga is not fixed get the error on the latest version.
pacman-mirrors —version print wrong version




Not Confirmed!

Some Python libraries from AUR needs to be rebuilt manually. For me, they are python-numpy-mkl and python-pymunk. Note that the check process of python-numpy-mkl would fail when numpy for Python 3.9 is not installed, but a recent comment on AUR (en) - python-numpy-mkl provides a solution.

BTW, the Chinese mirrors got me into a partially updated state, where some Python-related packages are not rebuilt against Python 3.9. I had to use an Australian mirror to get these packages updated. :sweat_smile:

Argh :man_facepalming: - forgot to push to master branch - only pushed my working branch

And that is now fixed - and with a little extra I have worked on

[4.19] 2011-12-02

  • enhanced -c/--country argument
    • countries can be specified using country code or country name
    • further enhanced argument to accept lower case (any casing is accepted)
    • country specifications can be a mix of country code and country name
    • duplicate countries are removed