[Unstable Update] 2020-09-13 - Kernels, Qt 5.15.1, Browser, Pamac

Krusader does not start because of conflicting QT-libraries, some other apps do the same.
(12.09.2020) - I reverted to testing.

I had kvantum style selected in qt5ct. Error:

Cannot mix incompatible Qt library (5.15.0) with this library (5.15.1)

installed qt5-styleplugins (
and did the update “unstable” again (13.09.2020):
Krusader works again.

1 Like

I haven’t ran the update yet, but people on Arch are reporting massive issues after the qt5 update to 5.15.1, and I know some of them seem to be solved here, but the multi-monitor one mentioned on reddit (why can’t we post links here?) isn’t mentioned in this thread. I suppose I can update and maybe downgrade if I encounter issues, but I have to have dual-monitor functionality so it’ll be a PITA if it’s borked. Someone here mentioned that qt5-base is on 5.15.1-3 in the repos, but my update is only showing 5.15.1-1. Fingers crossed, will report back.

Weird, I’m on qt5-base 5.15.1-1 and I don’t have the issue others are talking about with dual monitors. Awesome. Anyways, fully updated, everything is fine (except obviously the gparted bug which I bisected and reverted).

Discussing that question would be very off-topic for this thread, but maybe just a little off-topic would be to suggest that, if you cannot post a link, simply paste it in your post, then highlight it, then click the preformatted text icon (</>)

gparted issue is fixed with 5.8.9-2 (xfce)


One more strange issue is Plasma has begun half-loading on a separate display: laptop’s one loads fine on startup, but the external one shows only Latte dock and top panel, the remaining space is simply black and doesn’t react to right-clicks, for example. Restarting Plasma manually makes it load properly, but on the next login I see the same behavior. Reproducible with another user’s account (test acc, default settings).


Problems for me too on a triple monitor setup, I have a black box on the wallpaper, and I can’t see and reach the icons on the top of the desktop, the notification appears on the left top angle of the center monitor instead of the top right, even the startup splash screen seems to be off center.

Are you sure?
Phil’s top post links to: https://gitlab.manjaro.org/-/snippets/541/raw
and I see:

 qt5-base             5.15.0-5             5.15.1-1

Which matches mine in unstable KDE-Dev:

$ pacman -Qi qt5-base
Name            : qt5-base
Version         : 5.15.1-1
Description     : A cross-platform application and UI framework
Architecture    : x86_64
URL             : https://www.qt.io
Licenses        : GPL3  LGPL3  FDL  custom
Groups          : qt  qt5
Provides        : None
Depends On      : libjpeg-turbo  xcb-util-keysyms  xcb-util-renderutil  libgl  fontconfig
                  xdg-utils  shared-mime-info  xcb-util-wm  libxrender  libxi  sqlite
                  xcb-util-image  mesa  tslib  libinput  libxkbcommon-x11  libproxy  libcups
                  double-conversion  md4c  icu
Optional Deps   : qt5-svg: to use SVG icon themes [installed]
                  qt5-wayland: to run Qt applications in a Wayland session [installed]
                  qt5-translations: for some native UI translations [installed]
                  postgresql-libs: PostgreSQL driver
                  mariadb-libs: MariaDB driver
                  unixodbc: ODBC driver
                  libfbclient: Firebird/iBase driver
                  freetds: MS SQL driver
                  gtk3: GTK platform plugin [installed]
                  perl: for fixqt4headers and syncqt [installed]
Required By     : appstream-qt  attica-git  bluez-qt-git  breeze-gtk-git  karchive-git
                  kcodecs-git  kconfig-git  kcoreaddons-git  kdnssd  kdsoap  kholidays-git
                  kitemmodels-git  kitemviews-git  kjs  kuserfeedback-git  kwayland-server-git
                  kwidgetsaddons-git  libaccounts-qt  libdbusmenu-qt5  libkdcraw  libkexiv2
                  manjaro-settings-manager  modemmanager-qt-git  networkmanager-qt-git  octopi
                  packagekit-qt5  phonon-qt5  polkit-qt5  poppler-qt5  prison-git
                  pulseaudio-qt  python-pyqt5  qca  qt5-declarative  qt5-multimedia  qt5-script
                  qt5-sensors  qt5-svg  qt5-tools  qt5-translations  qt5-x11extras  qtermwidget
                  signond  solid-git  sonnet-git  syntax-highlighting-git  threadweaver-git
Optional For    : avahi  cmake  libde265  openal  pinentry  v4l-utils
Conflicts With  : qtchooser
Replaces        : None
Installed Size  : 64.06 MiB
Packager        : Bernhard Landauer <oberon@manjaro.org>
Build Date      : Sat 12 Sep 2020 10:57:56 AM EDT
Install Date    : Sun 13 Sep 2020 05:41:43 PM EDT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

yakuake has a white background now…

Dark as ever on my end. Did you try re-applying profiles and/or background color settings?


re-applying the breeze profile as in my Konsole fixed it
(no breath2 here)

gparted issue is fixed with 5.8.9-2 (GNOME)

1 Like

yes i am sure that this was the case.
however, it no longer is.

therefore, i have downgraded to the official version as well:

1 Like

Yeah. -3 was there for like 30 minutes. Then it was set back to -1

1 Like

probably a packaging error.

but if an important package is broken, i do not mind such a thing. and after all - it was corrected later.

All good. I didn’t want to complain but just explain what happened :wink:

I think it was just that Bernhard forgot to put it pkgrel back to 1 when updating the PKGBUILD and then quickly fixed it and set it to 1 while 3 already hit the repos (if I would be doing it, this would happen to me all the time I guess :joy: )

1 Like


whats about Gnome 3.38 :innocent:

I think, expressed in german: “Niemand hat vor, Gnome 3.38 einzuführen…”

With the latest version of vulkan-icd-loader and lib32-vulkan-icd-loader games now crash on start. On arch repos there is a new version available, this version fix the problem.

1 Like

It’s fixed with 1.2.153-2.

1 Like

I appear to have run into some mkinitcpio trouble with the latest kernel images. The vmlinuzs aren’t copied into /boot for some reason? See:

error ouput

==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: ‘default’
-> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64.img
==> ERROR: specified kernel image does not exist: /boot/vmlinuz-5.4-x86_64' ==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'fallback' -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64-fallback.img -S autodetect ==> ERROR: specified kernel image does not exist: /boot/vmlinuz-5.4-x86_64’
==> Building image from preset: /etc/mkinitcpio.d/linux58.preset: ‘default’
-> -k /boot/vmlinuz-5.8-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.8-x86_64.img
==> ERROR: specified kernel image does not exist: /boot/vmlinuz-5.8-x86_64' ==> Building image from preset: /etc/mkinitcpio.d/linux58.preset: 'fallback' -> -k /boot/vmlinuz-5.8-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.8-x86_64-fallback.img -S autodetect ==> ERROR: specified kernel image does not exist: /boot/vmlinuz-5.8-x86_64’

I checked pacman.log, 90-mkinitcpio-install.hook did indeed run before attempting to build the images. cryptsetup, mkinitcpio, linux54, linux58, and sudo were all updated with this run. Trying to reinstall them isn’t helping…