Unregistered Authentication Agent for unix-process

Registered Authentication Agent for unix-process:681182:16398539 (system bus name :1.27419 [/usr/bin/pkttyagent --process 681182 --notify-fd 4 --fallback], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)

Unregistered Authentication Agent for unix-process:1594:1911 (system bus name :1.63, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)

These are the full error logs. (mind you, these are from two different instances. But the first Registered log is always immediately followed by an Unregistered log. Both the system bus names and PIDs match between the logs)

Recently, I’ve noticed this filling up my journal. And randomly, My screensaver would launch which I’ve set with swayidle whenever I run some command. Its very random. I can’t also run flatpak search [somepackage]. It would always hang and emit this:

Registered Authentication Agent for unix-process:1527:1878 (system bus name :1.57 [flatpak list --columns=application], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)

Which would again be followed by
Unregistered Authentication Agent for unix-process:9512:68661 (system bus name :1.373, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)

I run hyprland WM but I also have GNOME installed. I think this is a problem with my authentication agent as I cannot mount my Windows dual boot partitions in nautilus either. It results in not authorised to perform action while works fine in GNOME with an authentication popup