Unread notifications tray icon not showing

Usually there is an icon for unread notifications. If I download a file in internet browser, for example, I should see this icon. Now icon doesn’t show, can only be seen in hidden part of system tray along with other icons that aren’t currently being used (like Caps Lock indicator or a menu for removable drives when there are none). It always shows 0 unread notifications like if KDE considered all of them read by default, but at least notifications about downloaded files are present there. If I turn on Do Not Disturb mode, icon does show in tray.
Before I noticed it I installed and removed ibus-anthy. But since it’s about keyboard input I’m not sure if that can be the reason for described behavior

Probably changed by an update. I think I’ve had this happen. Does going to “System Tray Settings” “Entries” and changing it to “Always Shown” not bring it back?

Thanks. I was only searching in notification settings and forgot about tray settings. Just like turning on Do Not Disturb it makes the icon appear. Indication of unread notifications still doesn’t work, but since they seem to be getting collected just fine it’s not that big of a deal I guess

Just as a tip, I have disabled the notifications icon in the System Tray, and instead I have a Notifications widget on the panel itself. That way, it’s always visible. :wink:

That gives the same result as toggling notifications to be always seen. But notifications still don’t stay unread. From what I’ve seen only notification about graphics restart after waking PC from waiting mode is marked as unread, all others are counted as read by default. That’s not critical, but it’s a weird behavior

You’ll have to go through the individual settings of the notifications pages to enable or disable them. Some things don’t have any finer controls while others do, and some notifications are application-specific, while others might be Plasma-specific.

I’ve checked individual apps notifications settings and they seem to be fine, they all have saving in history and messages counter toggled on. Can’t see anything else that could lead to observed effect.
I also noticed another notification that counts as unread for some reason. It’s a notifier about a message received on this forum. Other notifications from the same browser (Brave) are marked as read by default, just like the most other messages from different apps

The only thing I can suggest then is to log out of Plasma completely — you have to be looking at the login screen — and to then switch to a tty, log in there (as yourself), and delete the contents of your ~/.cache folder, like so… :point_down:

rm -rf ~/.cache/*

Make sure you do not delete the folder itself. Then, switch back to the login screen and reboot.


Repeated these instructions. It didn’t fix this behavior, notifications are still read by default

Just for the record, have you also cleaned out any remnants of that in your home directory?

No. Should I?

Well, for proper home directory hygiene, you should, yes. :slight_smile:

List of files that package contains doesn’t show any /home entries, all of them are in /usr

This is normal, but you should still check your home directory for any user-specific configuration files left over after the package was removed. This includes anything related to the package under the Autostart category of Plasma.

I found the config file for ibus-daemon and several empty directories with that name in other apps’ files.
In system settings nothing associated with ibus is toggled to autostart. ~/.config/autostart contains nothing associated with ibus either

Okay, so remove all of that old stuff and reboot. :wink:

Now notifications from Spectacle and seemingly most other apps are working as intended, only with a small delay (maybe supposed to be there?). Notifications about downloaded files in Brave still count as read by default

Then you’ll have to go over the notification settings for brave again, and maybe repeat the step of emptying ~/.cache/* from a tty while completely logged out of Plasma.

The devil is in the details. :wink:

I double checked the settings and deleted everything from ~/.cache/ again, but to no effect

Well, I can’t offer you any more help with that — I don’t use brave — but at least it’s now working again for everything else. So I’d say that your problem is solved, and that it’s obvious that brave is the application at fault here. :man_shrugging: