"Unkown terminal" error after update to Manjaro Mikah

Hi everyone,

After updating my system to Manjaro Mikah, I experience the following problem:

When using any terminal (have tried with gnome-terminal and urxvt) and SIGINT is sent (Ctrl + C) I get the following error message in my terminal (this one for gnome-terminal):

output: unknown terminal “xterm-256color”

and the “xterm-256color” holds whatever is written to $TERM, for urxvt it is “rxvt-unicode-256color” .

When searching this error message online I only find threads concerning terminal issues when ssh’ing, and they advise to change $TERM, but in my case I’m on my local system, and changing $TERM to another value, eg “export TERM=linux” will just change the error to 'output: unknown terminal “linux” ’

Does anyone know what’s going on here?

On a potential sidenote: after rebooting from update I also experienced the problem that my GUI failed to start up due to some nvidea drivers issues which I could solve , so perhaps this could be linked (however I don’t see the connection between my terminal and the nvidia drivers)

1 Like

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…
  1. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
  2. Do you also get the output: unknown terminal “xterm-256color” error when you create a new user and log in there?

:innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have, …

  1. Here is my output to inxi:
~ inxi --admin --verbosity=7 --filter --no-host --width
tput: unknown terminal "xterm-256color"
tput: unknown terminal "xterm-256color"
Argument "" isn't numeric in numeric eq (==) at /usr/bin/inxi line 387.
System:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=7b9a0c0f-3b65-4a3b-ac35-c89c93c4caa5 rw quiet apparmor=1 
  security=apparmor resume=UUID=44c3553f-5fb8-4c9c-9cea-080d71984e7d 
  udev.log_priority=3 
  Desktop: i3 4.18.2 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X712FBC_S712FB 
  v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X712FBC v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X712FBC.302 date: 10/18/2019 
Battery:
  ID-1: BAT0 charge: 40.3 Wh condition: 42.3/47.0 Wh (90%) volts: 11.8/11.8 
  model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Discharging 
  cycles: 80 
Memory:
  RAM: total: 15.49 GiB used: 1.35 GiB (8.7%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: C (12) microcode: D6 
  L2 cache: 8192 KiB bogomips: 36812 
  Speed: 900 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 
  4: 900 5: 900 6: 900 7: 900 8: 900 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc 
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms 
  est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr 
  nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni 
  popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss 
  ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc 
  tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
  xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:9b41 
  Device-2: NVIDIA GM108M [GeForce MX110] vendor: ASUSTeK driver: nouveau 
  v: kernel alternate: nvidia_drm,nvidia bus ID: 02:00.0 chip ID: 10de:174e 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-6:2 chip ID: 13d3:56dd serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: compton driver: modesetting 
  unloaded: intel,nouveau alternate: fbdev,nv,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 128 size: 382x215mm (15.0x8.5") 
  diag: 438mm (17.3") 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.8 
  direct render: Yes 
Audio:
  Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:02c8 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lite-On driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: 3000 
  bus ID: 03:00.0 chip ID: 10ec:c822 
  IF: wlo1 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: docker0 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 1.38 TiB used: 65.15 GiB (4.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 002C scheme: GPT 
  ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-80Z10T2 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 1A04 scheme: GPT 
  Message: No Optical or Floppy data was found. 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / raw size: 500.00 GiB size: 491.15 GiB (98.23%) 
  used: 65.15 GiB (13.3%) fs: ext4 dev: /dev/sda3 label: N/A 
  uuid: 7b9a0c0f-3b65-4a3b-ac35-c89c93c4caa5 
  ID-2: /boot/efi raw size: 513.0 MiB size: 512.0 MiB (99.80%) 
  used: 316 KiB (0.1%) fs: vfat dev: /dev/sda1 label: N/A uuid: F38D-4A2F 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 24.00 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda2 label: N/A uuid: 44c3553f-5fb8-4c9c-9cea-080d71984e7d 
Unmounted:
  ID-1: /dev/nvme0n1p1 size: 260.0 MiB fs: vfat label: SYSTEM uuid: 64DC-4CBB 
  ID-2: /dev/nvme0n1p2 size: 16.0 MiB fs: <superuser/root required> label: N/A 
  uuid: N/A 
  ID-3: /dev/nvme0n1p3 size: 476.03 GiB fs: ntfs label: OS 
  uuid: A676DE2176DDF253 
  ID-4: /dev/nvme0n1p4 size: 650.0 MiB fs: ntfs label: RECOVERY 
  uuid: 3C7207B672077444 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 1-6:2 info: IMC Networks USB2.0 HD UVC WebCam type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 13d3:56dd 
  serial: <filter> 
  Device-2: 1-10:3 info: Lite-On Bluetooth Radio type: Bluetooth driver: btusb 
  interfaces: 2 rev: 1.0 speed: 12 Mb/s chip ID: 04ca:4005 serial: <filter> 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 37.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 286 Uptime: 4h 13m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  alt: 8/9 Packages: 1294 pacman: 1291 lib: 311 snap: 3 Shell: fish v: 3.1.2 
  running in: gnome-terminal inxi: 3.1.05
  1. I tried creating a new user and logging in to there, and here I don’t get this problem, so the problem must be somewhere in my configurations, but where… :sweat_smile:

EDIT: I also found out that when I type reset, I get this output:

~ reset
reset: can't initialize terminal type xterm-256color (error -1)
Terminal type?    
  1. Yup, as I suspected: your bash terminal settings are wrong. Did you edit your .bashrc or .bash_profile files recently?
  2. If you don’t remember, or cannot find what you did, we’ll be copying all your files from the “bad” account into the “good” account, leaving the mess you got yourself into old one disabled, but not deleted.

:stuck_out_tongue_winking_eye:

I found the issue: the difference between my new user and me was that the new user uses bash, while I commonly use fish.

I then found out I dont have to problem with bash, only with fish.

After shotgun debugging my config.fish file I found that this line caused the failure:

set -gx PATH /opt/anaconda/bin $PATH

So something in my /opt/anaconda/bin file must be causing this strange behaviour.

I don’t know why, I removed this line out of my config and I’m happy that I got rid of the error :slight_smile:

That is good under DOS and Windows but wrong under Linux…

It should read:

set -gx PATH /opt/anaconda/bin:$PATH

(a colon, not a space)

:stuck_out_tongue_winking_eye:

I think it’s just specific fish syntax because according to their documentation you have to do it like that. For some reason I can’t share links otherwise I would share the link to the documentation page of fish where they explain it. :slight_smile:

Thanks for helping me!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.