Unknown folder appears suddenly in home folder called "go"

Today as I was browsing through my drive, I stumbled across a certain folder with the name “go”. The creation date of that folder is 4th January 2024. The folder has many files and it has in total 515 megabytes. I am absolutely sure that I did not create this folder, but it is possible that it was created by some other application during the pamac update which was perhaps performed at the beginning of this year (although I am not completely sure about the date).

When I go to my pamac and search for “go” or “crypto” or “golang.org” which often repeats in the file names within that folder, I do not see that any package with such names was installed on my laptop. I will attach 2 screenshots of what I see in my thunar File Explorer, as well as a text file that contains the recursive listing of all files within that folder. There are too many files within that folder to paste them all it in this message.

Does anybody recognize what this “go” folder could be? Is that some legitimate software that some other application has installed, or do I have a reason for concern regarding hacking?

I have found even a PDF file within one of the deeper folders in that folder which has the title go cryptography. Does that ring any bells?

go folder2c

Can you switch to details view and show the content of the folder go ?

I can, but it doesn’t reveal too much because the first folder that you come across at when you go deeper is called “pkg”, and there is nothing else except that folder. And then you have to enter the “pkg” and you run into folder called “mod” and then finally within mod you can find more folders and I will submit the screenshot of that folder. But please note that there are many many other folders and files deeper within.

I will submit the text file that contains the recursive listing of all folders from the terminal. I don’t know how to attach a text file in this message so I will upload it to my server. But rest assured its just a text file.

Listing of all files within go folder


By the way, I have two older installations of manjaro on this laptop on different partitions, and none of them contain the “go” folder. So if it is a legitimate part of some other software, it has to be a very recent thing.

Hi @Antarmanu71,

Check the owner of the directory with pacman to see it it was created by pacman:

pacman -Qo /go

I just updated the topic title as the “go” folder is in the OP’s home, not root, folder.


Here it is, and it doesn’t look good.

[ben85@ben85-inspiron3521 go]$ sudo pacman -Qo /go
[sudo] password for ben85:

error: No package owns /go

Then I wonder how it appeared. You can always rename it, or move it temporarily and see what, if anything, complains, and delete it in a week, or moth’s time permanently.

Here should be more info about it in the XDG Base Directory’s:

I wonder how it appeared, too. The best explanation that I can find is that some time during last summer I tried to install several Android emulators, among which was Android Studio. And now while searching the internet I can see several websites where Android studio and “go package” are mentioned together, so it is maybe possible that when I tried to install Android studio the go package was installed as well.

As far as I remember, Android studio was an AUR package, and its installation lasted for the whole eternity, so after about one day I stopped the installation without the package being actually installed. Would an additional package (such as go package) be installed in such a case when the installation of the original AUR package (in this case Android studio) was cancelled? Also, does anybody know if the go package actually gets installed automatically along with Android studio?

But even if this explains the origin of that go package, the date is completely wrong. I messed with those Android emulators last summer and none of them was left installed on my laptop. Why would this go package be updated if no other software requires it or owns it? Would pamac update the go package in such a case?

Here I found some more information about the go package:


When I type into the terminal “go help” it treats go as a regular command and gives the help for that command. However if I type “go packages” it returns " unknown command" error.

You built a AUR package with the Go programming language. Only you know which package you installed.

You can safely delete this directory, if necessary, it’s re-created automatically.


This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.